aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2006-01-14 11:24:03 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2006-01-14 11:24:03 +0800
commit813169fa865526bdc4c38e386a37e6c44b7a1694 (patch)
treea63ec97efb3be3f27d2f0c8efb4e5aad7b1630ae
parentfc9f03f43aa3983a8a18dc2d474969636d095bd1 (diff)
downloadfreebsd-ports-gnome-813169fa865526bdc4c38e386a37e6c44b7a1694.tar.gz
freebsd-ports-gnome-813169fa865526bdc4c38e386a37e6c44b7a1694.tar.zst
freebsd-ports-gnome-813169fa865526bdc4c38e386a37e6c44b7a1694.zip
- Convert to USE_GECKO [1]
- Convert to USE_SQLITE [2] PR: 89023 [2] Submitted by: mezz [1], Scot Hetzel <swhetzel@gmail.com> [2]
-rw-r--r--deskutils/mcatalog/Makefile29
1 files changed, 7 insertions, 22 deletions
diff --git a/deskutils/mcatalog/Makefile b/deskutils/mcatalog/Makefile
index 5631b85b42b9..24af2be72c10 100644
--- a/deskutils/mcatalog/Makefile
+++ b/deskutils/mcatalog/Makefile
@@ -3,7 +3,7 @@
# Whom: Mezz <mezz@FreeBSD.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.9 2005/10/22 06:02:34 tmclau02 Exp $
+# $Id: Makefile,v 1.12 2006/01/11 00:29:46 tmclau02 Exp $
#
PORTNAME= mcatalog
@@ -18,22 +18,13 @@ COMMENT= An application for catalogue films and books
BUILD_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
${X11BASE}/libdata/pkgconfig/evolution-sharp.pc:${PORTSDIR}/mail/evolution-sharp \
${X11BASE}/libdata/pkgconfig/gecko-sharp-2.0.pc:${PORTSDIR}/www/gecko-sharp20
-LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite2
RUN_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
${X11BASE}/libdata/pkgconfig/evolution-sharp.pc:${PORTSDIR}/mail/evolution-sharp \
${X11BASE}/libdata/pkgconfig/gecko-sharp-2.0.pc:${PORTSDIR}/www/gecko-sharp20
-.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
-.else
-.if ${WITH_MOZILLA}=="firefox"
-MOZILLA= firefox
-.else
-MOZILLA= mozilla
-.endif
-.endif
-
+USE_GECKO= mozilla firefox
USE_GNOME= gnomeprefix gnomehack gconf2 intlhack
+USE_SQLITE= 2
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_AUTOTOOLS= libtool:15
@@ -43,20 +34,12 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
GCONF_SCHEMAS= mcatalog.schemas
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} " By default ${PORTNAME} uses www/mozilla for html rendering, but you can"
- @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " firefox "
- @${ECHO_MSG} ""
-
post-patch:
@${REINPLACE_CMD} -e 's|/pixmaps/mcatalog|/pixmaps|g' \
${WRKSRC}/images/Makefile.in
@${REINPLACE_CMD} -e 's|@prefix@/share|${PREFIX}/share/gnome|g' \
${WRKSRC}/mcatalog.desktop.in
- @${REINPLACE_CMD} -e 's|%%MOZILLA%%|${X11BASE}/lib/${MOZILLA}|g' \
+ @${REINPLACE_CMD} -e 's|%%MOZILLA%%|${X11BASE}/lib/${GECKO}|g' \
${WRKSRC}/src/mcatalog.in
.ifndef (NOPORTDOCS)
@@ -68,4 +51,6 @@ post-install:
.endif
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+.include <bsd.port.post.mk>