aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-04-30 16:40:19 +0800
committerale <ale@FreeBSD.org>2007-04-30 16:40:19 +0800
commit83f7e29e4682f2c66fc72464ec6c6ee1c0b7469d (patch)
tree5fd9abc7b4b6f800c50054b0c2dea7152939642d
parent0aaa2edfd969b927619377506b9d9c9abd82a7a1 (diff)
downloadfreebsd-ports-gnome-83f7e29e4682f2c66fc72464ec6c6ee1c0b7469d.tar.gz
freebsd-ports-gnome-83f7e29e4682f2c66fc72464ec6c6ee1c0b7469d.tar.zst
freebsd-ports-gnome-83f7e29e4682f2c66fc72464ec6c6ee1c0b7469d.zip
- Update to 1.5.3 release [1]
- Fix pecl command execution [2] PR: ports/110209 [2] Submitted by: miwi [1], chinsan [2]
-rw-r--r--devel/pear/Makefile5
-rw-r--r--devel/pear/distinfo6
-rw-r--r--devel/pear/files/patch-go-pear36
3 files changed, 14 insertions, 33 deletions
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
index 83afaa2856b7..a36de38a1137 100644
--- a/devel/pear/Makefile
+++ b/devel/pear/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pear
-PORTVERSION= 1.5.0
-PORTREVISION= 1
+PORTVERSION= 1.5.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ale
@@ -28,5 +27,7 @@ post-patch:
do-install:
@${LOCALBASE}/bin/php -q ${WRKSRC}/go-pear
+ @${SED} -i "" "s|<?php|<?php dl('pcre.so'); dl('xml.so');|" \
+ ${PEARDIR}/peclcmd.php
.include <bsd.port.mk>
diff --git a/devel/pear/distinfo b/devel/pear/distinfo
index 2cd8d00f7655..531f2551138d 100644
--- a/devel/pear/distinfo
+++ b/devel/pear/distinfo
@@ -1,3 +1,3 @@
-MD5 (pear-1.5.0.tar.bz2) = b0b026789911b75464bc5e83e1b8f5f7
-SHA256 (pear-1.5.0.tar.bz2) = 7ce4229e606af74c7027c305022372eafe50db99d2f99570ac647c7da44fe416
-SIZE (pear-1.5.0.tar.bz2) = 291923
+MD5 (pear-1.5.3.tar.bz2) = 87a9eb45ae8aedbb6d6f69528598e47f
+SHA256 (pear-1.5.3.tar.bz2) = af5b12e849c9f06cb5396289bd4f43aa0a5a0d6f8cfc8271b462bb7c149774f3
+SIZE (pear-1.5.3.tar.bz2) = 287609
diff --git a/devel/pear/files/patch-go-pear b/devel/pear/files/patch-go-pear
index ec2ebe01ea63..ddd3e4b1134f 100644
--- a/devel/pear/files/patch-go-pear
+++ b/devel/pear/files/patch-go-pear
@@ -1,5 +1,5 @@
---- go-pear.orig Tue Feb 6 18:30:15 2007
-+++ go-pear Wed Feb 7 16:00:44 2007
+--- go-pear.orig Fri Apr 27 23:07:03 2007
++++ go-pear Mon Apr 30 10:15:47 2007
@@ -308,6 +308,7 @@
$install_pfc = $_SESSION['go-pear']['install_pfc'];
}
@@ -64,27 +64,7 @@
if ($install_pfc) {
$to_install = array_merge($installer_packages, $pfc_packages);
-@@ -710,19 +718,6 @@
- }
- print "ok\n";
-
--print 'Bootstrapping: Console_Getopt.........';
--$r = 'RELEASE_' . ereg_replace('[^A-Za-z0-9]', '_', substr(substr($tarball['Console_Getopt'], 15), 0, -4));
--$url = "http://cvs.php.net/viewcvs.cgi/pear-core/Console/Getopt.php?view=co&pathrev=PEAR_1_4";
--mkdir('Console', 0700);
--if (in_array('Getopt.php', $local_dir)) {
-- copy(dirname(__FILE__).'/go-pear-bundle/Getopt.php', 'Console/Getopt.php');
-- echo "(local) ";
--} else {
-- download_url($url, 'Console/Getopt.php', $http_proxy);
-- echo "(remote) ";
--}
--print "ok\n";
--
- if ($install_pfc) {
- foreach ($pfc_packages as $pkg) {
- foreach($local_dir as $file) {
-@@ -788,7 +783,7 @@
+@@ -775,7 +783,7 @@
if (WEBINSTALLER || isset($_SERVER['argv'][1]) && $_SERVER['argv'][1] == 'local') {
$config = &PEAR_Config::singleton($prefix."/pear.conf", '');
} else {
@@ -93,7 +73,7 @@
}
-@@ -824,6 +819,7 @@
+@@ -811,6 +819,7 @@
// Base installation finished
@@ -101,7 +81,7 @@
ini_restore("include_path");
if (!WEBINSTALLER) {
-@@ -981,6 +977,7 @@
+@@ -968,6 +977,7 @@
if (WINDOWS && !WEBINSTALLER) {
win32CreateRegEnv();
}
@@ -109,7 +89,7 @@
// Set of functions following
// {{{ download_url()
-@@ -1377,17 +1374,17 @@
+@@ -1364,17 +1374,17 @@
}
} else {
if ($_prefix === null) {
@@ -131,7 +111,7 @@
// check if the user has installed PHP with PHP or GNU layout
if (@is_dir("$prefix/lib/php/.registry")) {
$php_dir = '$prefix/lib/php';
-@@ -1399,6 +1396,7 @@
+@@ -1386,6 +1396,7 @@
} elseif (@is_dir("$prefix/share/php/.registry")) {
$php_dir = '$prefix/share/php';
}
@@ -139,7 +119,7 @@
}
}
-@@ -2504,3 +2502,4 @@
+@@ -2491,3 +2502,4 @@
}
return true;
}