aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2009-02-10 19:42:31 +0800
committermm <mm@FreeBSD.org>2009-02-10 19:42:31 +0800
commit8afa69409703a8d65583e10ba217537f8e8d2f29 (patch)
treeeeb8afa7b85eef495c62046f3407f763a1efeec5
parent69faa13d9f67282c5c04eaf26aaecd94b6c4aac1 (diff)
downloadfreebsd-ports-gnome-8afa69409703a8d65583e10ba217537f8e8d2f29.tar.gz
freebsd-ports-gnome-8afa69409703a8d65583e10ba217537f8e8d2f29.tar.zst
freebsd-ports-gnome-8afa69409703a8d65583e10ba217537f8e8d2f29.zip
- switch to USE_TCL infrastructure
- add support for tcl84 and tcl85 - bump PORTREVISION PR: ports/130190 Approved by: maintainer (timeout)
-rw-r--r--games/etracer/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/games/etracer/Makefile b/games/etracer/Makefile
index 4ee2b16c6b98..a74add3c28f2 100644
--- a/games/etracer/Makefile
+++ b/games/etracer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= etracer
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/extremetuxracer
DISTNAME= extremetuxracer-${PORTVERSION}
@@ -15,17 +15,20 @@ DISTNAME= extremetuxracer-${PORTVERSION}
MAINTAINER= peter_dunning@dsl.pipex.com
COMMENT= The latest and greatest fork of the classic Tux Racer
-LIB_DEPENDS= tcl85:${PORTSDIR}/lang/tcl85 \
- png.5:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
USE_SDL= mixer sdl
USE_GL= gl glu glut
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.5 \
- --with-tcl-inc=${PREFIX}/include/tcl8.5 \
+
+USE_TCL= 84+
+
+.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= --with-tcl="${TCL_LIBDIR}" \
+ --with-tcl-inc="${TCL_INCLUDEDIR}" \
--with-gl-libs="${LOCALBASE}/lib" \
--with-gl-inc="${LOCALBASE}/include"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>