aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2006-08-28 14:03:13 +0800
committerdougb <dougb@FreeBSD.org>2006-08-28 14:03:13 +0800
commit9011a9fd67104b95834d33e4db2646106dd97d9d (patch)
treec0787827c32c040288125c55135886260639e407
parent5d209b076163de862e5d3b832f9e60a1459feeca (diff)
downloadfreebsd-ports-gnome-9011a9fd67104b95834d33e4db2646106dd97d9d.tar.gz
freebsd-ports-gnome-9011a9fd67104b95834d33e4db2646106dd97d9d.tar.zst
freebsd-ports-gnome-9011a9fd67104b95834d33e4db2646106dd97d9d.zip
Add OPTIONS to the rest of my ports that need them.
Add CONFLICTS to the bind* ports.
-rw-r--r--dns/bind8/Makefile17
-rw-r--r--dns/bind84/Makefile17
-rw-r--r--dns/bind9/Makefile26
-rw-r--r--dns/bind94/Makefile26
-rw-r--r--dns/bind95/Makefile26
-rw-r--r--dns/bind96/Makefile26
-rw-r--r--editors/pico/Makefile9
-rw-r--r--mail/pine4/Makefile13
-rw-r--r--textproc/htdig/Makefile13
9 files changed, 88 insertions, 85 deletions
diff --git a/dns/bind8/Makefile b/dns/bind8/Makefile
index 72497326f109..bf2ac2cbbca3 100644
--- a/dns/bind8/Makefile
+++ b/dns/bind8/Makefile
@@ -24,8 +24,15 @@ EXTRACT_ONLY= bind-src.tar.gz bind-doc.tar.gz
MAINTAINER?= DougB@FreeBSD.org
COMMENT= The Berkeley Internet Name Domain, an implementation of DNS
-.if defined(PORT_REPLACES_BASE_BIND8_INCLUDES)
-PORT_REPLACES_BASE_BIND8= yes
+CONFLICTS= bind84-8.* bind9* host-* zh-bind-8.*
+
+OPTIONS= REPLACE_BASE "Replace base BIND with this version" off \
+ REPLACE_BASE_INCLUDES "Replace includes as well as binaries" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_REPLACE_BASE_INCLUDES)
+WITH_REPLACE_BASE= yes
INCLUDE_PATH= include
PLIST_SUB+= INCLUDE_PATH=${INCLUDE_PATH}
.else
@@ -33,7 +40,7 @@ INCLUDE_PATH= include/bind
PLIST_SUB+= INCLUDE_PATH=${INCLUDE_PATH}
.endif
-.if defined(PORT_REPLACES_BASE_BIND8)
+.if defined(WITH_REPLACE_BASE)
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
@@ -80,7 +87,7 @@ post-patch:
@${MV} ${WRKSRC}/port/freebsd/Makefile.set.sed \
${WRKSRC}/port/freebsd/Makefile.set
-.if defined(PORT_REPLACES_BASE_BIND8)
+.if defined(WITH_REPLACE_BASE)
.for dir in nslookup nsupdate
@${SED} -e "s#{DESTBIN}#{DESTSBIN}#g" \
${WRKSRC}/bin/${dir}/Makefile > ${WRKSRC}/bin/${dir}/Makefile.sed
@@ -113,4 +120,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/bind84/Makefile b/dns/bind84/Makefile
index 5cb8f13be8e6..70441c86ee42 100644
--- a/dns/bind84/Makefile
+++ b/dns/bind84/Makefile
@@ -24,8 +24,15 @@ EXTRACT_ONLY= bind-src.tar.gz bind-doc.tar.gz
MAINTAINER= DougB@FreeBSD.org
COMMENT= The Berkeley Internet Name Domain, an implementation of DNS
-.if defined(PORT_REPLACES_BASE_BIND8_INCLUDES)
-PORT_REPLACES_BASE_BIND8= yes
+CONFLICTS= bind-8.* bind9* host-* zh-bind-8.*
+
+OPTIONS= REPLACE_BASE "Replace base BIND with this version" off \
+ REPLACE_BASE_INCLUDES "Replace includes as well as binaries" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_REPLACE_BASE_INCLUDES)
+WITH_REPLACE_BASE= yes
INCLUDE_PATH= include
PLIST_SUB+= INCLUDE_PATH=${INCLUDE_PATH}
.else
@@ -33,7 +40,7 @@ INCLUDE_PATH= include/bind
PLIST_SUB+= INCLUDE_PATH=${INCLUDE_PATH}
.endif
-.if defined(PORT_REPLACES_BASE_BIND8)
+.if defined(WITH_REPLACE_BASE)
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
@@ -86,7 +93,7 @@ post-patch:
@${MV} ${WRKSRC}/lib/irs/getaddrinfo.c.sed \
${WRKSRC}/lib/irs/getaddrinfo.c
-.if defined(PORT_REPLACES_BASE_BIND8)
+.if defined(WITH_REPLACE_BASE)
.for dir in nslookup nsupdate
@${SED} -e "s#{DESTBIN}#{DESTSBIN}#g" \
${WRKSRC}/bin/${dir}/Makefile > ${WRKSRC}/bin/${dir}/Makefile.sed
@@ -119,4 +126,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/bind9/Makefile b/dns/bind9/Makefile
index 275860df39eb..c4e19d815cf2 100644
--- a/dns/bind9/Makefile
+++ b/dns/bind9/Makefile
@@ -33,6 +33,13 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
USE_OPENSSL= yes
+CONFLICTS= bind-8.* bind84-8.* bind9-dlz-* bind9-sdb-mysql-* host-* zh-bind-8.*
+
+OPTIONS= REPLACE_BASE "Replace base BIND with this version" off \
+ THREADS "Compile with thread support (NOT RECOMMENDED!)" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_OPENSSL_PORT)
CONFIGURE_ARGS+= --with-openssl=${LOCALBASE}
.else
@@ -41,13 +48,13 @@ CONFIGURE_ARGS+= --with-openssl
# ISC staff has informed me that for 9.3.x, threads are always a bad idea.
# Leave the affirmative option for those that want to experiment.
-.if defined(WITH_BIND9_THREADS)
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads
.endif
-.if defined(WITH_PORT_REPLACES_BASE_BIND9)
+.if defined(WITH_REPLACE_BASE)
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
@@ -98,19 +105,6 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
-pre-fetch:
-.if defined(PORT_REPLACES_BASE_BIND9)
- @${ECHO} ""
- @${ECHO} "***************************************************"
- @${ECHO} "Support for the old PORT_REPLACES_BASE_BIND9 option"
- @${ECHO} "will be removed in future versions of the port."
- @${ECHO} "Use WITH_PORT_REPLACES_BASE_BIND9 instead."
- @${ECHO} "***************************************************"
- @${ECHO} ""
- @/bin/sleep 5
-WITH_PORT_REPLACES_BASE_BIND9= true
-.endif
-
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
@@ -136,4 +130,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/bind94/Makefile b/dns/bind94/Makefile
index 275860df39eb..c4e19d815cf2 100644
--- a/dns/bind94/Makefile
+++ b/dns/bind94/Makefile
@@ -33,6 +33,13 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
USE_OPENSSL= yes
+CONFLICTS= bind-8.* bind84-8.* bind9-dlz-* bind9-sdb-mysql-* host-* zh-bind-8.*
+
+OPTIONS= REPLACE_BASE "Replace base BIND with this version" off \
+ THREADS "Compile with thread support (NOT RECOMMENDED!)" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_OPENSSL_PORT)
CONFIGURE_ARGS+= --with-openssl=${LOCALBASE}
.else
@@ -41,13 +48,13 @@ CONFIGURE_ARGS+= --with-openssl
# ISC staff has informed me that for 9.3.x, threads are always a bad idea.
# Leave the affirmative option for those that want to experiment.
-.if defined(WITH_BIND9_THREADS)
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads
.endif
-.if defined(WITH_PORT_REPLACES_BASE_BIND9)
+.if defined(WITH_REPLACE_BASE)
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
@@ -98,19 +105,6 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
-pre-fetch:
-.if defined(PORT_REPLACES_BASE_BIND9)
- @${ECHO} ""
- @${ECHO} "***************************************************"
- @${ECHO} "Support for the old PORT_REPLACES_BASE_BIND9 option"
- @${ECHO} "will be removed in future versions of the port."
- @${ECHO} "Use WITH_PORT_REPLACES_BASE_BIND9 instead."
- @${ECHO} "***************************************************"
- @${ECHO} ""
- @/bin/sleep 5
-WITH_PORT_REPLACES_BASE_BIND9= true
-.endif
-
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
@@ -136,4 +130,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/bind95/Makefile b/dns/bind95/Makefile
index 275860df39eb..c4e19d815cf2 100644
--- a/dns/bind95/Makefile
+++ b/dns/bind95/Makefile
@@ -33,6 +33,13 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
USE_OPENSSL= yes
+CONFLICTS= bind-8.* bind84-8.* bind9-dlz-* bind9-sdb-mysql-* host-* zh-bind-8.*
+
+OPTIONS= REPLACE_BASE "Replace base BIND with this version" off \
+ THREADS "Compile with thread support (NOT RECOMMENDED!)" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_OPENSSL_PORT)
CONFIGURE_ARGS+= --with-openssl=${LOCALBASE}
.else
@@ -41,13 +48,13 @@ CONFIGURE_ARGS+= --with-openssl
# ISC staff has informed me that for 9.3.x, threads are always a bad idea.
# Leave the affirmative option for those that want to experiment.
-.if defined(WITH_BIND9_THREADS)
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads
.endif
-.if defined(WITH_PORT_REPLACES_BASE_BIND9)
+.if defined(WITH_REPLACE_BASE)
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
@@ -98,19 +105,6 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
-pre-fetch:
-.if defined(PORT_REPLACES_BASE_BIND9)
- @${ECHO} ""
- @${ECHO} "***************************************************"
- @${ECHO} "Support for the old PORT_REPLACES_BASE_BIND9 option"
- @${ECHO} "will be removed in future versions of the port."
- @${ECHO} "Use WITH_PORT_REPLACES_BASE_BIND9 instead."
- @${ECHO} "***************************************************"
- @${ECHO} ""
- @/bin/sleep 5
-WITH_PORT_REPLACES_BASE_BIND9= true
-.endif
-
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
@@ -136,4 +130,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
index 275860df39eb..c4e19d815cf2 100644
--- a/dns/bind96/Makefile
+++ b/dns/bind96/Makefile
@@ -33,6 +33,13 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
USE_OPENSSL= yes
+CONFLICTS= bind-8.* bind84-8.* bind9-dlz-* bind9-sdb-mysql-* host-* zh-bind-8.*
+
+OPTIONS= REPLACE_BASE "Replace base BIND with this version" off \
+ THREADS "Compile with thread support (NOT RECOMMENDED!)" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_OPENSSL_PORT)
CONFIGURE_ARGS+= --with-openssl=${LOCALBASE}
.else
@@ -41,13 +48,13 @@ CONFIGURE_ARGS+= --with-openssl
# ISC staff has informed me that for 9.3.x, threads are always a bad idea.
# Leave the affirmative option for those that want to experiment.
-.if defined(WITH_BIND9_THREADS)
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads
.endif
-.if defined(WITH_PORT_REPLACES_BASE_BIND9)
+.if defined(WITH_REPLACE_BASE)
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
@@ -98,19 +105,6 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
-pre-fetch:
-.if defined(PORT_REPLACES_BASE_BIND9)
- @${ECHO} ""
- @${ECHO} "***************************************************"
- @${ECHO} "Support for the old PORT_REPLACES_BASE_BIND9 option"
- @${ECHO} "will be removed in future versions of the port."
- @${ECHO} "Use WITH_PORT_REPLACES_BASE_BIND9 instead."
- @${ECHO} "***************************************************"
- @${ECHO} ""
- @/bin/sleep 5
-WITH_PORT_REPLACES_BASE_BIND9= true
-.endif
-
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
@@ -136,4 +130,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/pico/Makefile b/editors/pico/Makefile
index d0ebdb26e8b3..16a9fc4eee70 100644
--- a/editors/pico/Makefile
+++ b/editors/pico/Makefile
@@ -22,9 +22,16 @@ DISTNAME= pine${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
COMMENT= PIne's message COmposition editor
+OPTIONS= ISPELL "Use ispell as the spell checker" on \
+ NO_SPELLER "Do not use a spell checker" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_NO_SPELLER)
.if !defined(WITHOUT_ISPELL)
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
.endif
+.endif
WRKSRC= ${WRKDIR}/pine${PORTVERSION}/pico
PATCH_WRKSRC= ${WRKSRC}/..
@@ -44,4 +51,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pico ${PREFIX}/bin/pico
${INSTALL_MAN} ${WRKSRC}/../doc/pico.1 ${PREFIX}/man/man1/pico.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/pine4/Makefile b/mail/pine4/Makefile
index bb3702b62e60..69ba43f89753 100644
--- a/mail/pine4/Makefile
+++ b/mail/pine4/Makefile
@@ -21,9 +21,13 @@ DISTNAME= pine${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
COMMENT= PINE(tm) -- a Program for Internet News & Email
-.if !defined(WITHOUT_ISPELL)
-RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
-.endif
+OPTIONS= PICO "Build and install pico, the default editor" on \
+ LDAP "Add support for LDAP" off \
+ IPV6 "Add support for IPv6" off
+
+USE_OPENSSL= yes
+
+.include <bsd.port.pre.mk>
.if !defined(WITHOUT_PICO)
RUN_DEPENDS+= pico:${PORTSDIR}/editors/pico
@@ -42,7 +46,6 @@ EXTRA_OPTS= LDAPLIBS="-L${LOCALBASE}/lib -lldap -llber"
.if defined(WITHOUT_SSL)
MAKE_ARGS+= SSLTYPE=none
.else
-USE_OPENSSL= yes
EXTRA_OPTS+= SSLINCLUDE=${OPENSSLINC} SSLLIB=${OPENSSLLIB}
.if defined(WITH_SSL_AND_PLAINTEXT)
EXTRA_OPTS+= SSLTYPE=unix
@@ -127,4 +130,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index cd423f8b60ca..e976febf161f 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -20,8 +20,6 @@ DISTNAME= htdig-3.2.0b6
MAINTAINER= DougB@FreeBSD.org
COMMENT= A www indexing and searching system
-RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/${APACHE_PORT}
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-config-dir=${PREFIX}/etc/htdig \
--with-default-config-file=${PREFIX}/etc/htdig/htdig.conf \
@@ -31,17 +29,22 @@ CONFIGURE_ARGS= --with-config-dir=${PREFIX}/etc/htdig \
--with-search-dir=${PREFIX}/www/data \
--with-image-dir=${PREFIX}/www/icons/htdig \
--with-image-url-prefix=/icons/htdig \
- --with-ssl \
- --with-apache=${LOCALBASE}/sbin
+ --with-ssl
MAN1= htdig.1 htdig-pdfparser.1 htdump.1 htfuzzy.1 htload.1 \
htmerge.1 htnotify.1 htpurge.1 htsearch.1 htstat.1 rundig.1
MAN8= htdigconfig.8
-APACHE_COMPAT= YES
+
+OPTIONS= APACHE "Include ${APACHE_PORT} as a dependency" on
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_APACHE)
+CONFIGURE_ARGS+= --with-apache=${LOCALBASE}/sbin
+RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/${APACHE_PORT}
+.endif
+
.if ${OSVERSION} < 500000
EXTRA_PATCHES+= ${PATCHDIR}/RELENG_4-patch-htnet_SSLConnection.cc
.endif