aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-02-13 18:03:40 +0800
committerlawrance <lawrance@FreeBSD.org>2006-02-13 18:03:40 +0800
commit90612dca75adcd000449221db4d61c9c8b9adda3 (patch)
treeb4eaa2f4fef277eaaf6c07fead56ef534b1fa03b
parentb95a97cb96490cbd755c9c326a7409be85671f76 (diff)
downloadfreebsd-ports-gnome-90612dca75adcd000449221db4d61c9c8b9adda3.tar.gz
freebsd-ports-gnome-90612dca75adcd000449221db4d61c9c8b9adda3.tar.zst
freebsd-ports-gnome-90612dca75adcd000449221db4d61c9c8b9adda3.zip
Update to 0.9.5.
PR: ports/93247 Submitted by: Ports Fury
-rw-r--r--x11-wm/matchbox/Makefile79
-rw-r--r--x11-wm/matchbox/distinfo6
-rw-r--r--x11-wm/matchbox/files/patch-src_misc.h11
-rw-r--r--x11-wm/matchbox/files/patch-src_toolbar_client.h10
-rw-r--r--x11-wm/matchbox/files/patch-src_wm.h10
-rw-r--r--x11-wm/matchbox/files/patch-util_monolaunch.c19
-rw-r--r--x11-wm/matchbox/pkg-descr2
7 files changed, 35 insertions, 102 deletions
diff --git a/x11-wm/matchbox/Makefile b/x11-wm/matchbox/Makefile
index 6f56ecfdf210..2a2c68349535 100644
--- a/x11-wm/matchbox/Makefile
+++ b/x11-wm/matchbox/Makefile
@@ -6,65 +6,48 @@
#
PORTNAME= matchbox
-PORTVERSION= 0.3
+PORTVERSION= 0.9.5
CATEGORIES= x11-wm
-MASTER_SITES= http://handhelds.org/~mallum/downloadables/matchbox/
+MASTER_SITES= http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION:R}
+DISTNAME= ${PORTNAME}-window-manager-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Window manager suitable for low-resolution screens
-DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
-
-CONFIGURE_ARGS= --prefix=${PREFIX}
-GNU_CONFIGURE= yes
-MAN1= matchbox.1 mbcontrol.1 monolaunch.1 miniapm.1 minisys.1 minitime.1 minivol.1
-PLIST= ${WRKDIR}/pkg-plist
+USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-pre-install:
- ${ECHO_CMD} bin/matchbox > ${PLIST}
-.for ii in minitime minisys minivol monolaunch mbcontrol mbdock
- ${ECHO_CMD} bin/${ii} >> ${PLIST}
-.endfor
-.for ii in defaults icon.xpm
- ${ECHO_CMD} share/matchbox/${ii} >> ${PLIST}
-.endfor
-.for ii in mbdock themes
- cd ${WRKSRC}/data/${ii} && ${FIND} -s . -type f | \
- ${CUT} -c3-999 | \
- ${SED} -e 's:^:share/matchbox/${ii}/:' >> ${PLIST} \
- && ${FIND} -d . -type d | \
- ${CUT} -c3-999 | \
- ${SED} -e 's:^:@dirrm share/matchbox/${ii}/:' >> ${PLIST}
-.endfor
-.if !defined(NOPORTDOCS)
-.for ii in ${DOCS}
- ${ECHO_CMD} share/doc/matchbox/${ii} >> ${PLIST}
-.endfor
- ${ECHO_CMD} @dirrm share/doc/matchbox >> ${PLIST}
+PORTDOCS= ${DOCS}
+PLIST_FILES= bin/matchbox-window-manager bin/matchbox-remote \
+ etc/matchbox/kbdconfig
+PLIST_DIRS= etc/matchbox
+
+DOCS= AUTHORS ChangeLog NEWS README
+
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3 || defined(WITHOUT_XFT)
+CONFIGURE_ARGS+= --enable-standalone
+.else
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+= --enable-standalone-xft
.endif
- ${ECHO_CMD} @dirrm share/matchbox >> ${PLIST}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/matchbox ${PREFIX}/bin
-.for ii in minitime minisys minivol monolaunch mbcontrol
- ${INSTALL_PROGRAM} ${WRKSRC}/util/${ii} ${PREFIX}/bin
-.endfor
- ${INSTALL_PROGRAM} ${WRKSRC}/dock/mbdock ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC}/data/ && ${PAX} -r -w themes ${DATADIR} \
- && ${PAX} -r -w mbdock ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/matchbox-remote ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/matchbox-window-manager ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/etc/matchbox
+ ${INSTALL_DATA} ${WRKSRC}/data/kbdconfig ${PREFIX}/etc/matchbox
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for ii in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-.for ii in defaults icon.xpm
- ${INSTALL_DATA} ${WRKSRC}/data/${ii} ${DATADIR}
-.endfor
-.for ii in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/doc/${ii} ${PREFIX}/man/man1/
-.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/matchbox/distinfo b/x11-wm/matchbox/distinfo
index 7e091d4ba064..5168e5d8da9b 100644
--- a/x11-wm/matchbox/distinfo
+++ b/x11-wm/matchbox/distinfo
@@ -1,3 +1,3 @@
-MD5 (matchbox-0.3.tar.gz) = 6a14ff325653a601d7643b1b0a627091
-SHA256 (matchbox-0.3.tar.gz) = ad5037e72abf5e38d4742d2e9821ccb07feac2a337022704880ae2df23fde51b
-SIZE (matchbox-0.3.tar.gz) = 192431
+MD5 (matchbox-window-manager-0.9.5.tar.bz2) = a992bda42a5f46c648fbaf007e8181db
+SHA256 (matchbox-window-manager-0.9.5.tar.bz2) = 404b96e165c746f1e44102895349a8659ed628b2bd358d127b27d3f9b82fe4ac
+SIZE (matchbox-window-manager-0.9.5.tar.bz2) = 194444
diff --git a/x11-wm/matchbox/files/patch-src_misc.h b/x11-wm/matchbox/files/patch-src_misc.h
deleted file mode 100644
index d83e6077794f..000000000000
--- a/x11-wm/matchbox/files/patch-src_misc.h
+++ /dev/null
@@ -1,11 +0,0 @@
-$FreeBSD$
-
---- src/misc.h.orig Sun May 26 16:45:09 2002
-+++ src/misc.h Wed Sep 25 13:24:24 2002
-@@ -52,5 +52,5 @@ int max_xstringChars(wm *w, int *width,
- int max_xstringChars(wm *w, int *width, char *txt, XFontStruct* font_info);
- #endif
- void scale_icon(Client *c);
--#endif _MISC_H_
-+#endif /* _MISC_H_ */
-
diff --git a/x11-wm/matchbox/files/patch-src_toolbar_client.h b/x11-wm/matchbox/files/patch-src_toolbar_client.h
deleted file mode 100644
index 0c8e4fc85bf3..000000000000
--- a/x11-wm/matchbox/files/patch-src_toolbar_client.h
+++ /dev/null
@@ -1,10 +0,0 @@
-$FreeBSD$
-
---- src/toolbar_client.h.orig Wed Feb 13 17:04:26 2002
-+++ src/toolbar_client.h Wed Sep 25 13:23:32 2002
-@@ -42,4 +42,4 @@ void toolbar_client_reparent(Client *c);
- void toolbar_client_redraw(Client *c, Bool use_cache);
- int toolbar_win_offset(Client *c);
-
--#endif _TOOLBAR_CLIENT_H_
-+#endif /* _TOOLBAR_CLIENT_H_ */
diff --git a/x11-wm/matchbox/files/patch-src_wm.h b/x11-wm/matchbox/files/patch-src_wm.h
deleted file mode 100644
index 3aff920b3eb3..000000000000
--- a/x11-wm/matchbox/files/patch-src_wm.h
+++ /dev/null
@@ -1,10 +0,0 @@
-$FreeBSD$
-
---- src/wm.h.orig Mon Jun 24 08:27:44 2002
-+++ src/wm.h Wed Sep 25 13:23:43 2002
-@@ -86,4 +86,4 @@ void wm_gravitate(Client *c, int multipl
- void wm_init_existing(Wm *w);
- int wm_total_dock_height(Client *c);
- void wm_toggle_desktop(Wm *w);
--#endif _WM_H_
-+#endif /* _WM_H_ */
diff --git a/x11-wm/matchbox/files/patch-util_monolaunch.c b/x11-wm/matchbox/files/patch-util_monolaunch.c
deleted file mode 100644
index b2e753ab2b27..000000000000
--- a/x11-wm/matchbox/files/patch-util_monolaunch.c
+++ /dev/null
@@ -1,19 +0,0 @@
-$FreeBSD$
-
---- util/monolaunch.c.orig Wed Jul 10 06:38:02 2002
-+++ util/monolaunch.c Sun Jul 14 20:41:16 2002
-@@ -20,14 +20,12 @@
- */
-
- #include <stdlib.h>
--#include <getopt.h>
- #include <string.h>
- #include <fcntl.h>
- #include <stdio.h>
- #include <errno.h>
- #include <sys/types.h>
- #include <sys/stat.h>
--#include <sys/sysmacros.h>
- #include <signal.h>
- #include <X11/X.h>
- #include <X11/Xlib.h>
diff --git a/x11-wm/matchbox/pkg-descr b/x11-wm/matchbox/pkg-descr
index b34b1cc2f383..ba43c83d71cb 100644
--- a/x11-wm/matchbox/pkg-descr
+++ b/x11-wm/matchbox/pkg-descr
@@ -11,4 +11,4 @@ they are Linux-specific).
The dock may be used with the metacity window manager. Matchbox
is compatible with the GNOME and KDE panels.
-WWW: http://matchbox.handhelds.org
+WWW: http://projects.o-hand.com/matchbox/