aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2012-02-24 21:04:14 +0800
committerosa <osa@FreeBSD.org>2012-02-24 21:04:14 +0800
commit925ba7e0afc4387863167fa6f0d8dffded94712b (patch)
tree33afc556e3905b58666fde6b3a161def112dea20
parent6c3994543184f46f801f4c2f6c3bac19c1e720b6 (diff)
downloadfreebsd-ports-gnome-925ba7e0afc4387863167fa6f0d8dffded94712b.tar.gz
freebsd-ports-gnome-925ba7e0afc4387863167fa6f0d8dffded94712b.tar.zst
freebsd-ports-gnome-925ba7e0afc4387863167fa6f0d8dffded94712b.zip
Update from 2.4.7 to 2.4.8.
<ChangeLog> UPGRADE URGENCY: moderate if you don't experience any of the fixed problems. * [BUGFIX] Make install now uses cp -f to avoid 'text file busy' errors. * [BUGFIX] redis-check-aof is now large files safe also on 32 bit systems. * [BUGFIX] Issue #327 fixed: maxmemory and replication now work much better. * [BUGFIX] Now HINCRBY can detect overflows too. Fix for issue #330. * [BUGFIX] Fixed compilation with latest clang. * [BUGFIX] Fixed handling of empty sorted sets produced in RDB by very old Redis versions (1.2.x). </ChangeLog>
-rw-r--r--databases/redis/Makefile2
-rw-r--r--databases/redis/distinfo4
-rw-r--r--databases/redis/files/patch-deps::hiredis::Makefile54
-rw-r--r--databases/redis/files/patch-deps::linenoise::Makefile4
-rw-r--r--databases/redis/files/patch-deps:hiredis:hiredis.c11
-rw-r--r--databases/redis/files/patch-src::config.h8
6 files changed, 42 insertions, 41 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 8045afb314e0..a9bb15d95f17 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= redis
-PORTVERSION= 2.4.7
+PORTVERSION= 2.4.8
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
diff --git a/databases/redis/distinfo b/databases/redis/distinfo
index e3fea295d6f3..11e01fca7c28 100644
--- a/databases/redis/distinfo
+++ b/databases/redis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redis-2.4.7.tar.gz) = f91956377b7ff23cc23e0c8758e0b873032f36545c61d88436ebb741bf4dd5e1
-SIZE (redis-2.4.7.tar.gz) = 611577
+SHA256 (redis-2.4.8.tar.gz) = 8166ca6ddea4bdb311510590a1ef94e3e32eed2fae44875a5b44fe72bda556f3
+SIZE (redis-2.4.8.tar.gz) = 618164
diff --git a/databases/redis/files/patch-deps::hiredis::Makefile b/databases/redis/files/patch-deps::hiredis::Makefile
index f6d34bd3a9de..b0cfcd406885 100644
--- a/databases/redis/files/patch-deps::hiredis::Makefile
+++ b/databases/redis/files/patch-deps::hiredis::Makefile
@@ -1,10 +1,24 @@
---- deps/hiredis/Makefile.orig 2010-12-23 15:17:54.000000000 +0300
-+++ deps/hiredis/Makefile 2010-12-24 09:24:45.000000000 +0300
-@@ -24,6 +24,14 @@
- DYLIB_MAKE_CMD?=libtool -dynamic -o ${DYLIBNAME} -lm ${DEBUG} - ${OBJ}
- STLIBNAME?=libhiredis.a
- STLIB_MAKE_CMD?=libtool -static -o ${STLIBNAME} - ${OBJ}
-+else ifeq ($(uname_S),FreeBSD)
+--- deps/hiredis/Makefile.orig 2012-02-22 17:23:43.000000000 +0400
++++ deps/hiredis/Makefile 2012-02-24 16:46:44.000000000 +0400
+@@ -12,10 +12,10 @@
+
+ # Fallback to gcc when $CC is not in $PATH.
+ CC:=$(shell sh -c 'type $(CC) >/dev/null 2>/dev/null && echo $(CC) || echo gcc')
+-OPTIMIZATION?=-O3
++#OPTIMIZATION?=-O3
+ WARNINGS=-Wall -W -Wstrict-prototypes -Wwrite-strings
+-DEBUG?= -g -ggdb
+-REAL_CFLAGS=$(OPTIMIZATION) -fPIC $(CFLAGS) $(WARNINGS) $(DEBUG) $(ARCH)
++#DEBUG?= -g -ggdb
++REAL_CFLAGS=$(OPTIMIZATION) -fPIC $(CFLAGS) $(WARNINGS) $(DEBUG)
+ REAL_LDFLAGS=$(LDFLAGS) $(ARCH)
+
+ DYLIBSUFFIX=so
+@@ -34,6 +34,15 @@
+ DYLIB_MAKE_CMD=$(CC) -G -o $(DYLIBNAME) -h $(DYLIB_MINOR_NAME) $(LDFLAGS)
+ INSTALL= cp -r
+ endif
++ifeq ($(uname_S),FreeBSD)
+ CFLAGS?=$(CFLAGS)
+ CCLINK?=-pthread
+ LDFLAGS?=-L. -Wl,-rpath,.
@@ -12,18 +26,16 @@
+ DYLIB_MAKE_CMD?=$(CC) -o ${DYLIBNAME} ${OBJ}
+ STLIBNAME?=libhiredis.a
+ STLIB_MAKE_CMD?=ar rcs ${STLIBNAME} ${OBJ}
- else
- CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -fPIC -Wall -W -Wwrite-strings $(ARCH) $(PROF)
- CCLINK?=-lm -pthread
-@@ -34,9 +42,9 @@
- STLIB_MAKE_CMD?=ar rcs ${STLIBNAME} ${OBJ}
- endif
- CCOPT= $(CFLAGS) $(CCLINK)
--DEBUG?= -g -ggdb
-+#DEBUG?= -g -ggdb
++endif
+ ifeq ($(uname_S),Darwin)
+ DYLIBSUFFIX=dylib
+ DYLIB_MINOR_NAME=$(LIBNAME).$(HIREDIS_MAJOR).$(HIREDIS_MINOR).$(DYLIBSUFFIX)
+@@ -104,7 +113,7 @@
+ $(CC) -MM *.c
--PREFIX?= /usr/local
-+PREFIX?= ${PREFIX}
- INSTALL_INC= $(PREFIX)/include/hiredis
- INSTALL_LIB= $(PREFIX)/lib
- INSTALL= cp -a
+ # Installation related variables and target
+-PREFIX?=/usr/local
++PREFIX?=${PREFIX}
+ INCLUDE_PATH?=include/hiredis
+ LIBRARY_PATH?=lib
+ INSTALL_INCLUDE_PATH= $(PREFIX)/$(INCLUDE_PATH)
diff --git a/databases/redis/files/patch-deps::linenoise::Makefile b/databases/redis/files/patch-deps::linenoise::Makefile
index 2a79e2e3208c..de4181edbd6c 100644
--- a/databases/redis/files/patch-deps::linenoise::Makefile
+++ b/databases/redis/files/patch-deps::linenoise::Makefile
@@ -1,5 +1,5 @@
---- deps/linenoise/Makefile.orig 2010-12-24 09:27:03.000000000 +0300
-+++ deps/linenoise/Makefile 2010-12-24 09:27:47.000000000 +0300
+--- deps/linenoise/Makefile.orig 2012-02-22 17:23:43.000000000 +0400
++++ deps/linenoise/Makefile 2012-02-24 16:48:55.000000000 +0400
@@ -1,10 +1,10 @@
linenoise_example: linenoise.h linenoise.c
diff --git a/databases/redis/files/patch-deps:hiredis:hiredis.c b/databases/redis/files/patch-deps:hiredis:hiredis.c
deleted file mode 100644
index db4496d75c13..000000000000
--- a/databases/redis/files/patch-deps:hiredis:hiredis.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- deps/hiredis/hiredis.c.orig 2011-11-23 15:42:15.000000000 +0400
-+++ deps/hiredis/hiredis.c 2011-11-23 15:42:45.000000000 +0400
-@@ -697,7 +697,7 @@
- }
-
- /* Consume and discard vararg */
-- va_arg(ap,void);
-+ va_arg(ap,void*);
- }
- }
- touched = 1;
diff --git a/databases/redis/files/patch-src::config.h b/databases/redis/files/patch-src::config.h
index d69cd179d65e..ae6f5cb4fde2 100644
--- a/databases/redis/files/patch-src::config.h
+++ b/databases/redis/files/patch-src::config.h
@@ -1,11 +1,11 @@
---- src/config.h.orig 2011-11-30 16:28:05.000000000 +0400
-+++ src/config.h 2011-11-30 16:28:19.000000000 +0400
+--- src/config.h.orig 2012-02-24 16:56:36.000000000 +0400
++++ src/config.h 2012-02-24 16:57:01.000000000 +0400
@@ -25,7 +25,7 @@
#endif
/* Test for backtrace() */
--#if defined(__APPLE__) || defined(__linux__)
-+#if defined(__APPLE__) || defined(__linux__) || defined(__FreeBSD__)
+-#if defined(__APPLE__) || defined(__linux__) || defined(__sun)
++#if defined(__APPLE__) || defined(__linux__) || defined(__sun) || defined(__FreeBSD__)
#define HAVE_BACKTRACE 1
#endif