aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2012-04-27 17:49:01 +0800
committerkwm <kwm@FreeBSD.org>2012-04-27 17:49:01 +0800
commit94192be6c8dd0a1da69b8c5e3232c50c3aba98f2 (patch)
tree6c4cce122e4b0a1f2797a05f00b790fa5afbc8d4
parent0c8496082c62a4a12892f66386fdb426cc06668a (diff)
downloadfreebsd-ports-gnome-94192be6c8dd0a1da69b8c5e3232c50c3aba98f2.tar.gz
freebsd-ports-gnome-94192be6c8dd0a1da69b8c5e3232c50c3aba98f2.tar.zst
freebsd-ports-gnome-94192be6c8dd0a1da69b8c5e3232c50c3aba98f2.zip
Update to 3.5.0.2.
Update media tree sources to version 3.5-staging. Add new drivers, and fix the mceusb remote control driver. Submitted by: maintainer
-rw-r--r--multimedia/webcamd/Makefile2
-rw-r--r--multimedia/webcamd/distinfo4
-rw-r--r--multimedia/webcamd/files/webcamd.conf.in9
-rw-r--r--multimedia/webcamd/files/webcamd.in7
4 files changed, 16 insertions, 6 deletions
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index 3b5c1b2b9739..7ededeb283c8 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= webcamd
-PORTVERSION= 3.2.0.2
+PORTVERSION= 3.5.0.2
CATEGORIES= multimedia
MASTER_SITES= http://www.selasky.org/hans_petter/distfiles/ \
http://hselasky.homeunix.org:8192/distfiles/
diff --git a/multimedia/webcamd/distinfo b/multimedia/webcamd/distinfo
index 25bca899ee9b..b77bd17e184a 100644
--- a/multimedia/webcamd/distinfo
+++ b/multimedia/webcamd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (webcamd-3.2.0.2.tar.bz2) = 227e4166f70f060559633b528975d9e030df986663fc269103e55ab3fbc6d1d8
-SIZE (webcamd-3.2.0.2.tar.bz2) = 8825403
+SHA256 (webcamd-3.5.0.2.tar.bz2) = 0111aa9066e1e79e28a051856981ae89d3c583148fb15c9fedc7c82ba30de077
+SIZE (webcamd-3.5.0.2.tar.bz2) = 9217074
diff --git a/multimedia/webcamd/files/webcamd.conf.in b/multimedia/webcamd/files/webcamd.conf.in
index c0800b1b3933..ab928f2c57ab 100644
--- a/multimedia/webcamd/files/webcamd.conf.in
+++ b/multimedia/webcamd/files/webcamd.conf.in
@@ -24,3 +24,12 @@ notify 100 {
match "intclass" "0x00";
action "env LD_PRELOAD=%%LIBHAL%%%%LIBCUSE%% %%PREFIX%%/etc/rc.d/webcamd start $cdev";
};
+
+# Generic USB input devices.
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "INTERFACE";
+ match "type" "ATTACH";
+ match "intclass" "0x03";
+ action "env LD_PRELOAD=%%LIBHAL%%%%LIBCUSE%% %%PREFIX%%/etc/rc.d/webcamd start $cdev $interface";
+};
diff --git a/multimedia/webcamd/files/webcamd.in b/multimedia/webcamd/files/webcamd.in
index 4e963675913c..905b64b66399 100644
--- a/multimedia/webcamd/files/webcamd.in
+++ b/multimedia/webcamd/files/webcamd.in
@@ -15,7 +15,8 @@ hald_enable=${hald_enable-"NO"}
. /etc/rc.subr
name=webcamd
-rcvar=webcamd_enable
+rcvar=`set_rcvar`
+iface=${3-0}
command=%%PREFIX%%/sbin/webcamd
command_args="-B -U webcamd -G webcamd"
@@ -28,7 +29,7 @@ webcamd_prestart()
fi
}
-pidfile="/var/run/webcamd.*.0.pid"
+pidfile="/var/run/webcamd.*.$iface.pid"
load_rc_config $name
@@ -42,7 +43,7 @@ fi
if [ $# -gt 1 ]; then
pidfile="webcamd.dummy"
- command_args="$command_args -d $2 -i 0"
+ command_args="$command_args -d $2 -i $iface"
# Only run the rc command if the appropriate arguments are specified:
run_rc_command $1
fi