aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2012-01-12 20:55:15 +0800
committerrakuco <rakuco@FreeBSD.org>2012-01-12 20:55:15 +0800
commit97621863b2dc9a65b94fe826fc49f7694c0f7f28 (patch)
tree3bf0c6d99f0dda27914531979ad62c542afa25c1
parent2c35bb0833924a8ce5a72a257c15999f1077e8f8 (diff)
downloadfreebsd-ports-gnome-97621863b2dc9a65b94fe826fc49f7694c0f7f28.tar.gz
freebsd-ports-gnome-97621863b2dc9a65b94fe826fc49f7694c0f7f28.tar.zst
freebsd-ports-gnome-97621863b2dc9a65b94fe826fc49f7694c0f7f28.zip
Update to 2.0.2.
This includes two upstream SVN commits that should make the port build with clang. Approved by: avilla (mentor)
-rw-r--r--print/lyx/Makefile2
-rw-r--r--print/lyx/distinfo4
-rw-r--r--print/lyx/files/patch-src__Lexer.h14
-rw-r--r--print/lyx/files/patch-src__insets__InsetTabular.cpp129
-rw-r--r--print/lyx/pkg-plist31
5 files changed, 171 insertions, 9 deletions
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index f0f89f8b894f..64f9f269dfe5 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs \
CONFLICTS= lyx-1.[0-9]*
MAJOR_VERSION= 2.0
-MINOR_VERSION= 1
+MINOR_VERSION= 2
USE_XZ= yes
USE_GMAKE= yes
diff --git a/print/lyx/distinfo b/print/lyx/distinfo
index 2383c12ac9cd..16939ad8cab0 100644
--- a/print/lyx/distinfo
+++ b/print/lyx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lyx-2.0.1.tar.xz) = a58b7e0f27afce0497fffec0d19fc95fb1b3ac36818e8d02ecaf9e882c8f3852
-SIZE (lyx-2.0.1.tar.xz) = 10119588
+SHA256 (lyx-2.0.2.tar.xz) = e5eacacd200d4502808f59e244d380634dca421b2bc89a5c213b3faddadcbd18
+SIZE (lyx-2.0.2.tar.xz) = 10175756
diff --git a/print/lyx/files/patch-src__Lexer.h b/print/lyx/files/patch-src__Lexer.h
new file mode 100644
index 000000000000..a850b4fdd43d
--- /dev/null
+++ b/print/lyx/files/patch-src__Lexer.h
@@ -0,0 +1,14 @@
+Index: src/Lexer.h
+===================================================================
+--- src/Lexer.h (revision 40416)
++++ src/Lexer.h (revision 40417)
+@@ -18,8 +18,8 @@
+ #define LEXER_H
+
+ #include "support/strfwd.h"
++#include <string>
+
+-
+ namespace lyx {
+
+ namespace support { class FileName; }
diff --git a/print/lyx/files/patch-src__insets__InsetTabular.cpp b/print/lyx/files/patch-src__insets__InsetTabular.cpp
new file mode 100644
index 000000000000..931002474ef8
--- /dev/null
+++ b/print/lyx/files/patch-src__insets__InsetTabular.cpp
@@ -0,0 +1,129 @@
+Index: src/insets/InsetTabular.cpp
+===================================================================
+--- src/insets/InsetTabular.cpp (revision 39812)
++++ src/insets/InsetTabular.cpp (revision 39813)
+@@ -188,62 +188,6 @@
+ };
+
+
+-template <class T>
+-string const write_attribute(string const & name, T const & t)
+-{
+- string const s = tostr(t);
+- return s.empty() ? s : " " + name + "=\"" + s + "\"";
+-}
+-
+-template <>
+-string const write_attribute(string const & name, string const & t)
+-{
+- return t.empty() ? t : " " + name + "=\"" + t + "\"";
+-}
+-
+-
+-template <>
+-string const write_attribute(string const & name, docstring const & t)
+-{
+- return t.empty() ? string() : " " + name + "=\"" + to_utf8(t) + "\"";
+-}
+-
+-
+-template <>
+-string const write_attribute(string const & name, bool const & b)
+-{
+- // we write only true attribute values so we remove a bit of the
+- // file format bloat for tabulars.
+- return b ? write_attribute(name, convert<string>(b)) : string();
+-}
+-
+-
+-template <>
+-string const write_attribute(string const & name, int const & i)
+-{
+- // we write only true attribute values so we remove a bit of the
+- // file format bloat for tabulars.
+- return i ? write_attribute(name, convert<string>(i)) : string();
+-}
+-
+-
+-template <>
+-string const write_attribute(string const & name, Tabular::idx_type const & i)
+-{
+- // we write only true attribute values so we remove a bit of the
+- // file format bloat for tabulars.
+- return i ? write_attribute(name, convert<string>(i)) : string();
+-}
+-
+-
+-template <>
+-string const write_attribute(string const & name, Length const & value)
+-{
+- // we write only the value if we really have one same reson as above.
+- return value.zero() ? string() : write_attribute(name, value.asString());
+-}
+-
+-
+ string const tostr(LyXAlignment const & num)
+ {
+ switch (num) {
+@@ -503,6 +447,61 @@
+ }
+ }
+
++template <class T>
++string const write_attribute(string const & name, T const & t)
++{
++ string const s = tostr(t);
++ return s.empty() ? s : " " + name + "=\"" + s + "\"";
++}
++
++template <>
++string const write_attribute(string const & name, string const & t)
++{
++ return t.empty() ? t : " " + name + "=\"" + t + "\"";
++}
++
++
++template <>
++string const write_attribute(string const & name, docstring const & t)
++{
++ return t.empty() ? string() : " " + name + "=\"" + to_utf8(t) + "\"";
++}
++
++
++template <>
++string const write_attribute(string const & name, bool const & b)
++{
++ // we write only true attribute values so we remove a bit of the
++ // file format bloat for tabulars.
++ return b ? write_attribute(name, convert<string>(b)) : string();
++}
++
++
++template <>
++string const write_attribute(string const & name, int const & i)
++{
++ // we write only true attribute values so we remove a bit of the
++ // file format bloat for tabulars.
++ return i ? write_attribute(name, convert<string>(i)) : string();
++}
++
++
++template <>
++string const write_attribute(string const & name, Tabular::idx_type const & i)
++{
++ // we write only true attribute values so we remove a bit of the
++ // file format bloat for tabulars.
++ return i ? write_attribute(name, convert<string>(i)) : string();
++}
++
++
++template <>
++string const write_attribute(string const & name, Length const & value)
++{
++ // we write only the value if we really have one same reson as above.
++ return value.zero() ? string() : write_attribute(name, value.asString());
++}
++
+ } // namespace
+
+
diff --git a/print/lyx/pkg-plist b/print/lyx/pkg-plist
index ebdf6d0d8de3..d9ffa4ea0cf6 100644
--- a/print/lyx/pkg-plist
+++ b/print/lyx/pkg-plist
@@ -170,6 +170,7 @@ bin/tex2lyx
%%DATADIR%%/doc/fr/clipart/BoxInsetDefaultQt4.png
%%DATADIR%%/doc/fr/clipart/ChildDocumentQt4.png
%%DATADIR%%/doc/fr/clipart/CommentNoteImageQt4.png
+%%DATADIR%%/doc/fr/clipart/ERT.png
%%DATADIR%%/doc/fr/clipart/GreyedOutNoteImageQt4.png
%%DATADIR%%/doc/fr/clipart/LyXNoteImageQt4.png
%%DATADIR%%/doc/fr/clipart/floatQt4.png
@@ -347,6 +348,7 @@ bin/tex2lyx
%%DATADIR%%/examples/linguistics.lyx
%%DATADIR%%/examples/listerrors.lyx
%%DATADIR%%/examples/localization_test.lyx
+%%DATADIR%%/examples/longsheet.gnumeric
%%DATADIR%%/examples/modernCV.lyx
%%DATADIR%%/examples/multicol.lyx
%%DATADIR%%/examples/nl/multicol.lyx
@@ -367,11 +369,15 @@ bin/tex2lyx
%%DATADIR%%/examples/serial_letter2.lyx
%%DATADIR%%/examples/serial_letter3.lyx
%%DATADIR%%/examples/simplecv.lyx
+%%DATADIR%%/examples/sheet1.gnumeric
+%%DATADIR%%/examples/sheet2.ods
+%%DATADIR%%/examples/sheet3.xls
%%DATADIR%%/examples/sk/splash.lyx
%%DATADIR%%/examples/sl/primer_lyxan.lyx
%%DATADIR%%/examples/sl/primer_surov.lyx
%%DATADIR%%/examples/sl/splash.lyx
%%DATADIR%%/examples/splash.lyx
+%%DATADIR%%/examples/spreadsheet.lyx
%%DATADIR%%/examples/sr/Braille.lyx
%%DATADIR%%/examples/sr/splash.lyx
%%DATADIR%%/examples/sv/splash.lyx
@@ -1410,6 +1416,9 @@ bin/tex2lyx
%%DATADIR%%/layouts/broadway.layout
%%DATADIR%%/layouts/chess.layout
%%DATADIR%%/layouts/cl2emult.layout
+%%DATADIR%%/layouts/ctex-article.layout
+%%DATADIR%%/layouts/ctex-book.layout
+%%DATADIR%%/layouts/ctex-report.layout
%%DATADIR%%/layouts/customHeadersFooters.module
%%DATADIR%%/layouts/db_lyxmacros.inc
%%DATADIR%%/layouts/db_stdcharstyles.inc
@@ -1526,10 +1535,10 @@ bin/tex2lyx
%%DATADIR%%/layouts/stdstarsections.inc
%%DATADIR%%/layouts/stdstruct.inc
%%DATADIR%%/layouts/stdtitle.inc
+%%DATADIR%%/layouts/svcommon.inc
%%DATADIR%%/layouts/svglobal.layout
%%DATADIR%%/layouts/svglobal3.layout
%%DATADIR%%/layouts/svjog.layout
-%%DATADIR%%/layouts/svjour.inc
%%DATADIR%%/layouts/svmono.layout
%%DATADIR%%/layouts/svmult.layout
%%DATADIR%%/layouts/svprobth.layout
@@ -1558,6 +1567,7 @@ bin/tex2lyx
%%DATADIR%%/layouts/theorems-starred.inc
%%DATADIR%%/layouts/theorems-starred.module
%%DATADIR%%/layouts/theorems-std.module
+%%DATADIR%%/layouts/theorems-without-preamble.inc
%%DATADIR%%/layouts/theorems.inc
%%DATADIR%%/layouts/treport.layout
%%DATADIR%%/layouts/tufte-book.layout
@@ -1692,6 +1702,7 @@ bin/tex2lyx
%%DATADIR%%/scripts/lyxpreview_tools.py
%%DATADIR%%/scripts/lyxpreview_tools.pyc
%%DATADIR%%/scripts/lyxpreview_tools.pyo
+%%DATADIR%%/scripts/lyxstangle.R
%%DATADIR%%/scripts/lyxsweave.R
%%DATADIR%%/scripts/prefs2prefs.py
%%DATADIR%%/scripts/prefs2prefs.pyc
@@ -1719,6 +1730,7 @@ bin/tex2lyx
%%DATADIR%%/templates/agutex.lyx
%%DATADIR%%/templates/apa.lyx
%%DATADIR%%/templates/beamer-conference-ornate-20min.lyx
+%%DATADIR%%/templates/ctex.lyx
%%DATADIR%%/templates/de_beamer-conference-ornate-20min.lyx
%%DATADIR%%/templates/dinbrief.lyx
%%DATADIR%%/templates/docbook_article.lyx
@@ -1740,11 +1752,17 @@ bin/tex2lyx
%%DATADIR%%/templates/lettre.lyx
%%DATADIR%%/templates/revtex4.lyx
%%DATADIR%%/templates/slides.lyx
-%%DATADIR%%/templates/svjour3.lyx
-%%DATADIR%%/templates/svmono_book.lyx
-%%DATADIR%%/templates/svmult_appendix.lyx
-%%DATADIR%%/templates/svmult_author.lyx
-%%DATADIR%%/templates/svmult_editor.lyx
+%%DATADIR%%/templates/springer/svjour3.lyx
+%%DATADIR%%/templates/springer/svmono_acknow.lyx
+%%DATADIR%%/templates/springer/svmono_acronym.lyx
+%%DATADIR%%/templates/springer/svmono_appendix.lyx
+%%DATADIR%%/templates/springer/svmono_book-master.lyx
+%%DATADIR%%/templates/springer/svmono_chapter.lyx
+%%DATADIR%%/templates/springer/svmono_dedication.lyx
+%%DATADIR%%/templates/springer/svmono_foreword.lyx
+%%DATADIR%%/templates/springer/svmono_glossary.lyx
+%%DATADIR%%/templates/springer/svmono_part.lyx
+%%DATADIR%%/templates/springer/svmono_preface.lyx
%%DATADIR%%/templates/thesis/Acknowledgments.lyx
%%DATADIR%%/templates/thesis/Appendix.lyx
%%DATADIR%%/templates/thesis/Summary.lyx
@@ -1766,6 +1784,7 @@ bin/tex2lyx
@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%/tex
@dirrm %%DATADIR%%/templates/thesis
+@dirrm %%DATADIR%%/templates/springer
@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%/scripts
@dirrm %%DATADIR%%/lyx2lyx