aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-06-19 03:49:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-06-19 03:49:39 +0800
commit98ab99073aeb33378d8b88155f46aeff2a255834 (patch)
tree696b131d9fba119380f7eb823e3eb4690ce2da5b
parent1bc0f1cb49db29a7e8bcd9ba017ac1699aa30b6e (diff)
downloadfreebsd-ports-gnome-98ab99073aeb33378d8b88155f46aeff2a255834.tar.gz
freebsd-ports-gnome-98ab99073aeb33378d8b88155f46aeff2a255834.tar.zst
freebsd-ports-gnome-98ab99073aeb33378d8b88155f46aeff2a255834.zip
- Strip binaries
-rw-r--r--deskutils/preferences/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/deskutils/preferences/Makefile b/deskutils/preferences/Makefile
index 3577fc894f02..be2142b4145b 100644
--- a/deskutils/preferences/Makefile
+++ b/deskutils/preferences/Makefile
@@ -2,7 +2,7 @@
PORTNAME= preferences
PORTVERSION= 1.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= deskutils gnustep
MASTER_SITES= SF/prefsapp/prefsapp/${PORTVERSION}
DISTNAME= Preferences-${PORTVERSION}
@@ -28,4 +28,10 @@ post-patch:
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
${WRKSRC}/GNUmakefile.preamble
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Applications/Preferences.app/Preferences
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Applications/Preferences.app/Resources/PrefsApp.prefs/PrefsApp
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/0/libPrefsModule.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Preferences/Keyboard.prefs/Keyboard
+
.include <bsd.port.mk>