aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2013-02-20 04:34:13 +0800
committerohauer <ohauer@FreeBSD.org>2013-02-20 04:34:13 +0800
commit9ffde0cc1914dc43ab4915f63a7bb015a7a50e4a (patch)
treecbc18f984e1f8ee36d84dc2c981e2e434387ff99
parent8906091e8acf2dc35b95b7104dba74bea01fcd6f (diff)
downloadfreebsd-ports-gnome-9ffde0cc1914dc43ab4915f63a7bb015a7a50e4a.tar.gz
freebsd-ports-gnome-9ffde0cc1914dc43ab4915f63a7bb015a7a50e4a.tar.zst
freebsd-ports-gnome-9ffde0cc1914dc43ab4915f63a7bb015a7a50e4a.zip
- create conflict entry for postgis20
- adopt new Makefile header and OPTIONS NG - rename patches so they match patchfile nameing style
-rw-r--r--databases/postgis/Makefile25
-rw-r--r--databases/postgis/files/patch-doc__Makefile.in (renamed from databases/postgis/files/patch-doc-Makefile.in)0
-rw-r--r--databases/postgis/files/patch-doc__html__image_src__Makefile.in (renamed from databases/postgis/files/patch-doc-html-image_src-Makefile.in)0
-rw-r--r--databases/postgis/files/patch-loader__Makefile.in (renamed from databases/postgis/files/patch-loader-Makefile.in)0
-rw-r--r--databases/postgis/files/patch-postgis__Makefile.in (renamed from databases/postgis/files/patch-postgis-Makefile.in)0
5 files changed, 12 insertions, 13 deletions
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index 1694c58724d3..fa213749e5d8 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: PostGIS
-# Date created: June 09, 2004
-# Whom: Anderson Soares Ferreira <anderson@cnpm.embrapa.br>
-#
+# Created by: Anderson Soares Ferreira <anderson@cnpm.embrapa.br>
# $FreeBSD$
-#
PORTNAME= postgis
PORTVERSION= 1.5.3
@@ -15,30 +11,33 @@ MASTER_SITES= http://postgis.refractions.net/download/ \
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Adds support for geographic objects to PostgreSQL databases
-LIB_DEPENDS= proj.7:${PORTSDIR}/graphics/proj \
- geos.0:${PORTSDIR}/graphics/geos
+LIB_DEPENDS= proj:${PORTSDIR}/graphics/proj \
+ geos:${PORTSDIR}/graphics/geos
RUN_DEPENDS= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
+CONFLICTS= postgis-2.*
+
USE_BISON= build
+USE_GNOME= libxml2
USE_PGSQL= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
USE_PERL5_BUILD= yes
-OPTIONS= LOADERGUI "Enable shp2pgsql-gui" Off
+OPTIONS_DEFINE= LOADERGUI
+LOADERGUI_DESC= Enable shp2pgsql-gui
.include <bsd.port.options.mk>
INSTALL_TARGET= install
-GNU_CONFIGURE= yes
-.if defined(WITH_LOADERGUI)
-USE_GNOME= libxml2 gtk20
+.if ${PORT_OPTIONS:MLOADERGUI}
+USE_GNOME+= gtk20
CONFIGURE_ARGS= --with-projdir=${LOCALBASE} --with-gui
PLIST_SUB+= LOADERGUI=""
.else
-USE_GNOME= libxml2
CONFIGURE_ARGS= --with-projdir=${LOCALBASE}
PLIST_SUB+= LOADERGUI="@comment "
.endif
@@ -50,7 +49,7 @@ MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/html/chunk.xsl:${PORTSDIR}/textproc/docbook-xsl
CONFIGURE_ARGS+= --with-xsldir=${LOCALBASE}/share/xsl/docbook
diff --git a/databases/postgis/files/patch-doc-Makefile.in b/databases/postgis/files/patch-doc__Makefile.in
index 796fced2d04c..796fced2d04c 100644
--- a/databases/postgis/files/patch-doc-Makefile.in
+++ b/databases/postgis/files/patch-doc__Makefile.in
diff --git a/databases/postgis/files/patch-doc-html-image_src-Makefile.in b/databases/postgis/files/patch-doc__html__image_src__Makefile.in
index cc66e6d3f6f9..cc66e6d3f6f9 100644
--- a/databases/postgis/files/patch-doc-html-image_src-Makefile.in
+++ b/databases/postgis/files/patch-doc__html__image_src__Makefile.in
diff --git a/databases/postgis/files/patch-loader-Makefile.in b/databases/postgis/files/patch-loader__Makefile.in
index 801f8c6c8acd..801f8c6c8acd 100644
--- a/databases/postgis/files/patch-loader-Makefile.in
+++ b/databases/postgis/files/patch-loader__Makefile.in
diff --git a/databases/postgis/files/patch-postgis-Makefile.in b/databases/postgis/files/patch-postgis__Makefile.in
index 6562c4cfda54..6562c4cfda54 100644
--- a/databases/postgis/files/patch-postgis-Makefile.in
+++ b/databases/postgis/files/patch-postgis__Makefile.in