aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2006-08-15 01:57:15 +0800
committermi <mi@FreeBSD.org>2006-08-15 01:57:15 +0800
commita079321b20e3e0b41881f7c49f9187b01906f60f (patch)
tree9312372cea609ec248d18de897ce5c29eea5a850
parent80dcb1529e459534acc17b1ae8489d8411ea5915 (diff)
downloadfreebsd-ports-gnome-a079321b20e3e0b41881f7c49f9187b01906f60f.tar.gz
freebsd-ports-gnome-a079321b20e3e0b41881f7c49f9187b01906f60f.tar.zst
freebsd-ports-gnome-a079321b20e3e0b41881f7c49f9187b01906f60f.zip
Submit to Kris' insistence and mark BROKEN on -current. c++ gives up the
ghost (internal compiler error) on a particular file. Work is ongoing to submit this to the GCC people, who will, no doubt, berate us for using an old version of compiler, etc., etc., etc...
-rw-r--r--print/lyx-devel/Makefile2
-rw-r--r--print/lyx/Makefile2
-rw-r--r--print/lyx14/Makefile2
-rw-r--r--print/lyx15/Makefile2
-rw-r--r--print/lyx16/Makefile2
5 files changed, 10 insertions, 0 deletions
diff --git a/print/lyx-devel/Makefile b/print/lyx-devel/Makefile
index 8ccac45d5e2a..b1480ffcb0a4 100644
--- a/print/lyx-devel/Makefile
+++ b/print/lyx-devel/Makefile
@@ -95,6 +95,8 @@ QT_PRESENT= off
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
+.elif ${OSVERSION} >= 700007 && ${CXX} == c++
+BROKEN= C++ compiler seg-faults, try using a different one and report to ${MAINTAINER}
.endif
.include <bsd.port.post.mk>
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 8ccac45d5e2a..b1480ffcb0a4 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -95,6 +95,8 @@ QT_PRESENT= off
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
+.elif ${OSVERSION} >= 700007 && ${CXX} == c++
+BROKEN= C++ compiler seg-faults, try using a different one and report to ${MAINTAINER}
.endif
.include <bsd.port.post.mk>
diff --git a/print/lyx14/Makefile b/print/lyx14/Makefile
index 8ccac45d5e2a..b1480ffcb0a4 100644
--- a/print/lyx14/Makefile
+++ b/print/lyx14/Makefile
@@ -95,6 +95,8 @@ QT_PRESENT= off
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
+.elif ${OSVERSION} >= 700007 && ${CXX} == c++
+BROKEN= C++ compiler seg-faults, try using a different one and report to ${MAINTAINER}
.endif
.include <bsd.port.post.mk>
diff --git a/print/lyx15/Makefile b/print/lyx15/Makefile
index 8ccac45d5e2a..b1480ffcb0a4 100644
--- a/print/lyx15/Makefile
+++ b/print/lyx15/Makefile
@@ -95,6 +95,8 @@ QT_PRESENT= off
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
+.elif ${OSVERSION} >= 700007 && ${CXX} == c++
+BROKEN= C++ compiler seg-faults, try using a different one and report to ${MAINTAINER}
.endif
.include <bsd.port.post.mk>
diff --git a/print/lyx16/Makefile b/print/lyx16/Makefile
index 8ccac45d5e2a..b1480ffcb0a4 100644
--- a/print/lyx16/Makefile
+++ b/print/lyx16/Makefile
@@ -95,6 +95,8 @@ QT_PRESENT= off
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
+.elif ${OSVERSION} >= 700007 && ${CXX} == c++
+BROKEN= C++ compiler seg-faults, try using a different one and report to ${MAINTAINER}
.endif
.include <bsd.port.post.mk>