aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-06 15:03:22 +0800
committerbapt <bapt@FreeBSD.org>2014-05-06 15:03:22 +0800
commita1b59e4c19cd181a1cae647d0b40aa3c64169666 (patch)
tree4a6b5d4fdf2b0a704e72445b4863aa4b81f7bcdd
parentf562d6d05c4dac492696314b230243a70a25e0f3 (diff)
downloadfreebsd-ports-gnome-a1b59e4c19cd181a1cae647d0b40aa3c64169666.tar.gz
freebsd-ports-gnome-a1b59e4c19cd181a1cae647d0b40aa3c64169666.tar.zst
freebsd-ports-gnome-a1b59e4c19cd181a1cae647d0b40aa3c64169666.zip
Fix build after r353029
Change to 'USES=compiler:gcc-c++11-lib' to simplify the makefile PR: ports/189389 Submitted by: Rainer Hurling <rhurlin@gwdg.de> (maintainer)
-rw-r--r--math/saga/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 8f8ffd6b5ac6..7eb8cd8c57b0 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -3,7 +3,7 @@
PORTNAME= saga
PORTVERSION= 2.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -18,7 +18,7 @@ LIB_DEPENDS= libproj.so:${PORTSDIR}/graphics/proj \
libgdal.so:${PORTSDIR}/graphics/gdal \
libjasper.so:${PORTSDIR}/graphics/jasper \
libtiff.so:${PORTSDIR}/graphics/tiff \
- libiodbc.so:${PORTSDIR}/databases/libiodbc \
+ libodbc.so:${PORTSDIR}/databases/unixODBC \
liblas.so:${PORTSDIR}/devel/liblas \
libopencv_ml.so:${PORTSDIR}/graphics/opencv
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -33,7 +33,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -lopencv_core
USE_PYTHON= 2
USE_LDCONFIG= yes
USE_WX= 3.0
-USES= compiler:features iconv:wchar_t dos2unix libtool
+USES= compiler:gcc-c++11-lib iconv:wchar_t dos2unix libtool
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WX_UNICODE= yes
@@ -64,15 +64,6 @@ VIGRA_RUN_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:${PORTSDIR}/graphics/vigra
.include <bsd.port.pre.mk>
-# CLANG is not able to handle neither Fortran nor OpenMP
-USE_GCC= yes
-.if ${COMPILER_FEATURES:Mlibc++}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/c++/libstdc++.so:${PORTSDIR}/devel/libc++
-CFLAGS+= -isystem ${LOCALBASE}/include/c++/v1
-CXXFLAGS+= -nostdinc++ -isystem ${LOCALBASE}/include/c++/v1
-LDFLAGS+= -L${LOCALBASE}/lib/c++
-.endif
-
post-patch:
@${REINPLACE_CMD} -e's|wx-config |${WX_CONFIG} |g' \
${WRKSRC}/configure \