aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-01-07 22:49:49 +0800
committerwxs <wxs@FreeBSD.org>2009-01-07 22:49:49 +0800
commita227fd3a5a9f9c9427d0fe45625c56668a72769b (patch)
treed7f226ecb5c650d2ea3b828c8d01f66118616cd0
parent520bfb98d90e6fdf3ed2454f4d19393a39f6a5d5 (diff)
downloadfreebsd-ports-gnome-a227fd3a5a9f9c9427d0fe45625c56668a72769b.tar.gz
freebsd-ports-gnome-a227fd3a5a9f9c9427d0fe45625c56668a72769b.tar.zst
freebsd-ports-gnome-a227fd3a5a9f9c9427d0fe45625c56668a72769b.zip
- Make dejavu font an optional dependency
PR: ports/129716 Submitted by: Guido Falsi <mad@madpilot.net> Approved by: bg1tpt@gmail.com (maintainer)
-rw-r--r--databases/rrdtool/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index cc2d61c29a23..a174836625dc 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
png.5:${PORTSDIR}/graphics/png \
xml2.5:${PORTSDIR}/textproc/libxml2 \
pangocairo-1\.0.0:${PORTSDIR}/x11-toolkits/pango
-RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/dejavu:${PORTSDIR}/x11-fonts/dejavu
CONFLICTS= rrdtool-1.0*
@@ -37,9 +36,11 @@ PORTEXAMPLES= 4charts.pl bigtops.pl cgi-demo.cgi minmax.pl piped-demo.pl \
OPTIONS= PYTHON_MODULE "Build PYTHON bindings" off \
RUBY_MODULE "Build RUBY bindings" off \
- PERL_MODULE "Build PERL module" on
+ PERL_MODULE "Build PERL module" on \
+ DEJAVU "Use DejaVu fonts (requires X11)" off
.include <bsd.port.pre.mk>
+
.if defined(WITH_PYTHON_MODULE)
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"
@@ -69,6 +70,10 @@ CONFIGURE_ARGS+= --disable-perl
PLIST_SUB+= WITH_PERL="@comment "
.endif
+.if exists(${LOCALBASE}/lib/X11/fonts/dejavu) || defined(WITH_DEJAVU)
+RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/dejavu:${PORTSDIR}/x11-fonts/dejavu
+.endif
+
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-ffast-math}