aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-11 21:49:05 +0800
committerbapt <bapt@FreeBSD.org>2013-05-11 21:49:05 +0800
commitab8c25e75ecf5274b88323c941b9998c5fbef10c (patch)
tree49a9058687c46613437d48ef342bd3cd3963c552
parent891ac64752dab6caa5f5b015394819bb4d9bbc72 (diff)
downloadfreebsd-ports-gnome-ab8c25e75ecf5274b88323c941b9998c5fbef10c.tar.gz
freebsd-ports-gnome-ab8c25e75ecf5274b88323c941b9998c5fbef10c.tar.zst
freebsd-ports-gnome-ab8c25e75ecf5274b88323c941b9998c5fbef10c.zip
Convert to new options framework
-rw-r--r--devel/ode-devel/Makefile12
-rw-r--r--devel/ode/Makefile26
-rw-r--r--devel/p5-Any-Moose/Makefile10
-rw-r--r--devel/p5-Config-Auto/Makefile14
-rw-r--r--devel/p5-DateTime-Util-Calc/Makefile8
-rw-r--r--devel/p5-Test-NoWarnings/Makefile15
-rw-r--r--devel/p5-Test-YAML-Valid/Makefile11
-rw-r--r--devel/pth/Makefile15
-rw-r--r--devel/ptypes/Makefile20
-rw-r--r--devel/sdl_console/Makefile15
-rw-r--r--devel/spin/Makefile24
11 files changed, 73 insertions, 97 deletions
diff --git a/devel/ode-devel/Makefile b/devel/ode-devel/Makefile
index da1908003e9f..800fdb238dcf 100644
--- a/devel/ode-devel/Makefile
+++ b/devel/ode-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ode
-# Date created: 11 Oct 2003
-# Whom: David Yeske <dyeske@yahoo.com>
-#
+# Created by: David Yeske <dyeske@yahoo.com>
# $FreeBSD$
-#
PORTNAME= ode
DISTVERSION= ${ODEVER}-060223
@@ -24,7 +20,9 @@ USE_GL= yes
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
-OPTIONS= OPCODE "Enable code required by TriList (trimesh) class" on
+OPTIONS_DEFINE= OPCODE
+OPTIONS_DEFAULT= OPCODE
+OPCODE_DESC= Enable code required by TriList (trimesh) class
.include <bsd.port.pre.mk>
@@ -40,7 +38,7 @@ post-patch:
s|-L/usr/lib/X11R6||; s|-L/usr/lib/X11||; s|-L/usr/X11R6/lib|-L${LOCALBASE}/lib|; \
s|-fno-rtti||; s|-ffast-math|${CXXFLAGS} -I${LOCALBASE}/include|' \
${WRKSRC}/config/makefile.unix-gcc
-.if !defined(WITHOUT_OPCODE)
+.if ${PORT_OPTIONS:MOPCODE}
@${REINPLACE_CMD} -e 's/^#OPCODE_DIRECTORY/OPCODE_DIRECTORY/' \
${WRKSRC}/config/user-settings
.endif
diff --git a/devel/ode/Makefile b/devel/ode/Makefile
index b27f1def391c..6eb43a6ff19d 100644
--- a/devel/ode/Makefile
+++ b/devel/ode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ode
-# Date created: 11 Oct 2003
-# Whom: David Yeske <dyeske@yahoo.com>
-#
+# Created by: David Yeske <dyeske@yahoo.com>
# $FreeBSD$
-#
PORTNAME= ode
PORTVERSION= 0.11.1
@@ -23,10 +19,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-OPTIONS= GIMPACT "Enable gimpact instead of opcode support" off \
- GYROSCOPIC "Configure ODE to work with gyroscopic term" on \
- DOUBLE "Enable double precision (BROKEN with GIMPACT)" off \
- OU "Enable Thread-local storage (Experimental)" off
+OPTIONS_DEFINE= GIMPACT GYROSCOPIC DOUBLE OU
+OPTIONS_DEFAULT= GYROSCOPIC
+GIMPACT_DESC= Enable gimpact instead of opcode support
+GYROSCOPIC_DESC= Configure ODE to work with gyroscopic term
+DOUBLE_DESC= Enable double precision (BROKEN with GIMPACT)
+OU_DESC= Enable Thread-local storage (Experimental)
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -36,25 +34,25 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CFLAGS+= -fPIC -DPIC
.endif
-.if defined(WITH_GIMPACT) && defined(WITH_DOUBLE)
+.if ${PORT_OPTIONS:MGIMPACT) && defined(WITH_DOUBLE}
IGNORE= currently double precision is not supported by gimpact
.endif
-.if !defined(WITH_GIMPACT)
+.if ! ${PORT_OPTIONS:MGIMPACT}
CONFIGURE_ARGS+= --with-trimesh=opcode
.else
CONFIGURE_ARGS+= --with-trimesh=gimpact
.endif
-.if defined(WITHOUT_GYROSCOPIC)
+.if ! ${PORT_OPTIONS:MGYROSCOPIC}
CONFIGURE_ARGS+= --disable-gyroscopic
.endif
-.if defined(WITH_DOUBLE)
+.if ${PORT_OPTIONS:MDOUBLE}
CONFIGURE_ARGS+= --enable-double-precision
.endif
-.if defined(WITH_OU)
+.if ${PORT_OPTIONS:MOU}
CONFIGURE_ARGS+= --enable-ou
.else
CONFIGURE_ARGS+= --disable-ou
diff --git a/devel/p5-Any-Moose/Makefile b/devel/p5-Any-Moose/Makefile
index 6adf60e6a7e8..0bcf7cd22ac5 100644
--- a/devel/p5-Any-Moose/Makefile
+++ b/devel/p5-Any-Moose/Makefile
@@ -16,17 +16,19 @@ PERL_CONFIGURE= yes
MAN3= Any::Moose.3
-OPTIONS= MOOSE "Use Moose" off \
- MOUSE "Use Mouse" on
+OPTIONS_DEFINE= MOOSE MOUSE
+OPTIONS_DEFAULT= MOUSE
+MOOSE_DESC= Use Moose
+MOUSE_DESC= Use Mouse
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_MOOSE)
+.if ${PORT_OPTIONS:MMOOSE}
BUILD_DEPENDS+= p5-Moose>0:${PORTSDIR}/devel/p5-Moose
RUN_DEPENDS+= p5-Moose>0:${PORTSDIR}/devel/p5-Moose
.endif
-.if defined(WITH_MOUSE)
+.if ${PORT_OPTIONS:MMOUSE}
BUILD_DEPENDS+= p5-Mouse>=0.40:${PORTSDIR}/devel/p5-Mouse
RUN_DEPENDS+= p5-Mouse>=0.40:${PORTSDIR}/devel/p5-Mouse
.endif
diff --git a/devel/p5-Config-Auto/Makefile b/devel/p5-Config-Auto/Makefile
index dbb713fbf3d0..5070604bb145 100644
--- a/devel/p5-Config-Auto/Makefile
+++ b/devel/p5-Config-Auto/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: p5-Config-Auto
-# Date created: August 29 2003
-# Whom: Lars Thegler <lars@thegler.dk>
-#
+# Created by: Lars Thegler <lars@thegler.dk>
# $FreeBSD$
PORTNAME= Config-Auto
@@ -21,15 +18,16 @@ TEST_DEPENDS= p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String
PERL_CONFIGURE= yes
-OPTIONS= XMLSIMPLE "Support for XML config files" off
+OPTIONS_DEFINE= XMLSIMPLE
+XMLSIMPLE_DESC= Support for XML config files
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifdef(WITH_XMLSIMPLE)
+.if ${PORT_OPTIONS:MXMLSIMPLE}
BUILD_DEPENDS+= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
RUN_DEPENDS+= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
.endif
MAN3= Config::Auto.3
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Util-Calc/Makefile b/devel/p5-DateTime-Util-Calc/Makefile
index 726888476e84..a8a51f6d4265 100644
--- a/devel/p5-DateTime-Util-Calc/Makefile
+++ b/devel/p5-DateTime-Util-Calc/Makefile
@@ -19,12 +19,12 @@ PERL_CONFIGURE= yes
MAN3= DateTime::Util::Calc.3
-OPTIONS= GMP "Use GMP library" off
+OPTIONS_DEFINE= GMP
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GMP)
+.if ${PORT_OPTIONS:MGMP}
BUILD_DEPENDS+= p5-Math-BigInt-GMP>=0:${PORTSDIR}/math/p5-Math-BigInt-GMP
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-NoWarnings/Makefile b/devel/p5-Test-NoWarnings/Makefile
index 2b132b140d7d..81f01f5732b2 100644
--- a/devel/p5-Test-NoWarnings/Makefile
+++ b/devel/p5-Test-NoWarnings/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Test-NoWarnings
-# Date created: May 12th 2004
-# Whom: Alex Kapranoff <alex@kapranoff.ru>
-#
+# Created by: Alex Kapranoff <alex@kapranoff.ru>
# $FreeBSD$
-#
PORTNAME= Test-NoWarnings
PORTVERSION= 1.04
@@ -21,13 +17,14 @@ PERL_CONFIGURE= yes
MAN3= Test::NoWarnings.3
-OPTIONS= DEVEL_STACKTRACE "Stack trace support" off
+OPTIONS_DEFINE= DEVEL_STACKTRACE
+DEVEL_STACKTRACE_DESC= Stack trace support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEVEL_STACKTRACE)
+.if ${PORT_OPTIONS:MDEVEL_STACKTRACE}
BUILD_DEPENDS+= p5-Devel-StackTrace>=0:${PORTSDIR}/devel/p5-Devel-StackTrace
RUN_DEPENDS+= p5-Devel-StackTrace>=0:${PORTSDIR}/devel/p5-Devel-StackTrace
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-YAML-Valid/Makefile b/devel/p5-Test-YAML-Valid/Makefile
index d24adcf62cc9..693e140434a3 100644
--- a/devel/p5-Test-YAML-Valid/Makefile
+++ b/devel/p5-Test-YAML-Valid/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Test-YAML-Valid
-# Date created: 10 April 2007
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Test-YAML-Valid
PORTVERSION= 0.04
@@ -22,14 +18,15 @@ PERL_CONFIGURE= yes
MAN3= Test::YAML::Valid.3
-OPTIONS= YAMLSYCK "Use YAML::Syck for testing" OFF
+OPTIONS_DEFINE= YAMLSYCK
+YAMLSYCK_DESC= Use YAML::Syck for testing
post-patch:
${PERL} -pi -e '$$_="" if /auto_install/' ${WRKSRC}/Makefile.PL
.include <bsd.port.options.mk>
-.if defined(WITH_YAMLSYCK)
+.if ${PORT_OPTIONS:MYAMLSYCK}
RUN_DEPENDS+= p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck
BUILD_DEPENDS+= p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck
.endif
diff --git a/devel/pth/Makefile b/devel/pth/Makefile
index 5ed43b6bed95..4f58ab084831 100644
--- a/devel/pth/Makefile
+++ b/devel/pth/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: GNU Pth
-# Date Created: 23 May 1999
-# Whom: Ralf S. Engelschall <rse@gnu.org>
-#
+# Created by: Ralf S. Engelschall <rse@gnu.org>
# $FreeBSD$
-#
PORTNAME= pth
PORTVERSION= 2.0.7
@@ -27,11 +23,12 @@ CONFIGURE_ARGS= --enable-optimize \
MAN1= pth-config.1
MAN3= pth.3
-OPTIONS= OPTIMIZED_CFLAGS "Build with optimized CFLAGS" on
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
CONFLICTS?= pth-hard-2.*
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PKGNAMESUFFIX} == "-hard"
CONFIGURE_ARGS+= --enable-syscall-hard --disable-syscall-soft
@@ -44,7 +41,7 @@ MAN3+= pthread.3
.endif
post-patch:
-.if defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ! ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
${REINPLACE_CMD} -e \
's|-funroll-loops -fstrength-reduce -fomit-frame-pointer -ffast-math||' \
${WRKSRC}/configure
@@ -56,4 +53,4 @@ post-build:
test: build
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ptypes/Makefile b/devel/ptypes/Makefile
index c253f2610223..d2746017af65 100644
--- a/devel/ptypes/Makefile
+++ b/devel/ptypes/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: ptypes
-# Date created: Aug 12, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= ptypes
PORTVERSION= 2.1.1
@@ -21,19 +16,18 @@ PLIST_SUB+= SHLIB_VER=${SHLIB_VER}
PTYPES_CFLAGS= ${CFLAGS}
MAKE_JOBS_UNSAFE= yes
-OPTIONS= DEBUG "Build debug version" off \
- OPTIMIZED "Enable -O2 optimization" off
+OPTIONS_DEFINE= DEBUG OPTIMIZED_CFLAGS DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "powerpc"
BROKEN= Does not install on powerpc
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
DEBUG_FLAGS= "-DDEBUG -g"
.endif
-.if defined(WITH_OPTIMIZED)
+.if ${PORT_OPTIONS:MOPTIMIZED}
PTYPES_CFLAGS+=-O2
.endif
@@ -48,7 +42,7 @@ do-install:
${PREFIX}/lib
cd ${PREFIX}/lib; ${LN} -sf libptypes.so.${SHLIB_VER} libptypes.so
${INSTALL_DATA} ${WRKSRC}/lib/* ${PREFIX}/lib
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${EXAMPLESDIR}/wshare
-${RM} -f ${WRKSRC}/wshare/*.o ${WRKSRC}/wshare/*.orig
${INSTALL_DATA} ${WRKSRC}/wshare/*.* ${EXAMPLESDIR}/wshare
@@ -58,4 +52,4 @@ do-install:
cd ${WRKSRC}/doc; ${TAR} cf - *| ${TAR} xf - -C ${DOCSDIR}/doc
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/sdl_console/Makefile b/devel/sdl_console/Makefile
index 0ef2262dd63a..e7c9f90c2ffd 100644
--- a/devel/sdl_console/Makefile
+++ b/devel/sdl_console/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SDL Console
-# Date created: 2008-04-27
-# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
-#
+# Created by: Yen-Ming Lee <leeym@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= sdl_console
PORTVERSION= 2.1
@@ -19,15 +15,16 @@ USE_SDL= sdl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-OPTIONS= SDL_IMAGE "SDL Image support" Off
+OPTIONS_DEFINE= SDL_IMAGE
+SDL_IMAGE_DESC= SDL Image support
post-patch:
@${REINPLACE_CMD} -e '/objformat/s/aout/elf/' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_SDL_IMAGE)
+.if ${PORT_OPTIONS:MSDL_IMAGE}
USE_SDL+= image
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/spin/Makefile b/devel/spin/Makefile
index 7abae8405881..8e5ee9916679 100644
--- a/devel/spin/Makefile
+++ b/devel/spin/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: spin
-# Date created: Oct 23, 1997
-# Whom: jhanna@home.com
-#
+# Created by: jhanna@home.com
# $FreeBSD$
-#
PORTNAME= spin
PORTVERSION= 5.2.2
@@ -14,11 +10,13 @@ DISTNAME= spin${PORTVERSION:S/.//g}
MAINTAINER= jhanna@shaw.ca
COMMENT= An on-the-fly verification system for asynchronous concurrent systems
-OPTIONS= XSPIN "Install xspin and TCL/Tk dependency" on
+OPTIONS_DEFINE= XSPIN DOCS
+OPTIONS_DEFAULT= XSPIN
+XSPIN_DESC= Install xspin and TCL/Tk dependency
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_XSPIN)
+.if ${PORT_OPTIONS:MXSPIN}
RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
PLIST_SUB+= XSPIN=""
XSPIN_TCL= ${WRKDIR}/Spin/Xspin5.2/xspin521.tcl
@@ -37,13 +35,13 @@ post-extract:
@${ECHO_MSG} "Unbundling promela example files..."
@cd ${WRKDIR}/Spin/Test && ${SH} ${WRKDIR}/Spin/Test/examples
-.if !defined(WITHOUT_XSPIN)
+.if ${PORT_OPTIONS:MXSPIN}
pre-patch:
@${TR} -d '\r' < ${XSPIN_TCL} > ${XSPIN_TCL}.tmp
@${MV} -f ${XSPIN_TCL}.tmp ${XSPIN_TCL}
.endif
-.if !defined(WITHOUT_XSPIN)
+.if ${PORT_OPTIONS:MXSPIN}
post-patch:
@${REINPLACE_CMD} \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g;" \
@@ -52,10 +50,10 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spin ${PREFIX}/bin
-.if !defined(WITHOUT_XSPIN)
+.if ${PORT_OPTIONS:MXSPIN}
${INSTALL_SCRIPT} ${XSPIN_TCL} ${PREFIX}/bin/xspin
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/Doc
${MKDIR} ${DOCSDIR}/Examples
${MKDIR} ${DOCSDIR}/Test
@@ -72,4 +70,4 @@ MANPAGE_WRKSRC= ${WRKDIR}/Spin/Man
MAN1= spin.1
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>