aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2005-05-10 12:16:21 +0800
committersumikawa <sumikawa@FreeBSD.org>2005-05-10 12:16:21 +0800
commitac8784c4c1267f231672a1d2254ca6f709a3ce95 (patch)
tree76fd638f52744ae31f94376fc8295dd4f5ec066a
parent7833611ec9cb1db24945e7c5f81baa90eb696799 (diff)
downloadfreebsd-ports-gnome-ac8784c4c1267f231672a1d2254ca6f709a3ce95.tar.gz
freebsd-ports-gnome-ac8784c4c1267f231672a1d2254ca6f709a3ce95.tar.zst
freebsd-ports-gnome-ac8784c4c1267f231672a1d2254ca6f709a3ce95.zip
Upgrade to 20050510a. This is final release from KAME project.
racoon will be officially developed and supported by ipsec-tools team. See ftp://ftp.kame.net/pub/mail-list/snap-users/9012 in detail.
-rw-r--r--security/racoon/Makefile3
-rw-r--r--security/racoon/distinfo4
-rw-r--r--security/racoon/files/patch-crypto_openssl.c42
-rw-r--r--security/racoon/files/patch-pfkey_dump.c20
4 files changed, 23 insertions, 46 deletions
diff --git a/security/racoon/Makefile b/security/racoon/Makefile
index a68efae0f18e..97f9f1b3864a 100644
--- a/security/racoon/Makefile
+++ b/security/racoon/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= racoon
-PORTVERSION= 20040818a
-PORTREVISION= 1
+PORTVERSION= 20050510a
CATEGORIES= security net ipv6
MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
diff --git a/security/racoon/distinfo b/security/racoon/distinfo
index 62ac81a89bd5..2ef8af27d24d 100644
--- a/security/racoon/distinfo
+++ b/security/racoon/distinfo
@@ -1,2 +1,2 @@
-MD5 (racoon-20040818a.tar.gz) = c983587afc2772c11e4b81c3b4b9dfc4
-SIZE (racoon-20040818a.tar.gz) = 397275
+MD5 (racoon-20050510a.tar.gz) = 50a43fa2151e52aa138922fdd9466691
+SIZE (racoon-20050510a.tar.gz) = 398231
diff --git a/security/racoon/files/patch-crypto_openssl.c b/security/racoon/files/patch-crypto_openssl.c
deleted file mode 100644
index 3f243d19c8e2..000000000000
--- a/security/racoon/files/patch-crypto_openssl.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- crypto_openssl.old.c 2004-04-09 22:25:56.000000000 +0530
-+++ crypto_openssl.c 2004-08-02 20:30:03.000000000 +0530
-@@ -1654,6 +1654,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (SHA512_DIGEST_LENGTH != res->l) {
-@@ -1710,6 +1711,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (SHA384_DIGEST_LENGTH != res->l) {
-@@ -1766,6 +1768,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (SHA256_DIGEST_LENGTH != res->l) {
-@@ -1823,6 +1826,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (SHA_DIGEST_LENGTH != res->l) {
-@@ -1879,6 +1883,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (MD5_DIGEST_LENGTH != res->l) {
diff --git a/security/racoon/files/patch-pfkey_dump.c b/security/racoon/files/patch-pfkey_dump.c
new file mode 100644
index 000000000000..d05adf29811b
--- /dev/null
+++ b/security/racoon/files/patch-pfkey_dump.c
@@ -0,0 +1,20 @@
+--- ../libipsec/pfkey_dump.c.orig Mon Jan 31 17:25:28 2005
++++ ../libipsec/pfkey_dump.c Tue May 10 13:00:38 2005
+@@ -532,7 +532,7 @@ str_prefport(family, pref, port, ulp)
+ else
+ snprintf(prefbuf, sizeof(prefbuf), "/%u", pref);
+
+- if (ulp == IPPROTO_ICMPV6 || ulp == IPPROTO_MH)
++ if (ulp == IPPROTO_ICMPV6)
+ memset(portbuf, 0, sizeof(portbuf));
+ else {
+ if (port == IPSEC_PORT_ANY)
+@@ -570,8 +570,6 @@
+ else
+ printf("%u", ulp);
+
+- if (ulp == IPPROTO_MH && p1 != 0)
+- printf(" %u", p1);
+ endprotoent();
+ break;
+ }