aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-01-18 00:53:10 +0800
committergarga <garga@FreeBSD.org>2006-01-18 00:53:10 +0800
commitaf1ef33eb1951332dc778c2a60e4e3190c05e9a0 (patch)
treecc0b977119855ce421a5870c8fd85b3dcbffc8ef
parent2761dc2af128406d9c634dd50f8f8fa778553ee4 (diff)
downloadfreebsd-ports-gnome-af1ef33eb1951332dc778c2a60e4e3190c05e9a0.tar.gz
freebsd-ports-gnome-af1ef33eb1951332dc778c2a60e4e3190c05e9a0.tar.zst
freebsd-ports-gnome-af1ef33eb1951332dc778c2a60e4e3190c05e9a0.zip
- Use LIB_DEPENDS instead some BUILD_DEPENDS
PR: ports/91848 Submitted by: maintainer
-rw-r--r--audio/xmms2/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 361a9074c7fc..ee988b952ba2 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -42,8 +42,8 @@ PLIST_SUB+= CURL="@comment "
.endif
.if defined(WITH_SID)
-LIB_DEPENDS+= resid.0:${PORTSDIR}/audio/resid \
- sidplay.2:${PORTSDIR}/audio/libsidplay2
+LIB_DEPENDS+= resid.[0-9]:${PORTSDIR}/audio/resid \
+ sidplay2.[0-9]:${PORTSDIR}/audio/libsidplay2
PLIST_SUB+= SID=""
.else
EXCLUDE+= sid
@@ -67,7 +67,7 @@ PLIST_SUB+= RUBY="@comment "
.endif
.if defined(WITH_ECORE)
-BUILD_DEPENDS+= ecore.1:${PORTSDIR}/x11/ecore
+LIB_DEPENDS+= lecore.1:${PORTSDIR}/x11/ecore
PLIST_SUB+= ECORE=""
.else
EXCLUDE+= xmmsclient-ecore
@@ -75,7 +75,7 @@ PLIST_SUB+= ECORE="@comment "
.endif
.if defined(WITH_FLAC)
-BUILD_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
PLIST_SUB+= FLAC=""
.else
EXCLUDE+= flac
@@ -83,7 +83,7 @@ PLIST_SUB+= FLAC="@comment "
.endif
.if defined(WITH_FAAD)
-BUILD_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
+LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
PLIST_SUB+= FAAD=""
#EXTRA_PATCHES+= ${FILESDIR}/extraPatch-src::clients::faad::Plugin
.else
@@ -101,7 +101,7 @@ PLIST_SUB+= SDL="@comment "
.endif
.if defined(WITH_MUSEPACK)
-BUILD_DEPENDS+= mpcdec.3:${PORTSDIR}/audio/libmpcdec
+LIB_DEPENDS+= mpcdec.3:${PORTSDIR}/audio/libmpcdec
PLIST_SUB+= MUSEPACK=""
.else
EXCLUDE+= musepack