aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2011-06-06 19:19:40 +0800
committergerald <gerald@FreeBSD.org>2011-06-06 19:19:40 +0800
commitb5a2a5f3dd05383ac6aecc7a574df9e75233773e (patch)
tree37882fe4372cb20b61d40df46cfc8c755e396123
parent611d7ead1a0f96bc3f136f59bb0958e522351945 (diff)
downloadfreebsd-ports-gnome-b5a2a5f3dd05383ac6aecc7a574df9e75233773e.tar.gz
freebsd-ports-gnome-b5a2a5f3dd05383ac6aecc7a574df9e75233773e.tar.zst
freebsd-ports-gnome-b5a2a5f3dd05383ac6aecc7a574df9e75233773e.zip
Enable c, c++, and fortran (and only these) explicitly by default, and
Java when/where available. [1] Reported by: Scott Allendorf <scott-allendorf@uiowa.edu> [1]
-rw-r--r--lang/gcc45/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 81e3c1affb32..9a4b1f5eb8f0 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -61,6 +61,7 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--disable-nls \
+ --enable-languages=c,c++,fortran \
--enable-lto=no \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
@@ -101,7 +102,8 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
EXTRA_PATCHES+= ${FILESDIR}/java-patch-hier
# FIXME: we are currently getting weird build failures with libjava on
# some 4.x and 5.x systems, which the following works around. PR 81788.
-CONFIGURE_ARGS+=--disable-rpath --enable-libgcj
+CONFIGURE_ARGS+=--disable-rpath \
+ --enable-languages=c,c++,fortran,java
MAN1+= aot-compile${SUFFIX}.1 \
gappletviewer${SUFFIX}.1 \
gc-analyze${SUFFIX}.1 \