aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-12-28 10:48:59 +0800
committerwen <wen@FreeBSD.org>2010-12-28 10:48:59 +0800
commitb7c2850f1b1937a1b33c4255f25428f1274d5c74 (patch)
tree781b3a6de132e2756c21efb013ec3f9bcaa46514
parent27a59e7a107c257326df1b5c23bcb274526e7fab (diff)
downloadfreebsd-ports-gnome-b7c2850f1b1937a1b33c4255f25428f1274d5c74.tar.gz
freebsd-ports-gnome-b7c2850f1b1937a1b33c4255f25428f1274d5c74.tar.zst
freebsd-ports-gnome-b7c2850f1b1937a1b33c4255f25428f1274d5c74.zip
MooseX::MultiMethods provides multi method dispatch based on Moose type
constraints. It does so by providing a multi keyword that extends the method keyword provided by MooseX::Method::Signatures. When invoking a method declared as multi a matching variant is being searched in all the declared multi variants based on the passed parameters and the declared type constraints. If a variant has been found, it will be invoked. If no variant could be found, an exception will be thrown. WWW: http://search.cpan.org/dist/MooseX-MultiMethods/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-MooseX-MultiMethods/Makefile31
-rw-r--r--devel/p5-MooseX-MultiMethods/distinfo2
-rw-r--r--devel/p5-MooseX-MultiMethods/pkg-descr10
-rw-r--r--devel/p5-MooseX-MultiMethods/pkg-plist8
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a8e8620b108d..d4ee969b2779 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1953,6 +1953,7 @@
SUBDIR += p5-MooseX-Method-Signatures
SUBDIR += p5-MooseX-MethodAttributes
SUBDIR += p5-MooseX-MultiInitArg
+ SUBDIR += p5-MooseX-MultiMethods
SUBDIR += p5-MooseX-NonMoose
SUBDIR += p5-MooseX-Object-Pluggable
SUBDIR += p5-MooseX-POE
diff --git a/devel/p5-MooseX-MultiMethods/Makefile b/devel/p5-MooseX-MultiMethods/Makefile
new file mode 100644
index 000000000000..681ef5fc4ebe
--- /dev/null
+++ b/devel/p5-MooseX-MultiMethods/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-MooseX-MultiMethods
+# Date created: Dec 28, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-MultiMethods
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Multi Method Dispatch based on Moose type constraints
+
+RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-aliased>0:${PORTSDIR}/devel/p5-aliased \
+ p5-namespace-autoclean>0:${PORTSDIR}/devel/p5-namespace-autoclean \
+ p5-Devel-Declare>=0.004000:${PORTSDIR}/devel/p5-Devel-Declare \
+ p5-MooseX-Types-VariantTable>=0.03:${PORTSDIR}/devel/p5-MooseX-Types-VariantTable \
+ p5-MooseX-Method-Signatures>=0.29:${PORTSDIR}/devel/p5-MooseX-Method-Signatures \
+ p5-MooseX-Types>0:${PORTSDIR}/devel/p5-MooseX-Types
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= MooseX::MultiMethods.3 \
+ MooseX::MultiMethods::Meta::Method.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-MultiMethods/distinfo b/devel/p5-MooseX-MultiMethods/distinfo
new file mode 100644
index 000000000000..7118e3c7d6d6
--- /dev/null
+++ b/devel/p5-MooseX-MultiMethods/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MooseX-MultiMethods-0.10.tar.gz) = 9890a1b83c21b90a573751f4aa215b8a4cff869848d0fe098bca20fe67cd2061
+SIZE (MooseX-MultiMethods-0.10.tar.gz) = 11815
diff --git a/devel/p5-MooseX-MultiMethods/pkg-descr b/devel/p5-MooseX-MultiMethods/pkg-descr
new file mode 100644
index 000000000000..a8bc0171beb2
--- /dev/null
+++ b/devel/p5-MooseX-MultiMethods/pkg-descr
@@ -0,0 +1,10 @@
+MooseX::MultiMethods provides multi method dispatch based on Moose type
+constraints. It does so by providing a multi keyword that extends the
+method keyword provided by MooseX::Method::Signatures.
+
+When invoking a method declared as multi a matching variant is being searched
+in all the declared multi variants based on the passed parameters and the
+declared type constraints. If a variant has been found, it will be invoked.
+If no variant could be found, an exception will be thrown.
+
+WWW: http://search.cpan.org/dist/MooseX-MultiMethods/
diff --git a/devel/p5-MooseX-MultiMethods/pkg-plist b/devel/p5-MooseX-MultiMethods/pkg-plist
new file mode 100644
index 000000000000..5613e0bc2096
--- /dev/null
+++ b/devel/p5-MooseX-MultiMethods/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/MooseX/MultiMethods.pm
+%%SITE_PERL%%/MooseX/MultiMethods/Meta/Method.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/MultiMethods/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/MultiMethods
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX
+@dirrmtry %%SITE_PERL%%/MooseX/MultiMethods/Meta
+@dirrmtry %%SITE_PERL%%/MooseX/MultiMethods
+@dirrmtry %%SITE_PERL%%/MooseX