aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-05-08 05:27:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-05-08 05:27:38 +0800
commitbbd4d1d79e8359a8bfd98842dfb691eadd7a4643 (patch)
treeae84e5188b42db50e0698d8bc6aa8a51108224cc
parent0768e9a6b367ea7b7e57631458d0cf01b5e35d06 (diff)
downloadfreebsd-ports-gnome-bbd4d1d79e8359a8bfd98842dfb691eadd7a4643.tar.gz
freebsd-ports-gnome-bbd4d1d79e8359a8bfd98842dfb691eadd7a4643.tar.zst
freebsd-ports-gnome-bbd4d1d79e8359a8bfd98842dfb691eadd7a4643.zip
Add tor_instances (from security/tor)
- Add MANPAGES option (split from DOCS option) - Remove TRANSPARENT option - Bump PORTREVISION for package change - While I'm here, update BROKEN: use lowercase for leading character PR: 219116 Submitted by: Yuri Victorovich <yuri@rawbw.com> (maintainer)
-rw-r--r--security/tor-devel/Makefile32
-rw-r--r--security/tor-devel/files/pkg-message.in8
-rw-r--r--security/tor-devel/files/tor.in84
-rw-r--r--security/tor-devel/pkg-plist13
4 files changed, 108 insertions, 29 deletions
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index 21fd88400287..0a77a520f1ec 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= tor
-DISTVERSION= 0.3.0.6
+PORTVERSION= 0.3.0.6
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= TOR
PKGNAMESUFFIX= -devel
@@ -13,9 +14,9 @@ COMMENT= Anonymizing overlay network for TCP
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_mips64= Does not build: error: Need a uint128_t implementation!
-BROKEN_powerpc64= Does not build: error: Need a uint128_t implementation!
-BROKEN_sparc64= Does not build: error: Need a uint128_t implementation!
+BROKEN_mips64= does not build: error: Need a uint128_t implementation!
+BROKEN_powerpc64= does not build: error: Need a uint128_t implementation!
+BROKEN_sparc64= does not build: error: Need a uint128_t implementation!
USES= cpe gmake
CPE_VENDOR= torproject
@@ -27,18 +28,19 @@ CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include" \
TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/" \
TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
-OPTIONS_DEFINE= MANPAGES STATIC_TOR TCMALLOC TOR2WEB TRANSPARENT
+OPTIONS_DEFINE= MANPAGES DOCS STATIC_TOR TCMALLOC TOR2WEB
OPTIONS_SUB= yes
STATIC_TOR_DESC= Build a static tor
TCMALLOC_DESC= Use the tcmalloc memory allocation library
TOR2WEB_DESC= (EXPERT OPTION) Faster but non-anonymous hidden services
-TRANSPARENT_DESC= Transparent proxy support
-OPTIONS_DEFAULT= MANPAGES TRANSPARENT
+OPTIONS_DEFAULT= MANPAGES
USE_RC_SUBR= tor
SUB_FILES= pkg-message
+SUB_LIST= USER="${USERS}" GROUP="${GROUPS}"
+PLIST_SUB= USER="${USERS}" GROUP="${GROUPS}"
GROUPS= _tor
USERS= _tor
@@ -48,8 +50,8 @@ CONFLICTS= tor-[0-9]*
STATIC_TOR_USES= ssl:build
STATIC_TOR_USES_OFF= ssl
-MANPAGES_BUILD_DEPENDS= asciidoc:textproc/asciidoc
-MANPAGES_CONFIGURE_OFF= --disable-asciidoc
+DOCS_BUILD_DEPENDS= asciidoc:textproc/asciidoc
+DOCS_CONFIGURE_OFF= --disable-asciidoc
.include <bsd.port.options.mk>
@@ -84,12 +86,6 @@ LIB_DEPENDS+= libtcmalloc.so:devel/google-perftools
CONFIGURE_ARGS+= --enable-tor2web-mode
.endif
-.if ${PORT_OPTIONS:MTRANSPARENT}
-CONFIGURE_ARGS+= --enable-transparent
-.else
-CONFIGURE_ARGS+= --disable-transparent
-.endif
-
pre-everything::
.if ${PORT_OPTIONS:MTOR2WEB}
@${ECHO_MSG}
@@ -116,12 +112,8 @@ post-patch-STATIC_TOR-on:
@${REINPLACE_CMD} -e "s@-ltcmalloc@${LOCALBASE}/lib/libtcmalloc.a@" \
${WRKSRC}/configure
-post-configure:
- @${REINPLACE_CMD} -e '\|^nodist_man1_MANS =|s|$$|$$(install_mans:=.1)|' \
- ${WRKSRC}/Makefile
-
post-install:
- @${MKDIR} ${STAGEDIR}/var/log/tor ${STAGEDIR}/var/run/tor
+ @${MKDIR} ${STAGEDIR}/var/log/tor ${STAGEDIR}/var/run/tor ${STAGEDIR}/var/db/tor
.if ! ${PORT_OPTIONS:MTOR2WEB}
check regression-test test: build
diff --git a/security/tor-devel/files/pkg-message.in b/security/tor-devel/files/pkg-message.in
index a3155b04a889..52f931c64717 100644
--- a/security/tor-devel/files/pkg-message.in
+++ b/security/tor-devel/files/pkg-message.in
@@ -11,4 +11,12 @@ exploits sequential IP IDs by setting:
sysctl net.inet.ip.random_id=1
(see sysctl.conf(5)).
+
+In order to run additional, independent instances of tor on the same machine
+set tor_instances="inst1 inst2 ..." in your /etc/rc.conf, and create the
+corresponding additional configuration files %%PREFIX%%/etc/tor/torrc@inst1, ...
+
+Alternatively, you can use the extended instance definition to specify all
+instance parameteres explicitly:
+inst_name{:inst_conf:inst_user:inst_group:inst_pidfile:inst_data_dir}
================================================================================
diff --git a/security/tor-devel/files/tor.in b/security/tor-devel/files/tor.in
index 3ea0285e0418..185d9fe3370f 100644
--- a/security/tor-devel/files/tor.in
+++ b/security/tor-devel/files/tor.in
@@ -11,24 +11,99 @@
# they are command line options.
#
# tor_enable (bool): Set it to "YES" to enable tor. Default: NO
+# tor_instances (str): List of instances. Default: ""
# tor_conf (str): Points to your torrc file.
# Default: %%PREFIX%%/etc/tor/torrc
-# tor_user (str): Tor daemon user. Default: _tor
+# tor_user (str): Tor daemon user. Default: %%USER%%
+# tor_group (str): Tor group. Default: %%GROUP%%
+# tor_pidfile (str): Tor pid file. Default: /var/run/tor/tor.pid
# tor_datadir (str): Tor datadir. Default: /var/db/tor
+# tor_disable_default_instance (str): Doesn't run the default instance.
+# Only valid when tor_instances is used.
+# Default: NO
+#
+# The instance definition that tor_instances expects:
+# inst_name{:inst_conf:inst_user:inst_group:inst_pidfile:inst_data_dir}
#
. /etc/rc.subr
name="tor"
rcvar=tor_enable
+exit_code=0
load_rc_config ${name}
: ${tor_enable="NO"}
+: ${tor_instances=""}
: ${tor_conf="%%PREFIX%%/etc/tor/torrc"}
-: ${tor_user="_tor"}
+: ${tor_user="%%USER%%"}
+: ${tor_group="%%GROUP%%"}
: ${tor_pidfile="/var/run/tor/tor.pid"}
: ${tor_datadir="/var/db/tor"}
+: ${tor_disable_default_instance="NO"}
+
+instance=${slave_instance}
+if [ -n "${instance}" ]; then
+ inst_def=${instance}
+ inst_name=${inst_def%%:*}
+ [ "${inst_name}" != "main" ] || err 1 "${name} instance can't be named 'main'"
+ inst_def=${inst_def#$inst_name}
+ if [ -n "$inst_def" ]; then
+ # extended instance: parameters are set explicitly
+ inst_def=${inst_def#:}
+ tor_conf=${inst_def%%:*}
+ inst_def=${inst_def#$tor_conf:}
+ tor_user=${inst_def%%:*}
+ inst_def=${inst_def#$tor_user:}
+ tor_group=${inst_def%%:*}
+ inst_def=${inst_def#$tor_group:}
+ tor_pidfile=${inst_def%%:*}
+ tor_datadir=${inst_def#$tor_pidfile:}
+ if [ -z "${tor_conf}" -o -z "${tor_user}" -o -z "${tor_group}" -o -z "${tor_pidfile}" -o -z "${tor_datadir}" ]; then
+ warn "invalid tor instance ${inst_name} settings: ${instance}"
+ exit 1
+ fi
+ else
+ # regular instance: default parameters are used
+ tor_conf=${tor_conf}@${inst_name}
+ tor_pidfile=${tor_pidfile}@${inst_name}
+ tor_datadir=${tor_datadir}/instance@${inst_name}
+ fi
+ if ! [ -r ${tor_conf} ]; then
+ warn "tor instance ${inst_name} config file ${tor_conf} doesn't exist or isn't readable"
+ warn "you can copy the sample config %%PREFIX%%/etc/tor/torrc.sample and modify it"
+ exit 1
+ fi
+ if ! [ -d ${tor_datadir} ]; then
+ mkdir -p ${tor_datadir} &&
+ chown ${tor_user}:${tor_group} ${tor_datadir} &&
+ chmod 0700 ${tor_datadir} &&
+ echo "${name}: created the instance data directory ${tor_datadir}"
+ fi
+fi
+
+if [ -z "${instance}" -a -n "${tor_instances}" ]; then
+ inst_only="$2"
+ inst_done=0
+ for i in ${tor_instances}; do
+ inst_name=${i%%:*}
+ if [ -z "${inst_only}" -o "${inst_name}" = "${inst_only}" ]; then
+ echo -n "${name} instance ${inst_name}: "
+ if ! slave_instance=${i} %%PREFIX%%/etc/rc.d/tor "$1"; then
+ exit_code=1
+ fi
+ inst_done=$((inst_done+1))
+ fi
+ done
+ if [ -z "${inst_only}" -o "${inst_only}" = "main" ]; then
+ checkyesno tor_disable_default_instance && return $exit_code
+ echo -n "${name} main instance: "
+ elif [ -n "${inst_only}" ]; then
+ [ $inst_done -gt 0 ] || err 1 "${name} instance '$inst_only' isn't defined"
+ return $exit_code
+ fi
+fi
required_files=${tor_conf}
required_dirs=${tor_datadir}
@@ -37,5 +112,8 @@ command="%%PREFIX%%/bin/${name}"
command_args="-f ${tor_conf} --PidFile ${tor_pidfile} --RunAsDaemon 1 --DataDirectory ${tor_datadir}"
extra_commands="reload"
-run_rc_command "$1"
+if ! run_rc_command "$1"; then
+ exit_code=1
+fi
+return $exit_code
diff --git a/security/tor-devel/pkg-plist b/security/tor-devel/pkg-plist
index a9337b62bee0..f695dd5dffaa 100644
--- a/security/tor-devel/pkg-plist
+++ b/security/tor-devel/pkg-plist
@@ -7,11 +7,12 @@ bin/torify
%%MANPAGES%%man/man1/tor-resolve.1.gz
%%MANPAGES%%man/man1/tor.1.gz
%%MANPAGES%%man/man1/torify.1.gz
-%%MANPAGES%%%%PORTDOCS%%%%DOCSDIR%%/tor-gencert.html
-%%MANPAGES%%%%PORTDOCS%%%%DOCSDIR%%/tor-resolve.html
-%%MANPAGES%%%%PORTDOCS%%%%DOCSDIR%%/tor.html
-%%MANPAGES%%%%PORTDOCS%%%%DOCSDIR%%/torify.html
+%%PORTDOCS%%%%DOCSDIR%%/tor-gencert.html
+%%PORTDOCS%%%%DOCSDIR%%/tor-resolve.html
+%%PORTDOCS%%%%DOCSDIR%%/tor.html
+%%PORTDOCS%%%%DOCSDIR%%/torify.html
%%DATADIR%%/geoip
%%DATADIR%%/geoip6
-@dir(_tor,_tor,750) /var/run/tor
-@dir(_tor,_tor,750) /var/log/tor
+@dir(%%USER%%,%%GROUP%%,700) /var/run/tor
+@dir(%%USER%%,%%GROUP%%,700) /var/log/tor
+@dir(%%USER%%,%%GROUP%%,700) /var/db/tor