aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2013-01-19 18:06:26 +0800
committeroliver <oliver@FreeBSD.org>2013-01-19 18:06:26 +0800
commitbcef092f290676ee176bedb3df6d501ea2545432 (patch)
treea19510a17ff2866befb9df3a71b4b4085d30aace
parenta434ce89447769592f10423b55c9c0216d672b85 (diff)
downloadfreebsd-ports-gnome-bcef092f290676ee176bedb3df6d501ea2545432.tar.gz
freebsd-ports-gnome-bcef092f290676ee176bedb3df6d501ea2545432.tar.zst
freebsd-ports-gnome-bcef092f290676ee176bedb3df6d501ea2545432.zip
update ogre to 1.8.1
-rw-r--r--graphics/ogre3d/Makefile31
-rw-r--r--graphics/ogre3d/distinfo4
-rw-r--r--graphics/ogre3d/files/patch-CMakeLists.txt24
-rw-r--r--graphics/ogre3d/pkg-plist54
4 files changed, 66 insertions, 47 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 99e6025fce07..9b7b2d31cfd3 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -1,15 +1,10 @@
-# New ports collection makefile for: ogre3d
-# Date created: 03 Oct 2005
-# Whom: Oliver Lehmann <oliver@FreeBSD.org>
-#
+# Created by: Oliver Lehmann <oliver@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ogre3d
-PORTVERSION= 1.7.4
-PORTREVISION= 1
+PORTVERSION= 1.8.1
CATEGORIES= graphics devel
-MASTER_SITES= SF/ogre/ogre/${PORTVERSION:C/.[0-9]$//g}
+MASTER_SITES= SF/ogre/ogre/${PORTVERSION:C/.[0-9]$//g}/${PORTVERSION}
DISTNAME= ogre_src_v${PORTVERSION:S/./-/g}
MAINTAINER= oliver@FreeBSD.org
@@ -19,7 +14,7 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
freetype.9:${PORTSDIR}/print/freetype2 \
freeimage.3:${PORTSDIR}/graphics/freeimage
-OPTIONS= BOOST "Use Boost to build threaded ogre" off
+OPTIONS_DEFINE= BOOST
USE_LDCONFIG= YES
USE_BZIP2= YES
@@ -28,9 +23,9 @@ USE_SDL= sdl
USE_XORG= xaw
MAKE_JOBS_SAFE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_BOOST)
+.if ${PORT_OPTIONS:MBOOST}
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
RUND_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
PLIST_SUB+= BOOSTTRUE=""
@@ -53,22 +48,18 @@ post-patch:
@${REINPLACE_CMD} -e 's|Boost|No_Boost|g' \
${WRKSRC}/CMake/Dependencies.cmake
.endif
- @${REINPLACE_CMD} -e 's|(CEGUI::uint)|(size_t)|' \
- ${WRKSRC}/Samples/OceanDemo/src/OceanDemo.cpp
+ @${REINPLACE_CMD} -e 's|\(OGRE_RW_MUTEX.*\);|\1|g' \
+ ${WRKSRC}/OgreMain/include/OgreWorkQueue.h
@${REINPLACE_CMD} -e '\
s,defined(__x86_64__),& || defined(__powerpc__) || defined(__ia64__) || defined(__sparc64__) || defined(__alpha__) || defined(__amd64__),' \
${WRKSRC}/OgreMain/include/OgrePlatform.h
- @${REINPLACE_CMD} -e 's|tinyxml.h|../include/tinyxml.h|' \
- ${WRKSRC}/Tools/XMLConverter/src/tinyxml.cpp \
- ${WRKSRC}/Tools/XMLConverter/src/tinyxmlerror.cpp \
- ${WRKSRC}/Tools/XMLConverter/src/tinyxmlparser.cpp \
- ${WRKSRC}/Tools/XMLConverter/include/OgreXMLPrerequisites.h
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for docfile in README COPYING AUTHORS
@${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/ogre3d/distinfo b/graphics/ogre3d/distinfo
index 08649b6acf0f..088742f4f346 100644
--- a/graphics/ogre3d/distinfo
+++ b/graphics/ogre3d/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ogre_src_v1-7-4.tar.bz2) = afa475803d9e6980ddf3641dceaa53fcfbd348506ed67893c306766c166a4882
-SIZE (ogre_src_v1-7-4.tar.bz2) = 67391570
+SHA256 (ogre_src_v1-8-1.tar.bz2) = da908ac934265d25e378d336d648327afe569a758ef262029acd357d506f6aab
+SIZE (ogre_src_v1-8-1.tar.bz2) = 88619968
diff --git a/graphics/ogre3d/files/patch-CMakeLists.txt b/graphics/ogre3d/files/patch-CMakeLists.txt
index 8141884bb28c..4b1cc24e9240 100644
--- a/graphics/ogre3d/files/patch-CMakeLists.txt
+++ b/graphics/ogre3d/files/patch-CMakeLists.txt
@@ -1,14 +1,26 @@
---- CMakeLists.txt.orig 2011-08-21 00:25:46.000000000 +0200
-+++ CMakeLists.txt 2011-08-21 00:29:36.000000000 +0200
-@@ -291,6 +291,7 @@ cmake_dependent_option(OGRE_FULL_RPATH "
+--- CMakeLists.txt.orig 2012-05-25 21:48:44.000000000 +0200
++++ CMakeLists.txt 2012-06-23 16:33:51.000000000 +0200
+@@ -98,9 +98,9 @@
+ add_definitions(-msse)
+ endif ()
+ # This is a set of sensible warnings that provide meaningful output
+- set(OGRE_WARNING_FLAGS "-Wno-deprecated -Wall -Wctor-dtor-privacy -Winit-self -Wno-overloaded-virtual -Wcast-qual -Wwrite-strings -Wextra -Wno-unused-parameter -pedantic -Wshadow -Wno-missing-field-initializers -Wno-long-long")
++ set(OGRE_WARNING_FLAGS "-Wno-deprecated -Wall -Wctor-dtor-privacy -Winit-self -Wno-overloaded-virtual -Wcast-qual -Wwrite-strings -Wno-unused-parameter -Wshadow -Wno-missing-field-initializers -Wno-long-long")
+ if (NOT APPLE)
+- set(OGRE_WARNING_FLAGS "${OGRE_WARNING_FLAGS} -Wno-unused-but-set-parameter")
++ set(OGRE_WARNING_FLAGS "${OGRE_WARNING_FLAGS}")
+ endif ()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OGRE_WARNING_FLAGS}")
+ endif ()
+@@ -323,6 +323,7 @@
option(OGRE_PROFILING "Enable internal profiling support." FALSE)
cmake_dependent_option(OGRE_CONFIG_STATIC_LINK_CRT "Statically link the MS CRT dlls (msvcrt)" FALSE "MSVC" FALSE)
set(OGRE_LIB_DIRECTORY "lib${LIB_SUFFIX}" CACHE STRING "Install path for libraries, e.g. 'lib64' on some 64-bit Linux distros.")
+set(OGRE_LIBDATA_DIRECTORY "libdata" CACHE STRING "Install path for data files.")
- # hide advanced options
- mark_as_advanced(
-@@ -314,6 +315,7 @@ mark_as_advanced(
+ # Unity build options
+ # A Unity build includes all sources files in just a few actual compilation units
+@@ -359,6 +360,7 @@
OGRE_PROFILING
OGRE_CONFIG_STATIC_LINK_CRT
OGRE_LIB_DIRECTORY
diff --git a/graphics/ogre3d/pkg-plist b/graphics/ogre3d/pkg-plist
index 8f86816de9a2..8262a4879983 100644
--- a/graphics/ogre3d/pkg-plist
+++ b/graphics/ogre3d/pkg-plist
@@ -53,6 +53,7 @@ include/OGRE/OgreDDSCodec.h
include/OGRE/OgreDataStream.h
include/OGRE/OgreDefaultHardwareBufferManager.h
include/OGRE/OgreDistanceLodStrategy.h
+include/OGRE/OgreDualQuaternion.h
include/OGRE/OgreDynLib.h
include/OGRE/OgreDynLibManager.h
include/OGRE/OgreEdgeListBuilder.h
@@ -84,6 +85,7 @@ include/OGRE/OgreHighLevelGpuProgram.h
include/OGRE/OgreHighLevelGpuProgramManager.h
include/OGRE/OgreImage.h
include/OGRE/OgreImageCodec.h
+include/OGRE/OgreInstanceBatchShader.h
include/OGRE/OgreInstancedGeometry.h
include/OGRE/OgreIteratorRange.h
include/OGRE/OgreIteratorWrapper.h
@@ -210,6 +212,7 @@ include/OGRE/OgreSkeletonFileFormat.h
include/OGRE/OgreSkeletonInstance.h
include/OGRE/OgreSkeletonManager.h
include/OGRE/OgreSkeletonSerializer.h
+include/OGRE/OgreSmallVector.h
include/OGRE/OgreSphere.h
include/OGRE/OgreSpotShadowFadePng.h
include/OGRE/OgreStableHeaders.h
@@ -246,6 +249,7 @@ include/OGRE/OgreWireBoundingBox.h
include/OGRE/OgreWorkQueue.h
include/OGRE/OgreZip.h
include/OGRE/Paging/OgreGrid2DPageStrategy.h
+include/OGRE/Paging/OgreGrid3DPageStrategy.h
include/OGRE/Paging/OgrePage.h
include/OGRE/Paging/OgrePageConnection.h
include/OGRE/Paging/OgrePageContent.h
@@ -271,30 +275,16 @@ include/OGRE/Plugins/BSPSceneManager/OgreQuake3Level.h
include/OGRE/Plugins/BSPSceneManager/OgreQuake3Shader.h
include/OGRE/Plugins/BSPSceneManager/OgreQuake3ShaderManager.h
include/OGRE/Plugins/BSPSceneManager/OgreQuake3Types.h
-include/OGRE/Plugins/OctreeSceneManager/OgreHeightmapTerrainPageSource.h
include/OGRE/Plugins/OctreeSceneManager/OgreOctree.h
include/OGRE/Plugins/OctreeSceneManager/OgreOctreeCamera.h
include/OGRE/Plugins/OctreeSceneManager/OgreOctreeNode.h
include/OGRE/Plugins/OctreeSceneManager/OgreOctreePlugin.h
include/OGRE/Plugins/OctreeSceneManager/OgreOctreeSceneManager.h
include/OGRE/Plugins/OctreeSceneManager/OgreOctreeSceneQuery.h
-include/OGRE/Plugins/OctreeSceneManager/OgreTerrainPage.h
-include/OGRE/Plugins/OctreeSceneManager/OgreTerrainPageSource.h
-include/OGRE/Plugins/OctreeSceneManager/OgreTerrainPrerequisites.h
-include/OGRE/Plugins/OctreeSceneManager/OgreTerrainRenderable.h
-include/OGRE/Plugins/OctreeSceneManager/OgreTerrainSceneManager.h
-include/OGRE/Plugins/OctreeSceneManager/OgreTerrainVertexProgram.h
-include/OGRE/Plugins/OctreeZone/OgreHeightmapTerrainZonePageSource.h
include/OGRE/Plugins/OctreeZone/OgreOctreeZone.h
include/OGRE/Plugins/OctreeZone/OgreOctreeZoneOctree.h
include/OGRE/Plugins/OctreeZone/OgreOctreeZonePlugin.h
include/OGRE/Plugins/OctreeZone/OgreOctreeZonePrerequisites.h
-include/OGRE/Plugins/OctreeZone/OgreTerrainVertexProgram.h
-include/OGRE/Plugins/OctreeZone/OgreTerrainZone.h
-include/OGRE/Plugins/OctreeZone/OgreTerrainZonePage.h
-include/OGRE/Plugins/OctreeZone/OgreTerrainZonePageSource.h
-include/OGRE/Plugins/OctreeZone/OgreTerrainZonePrerequisites.h
-include/OGRE/Plugins/OctreeZone/OgreTerrainZoneRenderable.h
include/OGRE/Plugins/PCZSceneManager/OgreAntiPortal.h
include/OGRE/Plugins/PCZSceneManager/OgreCapsule.h
include/OGRE/Plugins/PCZSceneManager/OgreDefaultZone.h
@@ -396,6 +386,7 @@ include/OGRE/RenderSystems/GL/GLX/OgreGLXWindow.h
include/OGRE/RenderSystems/GL/OgreGLATIFSInit.h
include/OGRE/RenderSystems/GL/OgreGLContext.h
include/OGRE/RenderSystems/GL/OgreGLDefaultHardwareBufferManager.h
+include/OGRE/RenderSystems/GL/OgreGLDepthBuffer.h
include/OGRE/RenderSystems/GL/OgreGLFBOMultiRenderTarget.h
include/OGRE/RenderSystems/GL/OgreGLFBORenderTexture.h
include/OGRE/RenderSystems/GL/OgreGLFrameBufferObject.h
@@ -447,13 +438,36 @@ include/OGRE/Threading/OgreThreadDefines.h
%%BOOSTFALSE%%include/OGRE/Threading/OgreThreadDefinesNone.h
include/OGRE/Threading/OgreThreadHeaders.h
%%BOOSTTRUE%%include/OGRE/Threading/OgreThreadHeadersBoost.h
+include/OGRE/OgreDeflate.h
+include/OGRE/OgreInstanceBatchVTF.h
+include/OGRE/OgreInstanceBatch.h
+include/OGRE/Plugins/OctreeSceneManager/OgreOctreePrerequisites.h
+include/OGRE/OgreInstanceManager.h
+include/OGRE/RTShaderSystem/OgreShaderGLSLESProgramProcessor.h
+include/OGRE/RTShaderSystem/OgreShaderExDualQuaternionSkinning.h
+include/OGRE/RTShaderSystem/OgreShaderExLayeredBlending.h
+include/OGRE/RTShaderSystem/OgreShaderGLSLESProgramWriter.h
+include/OGRE/RTShaderSystem/OgreShaderExHardwareSkinningTechnique.h
+include/OGRE/RTShaderSystem/OgreShaderExLinearSkinning.h
+include/OGRE/RTShaderSystem/OgreShaderExTextureAtlasSampler.h
+include/OGRE/RTShaderSystem/OgreShaderExHardwareSkinning.h
+include/OGRE/OgreInstanceBatchHW_VTF.h
+include/OGRE/OgreInstancedEntity.h
+include/OGRE/OgreInstanceBatchHW.h
+include/OGRE/OgreDepthBuffer.h
include/OGRE/asm_math.h
lib/OGRE/Plugin_BSPSceneManager.so
lib/OGRE/Plugin_OctreeSceneManager.so
lib/OGRE/Plugin_OctreeZone.so
+lib/OGRE/Plugin_OctreeZone.so.1.8.1
lib/OGRE/Plugin_PCZSceneManager.so
lib/OGRE/Plugin_ParticleFX.so
+lib/OGRE/Plugin_PCZSceneManager.so.1.8.1
+lib/OGRE/Plugin_ParticleFX.so.1.8.1
+lib/OGRE/Plugin_BSPSceneManager.so.1.8.1
+lib/OGRE/Plugin_OctreeSceneManager.so.1.8.1
lib/OGRE/RenderSystem_GL.so
+lib/OGRE/RenderSystem_GL.so.1.8.1
lib/OGRE/cmake/FindOGRE.cmake
lib/OGRE/cmake/FindOIS.cmake
lib/OGRE/cmake/FindPkgMacros.cmake
@@ -462,16 +476,18 @@ lib/OGRE/cmake/OgreConfigTargets.cmake
lib/OGRE/cmake/OgreFindFrameworks.cmake
lib/OGRE/cmake/OgreGetVersion.cmake
lib/OGRE/cmake/PreprocessorUtils.cmake
+lib/OGRE/cmake/OgreAddTargets.cmake
+lib/OGRE/cmake/PrecompiledHeader.cmake
lib/libOgreMain.so
-lib/libOgreMain.so.1.7.4
+lib/libOgreMain.so.1.8.1
lib/libOgrePaging.so
-lib/libOgrePaging.so.1.7.4
+lib/libOgrePaging.so.1.8.1
%%BOOSTTRUE%%lib/libOgreProperty.so
-%%BOOSTTRUE%%lib/libOgreProperty.so.1.7.4
+%%BOOSTTRUE%%lib/libOgreProperty.so.1.8.1
lib/libOgreRTShaderSystem.so
-lib/libOgreRTShaderSystem.so.1.7.4
+lib/libOgreRTShaderSystem.so.1.8.1
lib/libOgreTerrain.so
-lib/libOgreTerrain.so.1.7.4
+lib/libOgreTerrain.so.1.8.1
libdata/pkgconfig/OGRE-PCZ.pc
libdata/pkgconfig/OGRE-Paging.pc
%%BOOSTTRUE%%libdata/pkgconfig/OGRE-Property.pc