aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 10:58:50 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 10:58:50 +0800
commitbfd1fe1c76f8b8ca597f0c9f5aaca0adcd6694f8 (patch)
treea2d07583906f130eeb3b735a6fbb575327fb831d
parent4d0d61ac363dbb2e7677700bf5b553b9b89cc21c (diff)
downloadfreebsd-ports-gnome-bfd1fe1c76f8b8ca597f0c9f5aaca0adcd6694f8.tar.gz
freebsd-ports-gnome-bfd1fe1c76f8b8ca597f0c9f5aaca0adcd6694f8.tar.zst
freebsd-ports-gnome-bfd1fe1c76f8b8ca597f0c9f5aaca0adcd6694f8.zip
[non-maintainer update] update logic for "BROKEN" variable in audio/aureal-kmod
The current logic to calculate BROKEN in this port does not allow for one OS release to ask the port if it is broken on another OS release. This is due to an assumption that the OSVERSION passed to the Makefile exactly corresponds to the source version installed under /usr/src/sys (if any.) That is the default. However, when doing a cross-query, this is not the case. While this is a problem that is probably only of interest to myself, Bill Fenner, and Dan Langille, the logic could use tightening anyway. PR: ports/52590 Submitted by: Mark Linimon <linimon@lonesome.com>
-rw-r--r--audio/aureal-kmod/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/audio/aureal-kmod/Makefile b/audio/aureal-kmod/Makefile
index 40f01fd63331..a99f46373d65 100644
--- a/audio/aureal-kmod/Makefile
+++ b/audio/aureal-kmod/Makefile
@@ -36,8 +36,7 @@ VERSION_SOUND_C!= ident < ${SRCPREFIX}/sys/dev/sound/pcm/sound.c | \
VERSION_SOUND_C=
.endif
-VERSION_SOUND_C_CURRENT:= ${VERSION_SOUND_C:S/1.//}
-VERSION_SOUND_C_STABLE:= ${VERSION_SOUND_C:S/1.17.2.//}
+VERSION_SOUND_C_MINOR:= ${VERSION_SOUND_C:S/^1.//:S/^17.2.//}
.if ${OSVERSION} < 410000
BROKEN= "FreeBSD 3.*, 4.0 are not supported"
@@ -51,7 +50,7 @@ PORTREVISION= 3
# FreeBSD 4.2, 4.3
PORTVERSION= 1.3
-.if ${VERSION_SOUND_C_STABLE} < 4
+.if ${VERSION_SOUND_C_MINOR} < 4
# FreeBSD 4.2 before kobj MFC
PORTREVISION= 1
@@ -69,7 +68,7 @@ MAKE_ENV+= HAVE_KOBJ_PCM=1
.elif ${OSVERSION} < 500000
# FreeBSD 4.5+, 4.6, 4.7, 4.8-
-.if ${VERSION_SOUND_C_STABLE} < 12
+.if ${VERSION_SOUND_C_MINOR} < 12
BROKEN= "Base system is outdated. This port needs -STABLE after 2002-04-22."
.endif
PORTVERSION= 1.3
@@ -79,7 +78,7 @@ MAKE_ENV+= HAVE_KOBJ_PCM=1
.if ${OSVERSION} > 500000
# FreeBSD 5-CURRENT
-.if ${VERSION_SOUND_C_CURRENT} < 70
+.if ${VERSION_SOUND_C_MINOR} < 70
BROKEN= "Base system is outdated. This port needs -CURRENT after 2002-04-04."
.endif
.endif