aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2004-06-06 09:35:04 +0800
committermarkus <markus@FreeBSD.org>2004-06-06 09:35:04 +0800
commitd03a0f0ac62458ed6dd36d199264200f38d03a74 (patch)
tree7e9ce77323e33b03805c2871d6b2c224da6c1003
parent324152bf045ea467662982872621f9fe5f699bdd (diff)
downloadfreebsd-ports-gnome-d03a0f0ac62458ed6dd36d199264200f38d03a74.tar.gz
freebsd-ports-gnome-d03a0f0ac62458ed6dd36d199264200f38d03a74.tar.zst
freebsd-ports-gnome-d03a0f0ac62458ed6dd36d199264200f38d03a74.zip
Don't use Makefile.kde anymore
-rw-r--r--ftp/kasablanca/Makefile9
-rw-r--r--graphics/gwenview-kde4/Makefile4
-rw-r--r--graphics/gwenview/Makefile4
-rw-r--r--graphics/kalbum/Makefile7
-rw-r--r--math/fung-calc/Makefile7
-rw-r--r--multimedia/hayes/Makefile10
6 files changed, 17 insertions, 24 deletions
diff --git a/ftp/kasablanca/Makefile b/ftp/kasablanca/Makefile
index dddec0652edb..168bac41f8a6 100644
--- a/ftp/kasablanca/Makefile
+++ b/ftp/kasablanca/Makefile
@@ -24,11 +24,10 @@ post-extract:
@${TOUCH} -t 200404130000 ${WRKSRC}/subdirs
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -e 's|\(-lssl\)|\1 -lcrypto|' \
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|\(-lssl\)|\1 -lcrypto ${PTHREAD_LIBS}|' \
${WRKSRC}/src/Makefile.in \
${WRKSRC}/src/kbftp/Makefile.in
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/gwenview-kde4/Makefile b/graphics/gwenview-kde4/Makefile
index ba1627e7117f..f0242faf4e71 100644
--- a/graphics/gwenview-kde4/Makefile
+++ b/graphics/gwenview-kde4/Makefile
@@ -27,6 +27,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|xx||g' ${WRKSRC}/po/Makefile.in
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/gwenview/Makefile b/graphics/gwenview/Makefile
index ba1627e7117f..f0242faf4e71 100644
--- a/graphics/gwenview/Makefile
+++ b/graphics/gwenview/Makefile
@@ -27,6 +27,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|xx||g' ${WRKSRC}/po/Makefile.in
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/kalbum/Makefile b/graphics/kalbum/Makefile
index e33670dbc23f..a66c5cfc14c1 100644
--- a/graphics/kalbum/Makefile
+++ b/graphics/kalbum/Makefile
@@ -20,8 +20,7 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
post-patch:
- @${REINPLACE_CMD} -e 's/-O2//g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/fung-calc/Makefile b/math/fung-calc/Makefile
index 5baf14c64e4e..80b87cd6848a 100644
--- a/math/fung-calc/Makefile
+++ b/math/fung-calc/Makefile
@@ -24,8 +24,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
pre-configure:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/hayes/Makefile b/multimedia/hayes/Makefile
index 2fbfedfc9c1e..00eefc56bf6f 100644
--- a/multimedia/hayes/Makefile
+++ b/multimedia/hayes/Makefile
@@ -19,11 +19,11 @@ USE_KDEBASE_VER= 3
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
+USE_REINPLACE= yes
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>