aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-06-17 20:18:47 +0800
committerstas <stas@FreeBSD.org>2009-06-17 20:18:47 +0800
commitd188b7d200d4a3013fc90ec4e808363ce8e15c32 (patch)
tree0854ea43c834b3057004a00c6ef8ffba1fa919f3
parent697da98a953f090b3b9c4516c7c7e2e3004b6a2a (diff)
downloadfreebsd-ports-gnome-d188b7d200d4a3013fc90ec4e808363ce8e15c32.tar.gz
freebsd-ports-gnome-d188b7d200d4a3013fc90ec4e808363ce8e15c32.tar.zst
freebsd-ports-gnome-d188b7d200d4a3013fc90ec4e808363ce8e15c32.zip
- Add ruby-fastri, a fast RDoc ri browser replacement.
Author: Mauricio Julio Fernandez Pradier <mfp@acm.org> WWW: http://eigenclass.org/hiki/fastri
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-fastri/Makefile31
-rw-r--r--devel/ruby-fastri/distinfo3
-rw-r--r--devel/ruby-fastri/files/patch-lib_fastri_util.rb10
-rw-r--r--devel/ruby-fastri/pkg-descr6
-rw-r--r--devel/ruby-fastri/pkg-plist19
6 files changed, 70 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c1494eebd7eb..17cb33d88331 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2539,6 +2539,7 @@
SUBDIR += ruby-eet
SUBDIR += ruby-event-loop
SUBDIR += ruby-fam
+ SUBDIR += ruby-fastri
SUBDIR += ruby-filelock
SUBDIR += ruby-filemagic
SUBDIR += ruby-flexmock
diff --git a/devel/ruby-fastri/Makefile b/devel/ruby-fastri/Makefile
new file mode 100644
index 000000000000..83b9c06d0475
--- /dev/null
+++ b/devel/ruby-fastri/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ruby-fastri
+# Date created: 16 June 2009
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= fastri
+PORTVERSION= 0.3.1
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= A fast RDoc documentation browser for ruby
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+CONFIGURE_ARGS= --prefix="${PREFIX}"
+
+DOCS= CHANGES README.en
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${RUBY_MODDOCDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-fastri/distinfo b/devel/ruby-fastri/distinfo
new file mode 100644
index 000000000000..7172d7c2c1b4
--- /dev/null
+++ b/devel/ruby-fastri/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/fastri-0.3.1.tar.gz) = 3a7d0a64b1c8e230a34ef7b4bad30dbe
+SHA256 (ruby/fastri-0.3.1.tar.gz) = a59376b51be65221ea8aefef8c106a61a9edcb51c052a5a618560cdb9f260042
+SIZE (ruby/fastri-0.3.1.tar.gz) = 48231
diff --git a/devel/ruby-fastri/files/patch-lib_fastri_util.rb b/devel/ruby-fastri/files/patch-lib_fastri_util.rb
new file mode 100644
index 000000000000..f0a7427f4207
--- /dev/null
+++ b/devel/ruby-fastri/files/patch-lib_fastri_util.rb
@@ -0,0 +1,10 @@
+--- lib/fastri/util.rb.orig 2009-06-17 16:15:24.000000000 +0400
++++ lib/fastri/util.rb 2009-06-17 16:15:32.000000000 +0400
+@@ -1,5 +1,7 @@
+ # Copyright (C) 2006 Mauricio Fernandez <mfp@acm.org>
+
++require 'rubygems'
++
+ # emulate rubygems.rb and define Gem.path if not loaded
+ # This is much faster than requiring rubygems.rb, which loads way too much
+ # stuff.
diff --git a/devel/ruby-fastri/pkg-descr b/devel/ruby-fastri/pkg-descr
new file mode 100644
index 000000000000..8d15d6e3acae
--- /dev/null
+++ b/devel/ruby-fastri/pkg-descr
@@ -0,0 +1,6 @@
+FastRI improves on the aging RI documentation tool: much faster, needs less
+RAM, "scoped" searches, e.g. get String extensions defined in a given RubyGems
+package, fast full-text search, remote access via DRb (auto-discovered).
+
+Author: Mauricio Julio Fernandez Pradier <mfp@acm.org>
+WWW: http://eigenclass.org/hiki/fastri
diff --git a/devel/ruby-fastri/pkg-plist b/devel/ruby-fastri/pkg-plist
new file mode 100644
index 000000000000..2fa9505ad4ef
--- /dev/null
+++ b/devel/ruby-fastri/pkg-plist
@@ -0,0 +1,19 @@
+bin/fastri-server
+bin/fri
+bin/qri
+bin/ri-emacs
+%%RUBY_SITELIBDIR%%/fastri/full_text_index.rb
+%%RUBY_SITELIBDIR%%/fastri/full_text_indexer.rb
+%%RUBY_SITELIBDIR%%/fastri/name_descriptor.rb
+%%RUBY_SITELIBDIR%%/fastri/ri_index.rb
+%%RUBY_SITELIBDIR%%/fastri/ri_service.rb
+%%RUBY_SITELIBDIR%%/fastri/util.rb
+%%RUBY_SITELIBDIR%%/fastri/version.rb
+%%RUBY_MODDOCDIR%%/CHANGES
+%%RUBY_MODDOCDIR%%/README.en
+@dirrm %%RUBY_MODDOCDIR%%
+@dirrm %%RUBY_DOCDIR%%
+@dirrm %%RUBY_SITELIBDIR%%/fastri
+@dirrmtry %%RUBY_SITELIBDIR%%
+@dirrmtry lib/ruby/site_ruby
+@dirrmtry lib/ruby