aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2008-04-27 21:14:48 +0800
committerthierry <thierry@FreeBSD.org>2008-04-27 21:14:48 +0800
commitd1d6409fd0f03dadde1ad4600c387d9fcb6110de (patch)
tree70f591139be3463682d0aedb8f7b560386dfb24a
parent8c4f1c2ee1e92464a814b4e5708c44469691a49a (diff)
downloadfreebsd-ports-gnome-d1d6409fd0f03dadde1ad4600c387d9fcb6110de.tar.gz
freebsd-ports-gnome-d1d6409fd0f03dadde1ad4600c387d9fcb6110de.tar.zst
freebsd-ports-gnome-d1d6409fd0f03dadde1ad4600c387d9fcb6110de.zip
Really update ImageMagick before trying to chase it...
Reported by: miwi
-rw-r--r--science/gnudatalanguage/Makefile5
-rw-r--r--science/gnudatalanguage/files/patch-configure19
2 files changed, 22 insertions, 2 deletions
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index 509518d7a76a..7b4d9d1be2a1 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -33,11 +33,12 @@ COMMENT?= GDL, a free IDL compatible incremental compiler
LIB_DEPENDS+= plplotd.11:${PORTSDIR}/math/plplot \
gsl.12:${PORTSDIR}/math/gsl \
+ dps.0:${PORTSDIR}/x11/dgs \
readline.5:${PORTSDIR}/devel/readline
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/ImageMagick" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
SLAVEDIRS= science/py-gnudatalanguage
@@ -54,7 +55,7 @@ PLIST_SUB+= MASTER=""
.endif
.if !defined(WITHOUT_IMAGEMAGICK)
-LIB_DEPENDS+= Magick.10:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS+= MagickWand.1:${PORTSDIR}/graphics/ImageMagick
CONFIGURE_ARGS+=--with-Magick=${LOCALBASE}
.else
CONFIGURE_ARGS+=--with-Magick=no
diff --git a/science/gnudatalanguage/files/patch-configure b/science/gnudatalanguage/files/patch-configure
new file mode 100644
index 000000000000..7590105152ea
--- /dev/null
+++ b/science/gnudatalanguage/files/patch-configure
@@ -0,0 +1,19 @@
+--- configure.orig 2007-10-30 00:27:12.000000000 +0100
++++ configure 2008-04-27 14:17:16.000000000 +0200
+@@ -19673,13 +19673,13 @@
+ INCLUDES="$INCLUDES -I/usr/include/magick"
+ fi
+
+- echo "$as_me:$LINENO: checking for GetMagickVersion in -lMagick" >&5
+-echo $ECHO_N "checking for GetMagickVersion in -lMagick... $ECHO_C" >&6
++ echo "$as_me:$LINENO: checking for GetMagickVersion in -lGraphicsMagick" >&5
++echo $ECHO_N "checking for GetMagickVersion in -lGraphicsMagick... $ECHO_C" >&6
+ if test "${ac_cv_lib_Magick_GetMagickVersion+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lMagick $LIBS"
++LIBS="-lGraphicsMagick $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF