aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-07-19 01:06:25 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-07-19 01:06:25 +0800
commitd2dcf3f4e420f3ec7074d6f490b2c1118d84c948 (patch)
treea9615f272ce84d5a47c5abb49d941102c2ebe6e9
parent07516fc7045a0dae6ed025e6c390142e9bda0b01 (diff)
downloadfreebsd-ports-gnome-d2dcf3f4e420f3ec7074d6f490b2c1118d84c948.tar.gz
freebsd-ports-gnome-d2dcf3f4e420f3ec7074d6f490b2c1118d84c948.tar.zst
freebsd-ports-gnome-d2dcf3f4e420f3ec7074d6f490b2c1118d84c948.zip
- Update to 20150601
- Use USE_GITHUB - Cleanup Makefile - Update WWW Changes: https://github.com/google/re2/commits/master PR: 201159 Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 20 days)
-rw-r--r--devel/re2/Makefile19
-rw-r--r--devel/re2/distinfo4
-rw-r--r--devel/re2/files/patch-Makefile26
-rw-r--r--devel/re2/pkg-descr2
-rw-r--r--devel/re2/pkg-plist1
5 files changed, 36 insertions, 16 deletions
diff --git a/devel/re2/Makefile b/devel/re2/Makefile
index 4e5275a7594a..8049b9b8a06b 100644
--- a/devel/re2/Makefile
+++ b/devel/re2/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= re2
-PORTVERSION= 20140304
+PORTVERSION= 20150601
CATEGORIES= devel
-MASTER_SITES= GOOGLE_CODE
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= Fast C++ regex library
@@ -13,19 +12,13 @@ LICENSE= BSD3CLAUSE
MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" prefix=${PREFIX}
USE_LDCONFIG= yes
-USES= compiler:c++11-lang gmake tar:tgz
+USES= compiler:c++11-lang gmake pathfix
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-.include <bsd.port.pre.mk>
-
-post-patch:
-# remove tr1 if using libc++
-.if ${COMPILER_FEATURES:Mlibc++}
- @${REINPLACE_CMD} -e 's|tr1/||; s|tr1::||' ${WRKSRC}/util/util.h
-.endif
+GH_ACCOUNT= google
+GH_TAGNAME= ${PORTVERSION:C|(....)(..)(..)|\1-\2-\3|}
+USE_GITHUB= yes
post-build:
@${STRIP_CMD} ${WRKSRC}/obj/so/libre2.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/re2/distinfo b/devel/re2/distinfo
index ef52cce4a8fa..f691fd153eae 100644
--- a/devel/re2/distinfo
+++ b/devel/re2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (re2-20140304.tgz) = 0bffd1a57de2f4b218ca0f77d8850bfd59c82944a98256c6edba25260e0196a7
-SIZE (re2-20140304.tgz) = 1050493
+SHA256 (google-re2-20150601-2015-06-01_GH0.tar.gz) = 90b4f48c26b1f33f4df5f86406d8c663c8a44b103a5554387ce3c53228abf20e
+SIZE (google-re2-20150601-2015-06-01_GH0.tar.gz) = 385441
diff --git a/devel/re2/files/patch-Makefile b/devel/re2/files/patch-Makefile
new file mode 100644
index 000000000000..ecf72d79e629
--- /dev/null
+++ b/devel/re2/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig 2015-05-29 02:13:42 UTC
++++ Makefile
+@@ -25,6 +25,7 @@ exec_prefix=$(prefix)
+ bindir=$(exec_prefix)/bin
+ includedir=$(prefix)/include
+ libdir=$(exec_prefix)/lib
++libdatadir=$(exec_prefix)/libdata
+ INSTALL=install
+ INSTALL_PROGRAM=$(INSTALL)
+ INSTALL_DATA=$(INSTALL) -m 644
+@@ -245,13 +246,13 @@ shared-bigtest: $(STESTS) $(SBIGTESTS)
+ benchmark: obj/test/regexp_benchmark
+
+ install: obj/libre2.a obj/so/libre2.so
+- mkdir -p $(DESTDIR)$(includedir)/re2 $(DESTDIR)$(libdir)/pkgconfig
++ mkdir -p $(DESTDIR)$(includedir)/re2 $(DESTDIR)$(libdatadir)/pkgconfig
+ $(INSTALL_DATA) $(INSTALL_HFILES) $(DESTDIR)$(includedir)/re2
+ $(INSTALL) obj/libre2.a $(DESTDIR)$(libdir)/libre2.a
+ $(INSTALL) obj/so/libre2.so $(DESTDIR)$(libdir)/libre2.so.$(SONAME).0.0
+ ln -sf libre2.so.$(SONAME).0.0 $(DESTDIR)$(libdir)/libre2.so.$(SONAME)
+ ln -sf libre2.so.$(SONAME).0.0 $(DESTDIR)$(libdir)/libre2.so
+- sed -e "s#@prefix@#${prefix}#" re2.pc >$(DESTDIR)$(libdir)/pkgconfig/re2.pc
++ sed -e "s#@prefix@#${prefix}#" re2.pc >$(DESTDIR)$(libdatadir)/pkgconfig/re2.pc
+
+ testinstall:
+ @mkdir -p obj
diff --git a/devel/re2/pkg-descr b/devel/re2/pkg-descr
index 478cebc0cb60..e231f4f55b25 100644
--- a/devel/re2/pkg-descr
+++ b/devel/re2/pkg-descr
@@ -8,4 +8,4 @@ use a small fixed C++ stack footprint no matter what inputs or regular
expressions it must process; thus RE2 is useful in multithreaded environments
where thread stacks cannot grow arbitrarily large.
-WWW: http://code.google.com/p/re2/
+WWW: https://github.com/google/re2
diff --git a/devel/re2/pkg-plist b/devel/re2/pkg-plist
index 4dcd3393b685..26f27346f66d 100644
--- a/devel/re2/pkg-plist
+++ b/devel/re2/pkg-plist
@@ -7,3 +7,4 @@ lib/libre2.a
lib/libre2.so
lib/libre2.so.0
lib/libre2.so.0.0.0
+libdata/pkgconfig/re2.pc