aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2009-05-21 00:21:01 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2009-05-21 00:21:01 +0800
commitd4b8f14cdcea007e8c55330a17804d52b89a8391 (patch)
treed79a749b37eb8eeff9f8623889c17bc4fc135962
parent74151a0fdc2a52efbc73f1d0dd08792281d7266e (diff)
downloadfreebsd-ports-gnome-d4b8f14cdcea007e8c55330a17804d52b89a8391.tar.gz
freebsd-ports-gnome-d4b8f14cdcea007e8c55330a17804d52b89a8391.tar.zst
freebsd-ports-gnome-d4b8f14cdcea007e8c55330a17804d52b89a8391.zip
- Update to 1.4.18
- Fix Subject/filename/non-ascii filename issue [1] PR: ports/133652 [1] Submitted by: Kazuo Dohzono <dohzono gmail.com> [1] Security: CVE-2009-1581 CVE-2009-1578 CVE-2009-1579 CVE-2009-1580
-rw-r--r--mail/squirrelmail/Makefile16
-rw-r--r--mail/squirrelmail/distinfo6
-rw-r--r--mail/squirrelmail/files/patch-class__deliver__Deliver.class.php31
-rw-r--r--mail/squirrelmail/files/patch-functions__i18n.php12
-rw-r--r--mail/squirrelmail/pkg-plist69
5 files changed, 93 insertions, 41 deletions
diff --git a/mail/squirrelmail/Makefile b/mail/squirrelmail/Makefile
index 6cd24d75b11c..31b5cc548718 100644
--- a/mail/squirrelmail/Makefile
+++ b/mail/squirrelmail/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= squirrelmail
-PORTVERSION= 1.4.17
+PORTVERSION= 1.4.18
CATEGORIES= mail www
MASTER_SITES= SF
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_GETTEXT= yes
.ifdef WITH_DATABASE
-RUN_DEPENDS+= ${PREFIX}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
+RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
.endif
.ifdef WITH_LDAP
@@ -56,7 +56,13 @@ pre-everything::
post-patch:
.ifndef PATCH_DEBUG
- @${RM} -f ${WRKSRC}/config/config_default.php.orig ${WRKSRC}/functions/global.php.orig ${WRKSRC}/src/compose.php.orig ${WRKSRC}/src/addrbook_search_html.php.orig
+ @${RM} -f \
+ ${WRKSRC}/class/deliver/Deliver.class.php.orig \
+ ${WRKSRC}/config/config_default.php.orig \
+ ${WRKSRC}/functions/global.php.orig \
+ ${WRKSRC}/functions/i18n.php.orig \
+ ${WRKSRC}/src/addrbook_search_html.php.orig \
+ ${WRKSRC}/src/compose.php.orig
.endif
@${REINPLACE_CMD} -e 's|ispell|${LOCALBASE}/bin/ispell|g' \
${WRKSRC}/plugins/squirrelspell/sqspell_config.php
@@ -67,10 +73,6 @@ post-patch:
# Rearrange the documentation
do-build:
-.for file in AUTHORS ChangeLog COPYING INSTALL README UPGRADE
- @${MV} ${WRKSRC}/${file} ${WRKSRC}/doc/
-.endfor
- @${MV} ${WRKSRC}/ReleaseNotes ${WRKSRC}/doc/ReleaseNotes-${PORTVERSION}.txt
@${MV} ${WRKSRC}/themes/README.themes ${WRKSRC}/doc/
@cd ${WRKSRC} ; for f in `find plugins -name "README*" -or \
-name INSTALL -or -name CHANGES -or -name HISTORY`; \
diff --git a/mail/squirrelmail/distinfo b/mail/squirrelmail/distinfo
index 7312f593cb9f..46e6877a90a9 100644
--- a/mail/squirrelmail/distinfo
+++ b/mail/squirrelmail/distinfo
@@ -1,6 +1,6 @@
-MD5 (squirrelmail/squirrelmail-1.4.17.tar.bz2) = 6ff0df8ae0e7f13418ed37ea1c93f6f3
-SHA256 (squirrelmail/squirrelmail-1.4.17.tar.bz2) = b14d3ef3735f8c7b49b091533c567048b3a06eb633eccbfeddd7cd8fdd2ffe25
-SIZE (squirrelmail/squirrelmail-1.4.17.tar.bz2) = 507158
+MD5 (squirrelmail/squirrelmail-1.4.18.tar.bz2) = 2df99afc1bc3b121296af65f52fbc5cc
+SHA256 (squirrelmail/squirrelmail-1.4.18.tar.bz2) = be7a8370b7937bfe7ad3a584d3416d4895986181e3aac5227f52e14279b100a0
+SIZE (squirrelmail/squirrelmail-1.4.18.tar.bz2) = 509216
MD5 (squirrelmail/all_locales-1.4.13-20071220.tar.bz2) = c6463312afcd602ae60fd8f388dfb8c2
SHA256 (squirrelmail/all_locales-1.4.13-20071220.tar.bz2) = 8fa5b82bb2e4448da80d2ccc42ec9874df8674691358736da6c7c3f7bbbae639
SIZE (squirrelmail/all_locales-1.4.13-20071220.tar.bz2) = 3016605
diff --git a/mail/squirrelmail/files/patch-class__deliver__Deliver.class.php b/mail/squirrelmail/files/patch-class__deliver__Deliver.class.php
new file mode 100644
index 000000000000..f1b7437580b1
--- /dev/null
+++ b/mail/squirrelmail/files/patch-class__deliver__Deliver.class.php
@@ -0,0 +1,31 @@
+--- ./class/deliver/Deliver.class.php.orig 2009-04-15 18:00:49.000000000 -0400
++++ ./class/deliver/Deliver.class.php 2009-05-19 23:25:59.000000000 -0400
+@@ -542,7 +542,19 @@
+ $cnt = count($header);
+ $hdr_s = '';
+ for ($i = 0 ; $i < $cnt ; $i++) {
+- $hdr_s .= $this->foldLine($header[$i], 78);
++ /*
++ * FIXME: Leave some name fields (filename, username) as they
++ * are, for now. If you want to fold these fields,
++ *
++ * 1) Count columns with base64 encoded chars, and
++ * 2) Split RAW text (before encoding), and
++ * 3) encode each splitted RAW texts.
++ */
++ if (strstr($header[$i], 'name') === false) {
++ $hdr_s .= $this->foldLine($header[$i], 78);
++ } else {
++ $hdr_s .= header[$i];
++ }
+ }
+ $header = $hdr_s;
+ $header .= $rn; /* One blank line to separate mimeheader and body-entity */
+@@ -773,6 +785,7 @@
+ case 'Cc':
+ case 'Bcc':
+ case 'From':
++ case 'Subject': // Prevent from base64-folding corruption.
+ $hdr_s .= $header[$i];
+ break;
+ default: $hdr_s .= $this->foldLine($header[$i], 78); break;
diff --git a/mail/squirrelmail/files/patch-functions__i18n.php b/mail/squirrelmail/files/patch-functions__i18n.php
new file mode 100644
index 000000000000..7ade75e357e0
--- /dev/null
+++ b/mail/squirrelmail/files/patch-functions__i18n.php
@@ -0,0 +1,12 @@
+--- ./functions/i18n.php.orig 2009-05-07 17:55:44.000000000 -0400
++++ ./functions/i18n.php 2009-05-19 23:27:43.000000000 -0400
+@@ -640,7 +640,8 @@
+ $useragent = func_get_arg(2);
+ if (strstr($useragent, 'Windows') !== false ||
+ strstr($useragent, 'Mac_') !== false) {
+- $ret = mb_convert_encoding($ret, 'SJIS', 'AUTO');
++ // $ret = mb_convert_encoding($ret, 'SJIS', 'AUTO'); // for Windows 9x clients
++ $ret = mb_convert_encoding($ret, 'UTF-8', 'AUTO'); // for Windows XP/Vista clients
+ } else {
+ $ret = mb_convert_encoding($ret, 'EUC-JP', 'AUTO');
+ }
diff --git a/mail/squirrelmail/pkg-plist b/mail/squirrelmail/pkg-plist
index 498eba4705ff..94f3725c9247 100644
--- a/mail/squirrelmail/pkg-plist
+++ b/mail/squirrelmail/pkg-plist
@@ -1,11 +1,12 @@
etc/periodic/daily/111.clean-squirrelmail
+%%SQUIRRELDIR%%/class/.htaccess
%%SQUIRRELDIR%%/class/deliver/Deliver.class.php
%%SQUIRRELDIR%%/class/deliver/Deliver_IMAP.class.php
%%SQUIRRELDIR%%/class/deliver/Deliver_SMTP.class.php
%%SQUIRRELDIR%%/class/deliver/Deliver_SendMail.class.php
%%SQUIRRELDIR%%/class/deliver/index.php
-%%SQUIRRELDIR%%/class/helper/index.php
%%SQUIRRELDIR%%/class/helper/VCard.class.php
+%%SQUIRRELDIR%%/class/helper/index.php
%%SQUIRRELDIR%%/class/html.class.php
%%SQUIRRELDIR%%/class/index.php
%%SQUIRRELDIR%%/class/mime.class.php
@@ -18,6 +19,7 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/class/mime/Rfc822Header.class.php
%%SQUIRRELDIR%%/class/mime/SMimeMessage.class.php
%%SQUIRRELDIR%%/class/mime/index.php
+%%SQUIRRELDIR%%/config/.htaccess
%%SQUIRRELDIR%%/config/conf.pl
%%SQUIRRELDIR%%/config/config_default.php
%%SQUIRRELDIR%%/config/config_local.php
@@ -26,6 +28,7 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/data/.htaccess
%%SQUIRRELDIR%%/data/default_pref
%%SQUIRRELDIR%%/data/index.php
+%%SQUIRRELDIR%%/functions/.htaccess
%%SQUIRRELDIR%%/functions/abook_database.php
%%SQUIRRELDIR%%/functions/abook_ldap_server.php
%%SQUIRRELDIR%%/functions/abook_local_file.php
@@ -107,6 +110,7 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/functions/strings.php
%%SQUIRRELDIR%%/functions/tree.php
%%SQUIRRELDIR%%/functions/url_parser.php
+%%SQUIRRELDIR%%/help/.htaccess
%%SQUIRRELDIR%%/help/bg_BG/FAQ.hlp
%%SQUIRRELDIR%%/help/bg_BG/addresses.hlp
%%SQUIRRELDIR%%/help/bg_BG/basic.hlp
@@ -333,19 +337,19 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/help/sv_SE/options.hlp
%%SQUIRRELDIR%%/help/sv_SE/read_mail.hlp
%%SQUIRRELDIR%%/help/sv_SE/search.hlp
+%%SQUIRRELDIR%%/help/th_TH/FAQ.hlp
+%%SQUIRRELDIR%%/help/th_TH/addresses.hlp
+%%SQUIRRELDIR%%/help/th_TH/basic.hlp
+%%SQUIRRELDIR%%/help/th_TH/compose.hlp
%%SQUIRRELDIR%%/help/th_TH/folders.hlp
-%%SQUIRRELDIR%%/help/th_TH/read_mail.hlp
+%%SQUIRRELDIR%%/help/th_TH/main_folder.hlp
%%SQUIRRELDIR%%/help/th_TH/options.hlp
-%%SQUIRRELDIR%%/help/th_TH/basic.hlp
-%%SQUIRRELDIR%%/help/th_TH/addresses.hlp
+%%SQUIRRELDIR%%/help/th_TH/read_mail.hlp
%%SQUIRRELDIR%%/help/th_TH/search.hlp
-%%SQUIRRELDIR%%/help/th_TH/FAQ.hlp
-%%SQUIRRELDIR%%/help/th_TH/main_folder.hlp
-%%SQUIRRELDIR%%/help/th_TH/compose.hlp
+%%SQUIRRELDIR%%/help/uk_UA/FAQ.hlp
%%SQUIRRELDIR%%/help/uk_UA/addresses.hlp
%%SQUIRRELDIR%%/help/uk_UA/basic.hlp
%%SQUIRRELDIR%%/help/uk_UA/compose.hlp
-%%SQUIRRELDIR%%/help/uk_UA/FAQ.hlp
%%SQUIRRELDIR%%/help/uk_UA/folders.hlp
%%SQUIRRELDIR%%/help/uk_UA/main_folder.hlp
%%SQUIRRELDIR%%/help/uk_UA/options.hlp
@@ -373,10 +377,10 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/images/sec_remove_cs_CZ.png
%%SQUIRRELDIR%%/images/sec_remove_da_DK.png
%%SQUIRRELDIR%%/images/sec_remove_de_DE.png
-%%SQUIRRELDIR%%/images/sec_remove_et_EE.png
%%SQUIRRELDIR%%/images/sec_remove_el_GR.png
%%SQUIRRELDIR%%/images/sec_remove_eng.png
%%SQUIRRELDIR%%/images/sec_remove_es_ES.png
+%%SQUIRRELDIR%%/images/sec_remove_et_EE.png
%%SQUIRRELDIR%%/images/sec_remove_fi_FI.png
%%SQUIRRELDIR%%/images/sec_remove_fo_FO.png
%%SQUIRRELDIR%%/images/sec_remove_fr_FR.png
@@ -400,12 +404,13 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/images/sec_remove_sr_YU.png
%%SQUIRRELDIR%%/images/sec_remove_sv_SE.png
%%SQUIRRELDIR%%/images/sec_remove_tr_TR.png
-%%SQUIRRELDIR%%/images/sec_remove_uk_UA.png
%%SQUIRRELDIR%%/images/sec_remove_ug.png
+%%SQUIRRELDIR%%/images/sec_remove_uk_UA.png
%%SQUIRRELDIR%%/images/senti.png
%%SQUIRRELDIR%%/images/sm_logo.png
%%SQUIRRELDIR%%/images/sort_none.png
%%SQUIRRELDIR%%/images/up_pointer.png
+%%SQUIRRELDIR%%/include/.htaccess
%%SQUIRRELDIR%%/include/index.php
%%SQUIRRELDIR%%/include/load_prefs.php
%%SQUIRRELDIR%%/include/options/display.php
@@ -414,6 +419,7 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/include/options/personal.php
%%SQUIRRELDIR%%/include/validate.php
%%SQUIRRELDIR%%/index.php
+%%SQUIRRELDIR%%/locale/.htaccess
%%SQUIRRELDIR%%/locale/README.locales
%%SQUIRRELDIR%%/locale/ar/LC_MESSAGES/squirrelmail.mo
%%SQUIRRELDIR%%/locale/ar/LC_MESSAGES/squirrelmail.po
@@ -441,8 +447,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/cs_CZ/LC_MESSAGES/squirrelmail.po
%%SQUIRRELDIR%%/locale/cs_CZ/LC_MESSAGES/vacation_local.mo
%%SQUIRRELDIR%%/locale/cs_CZ/LC_MESSAGES/vacation_local.po
-%%SQUIRRELDIR%%/locale/cs_CZ/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/cs_CZ/LC_MESSAGES/vkeyboard.mo
+%%SQUIRRELDIR%%/locale/cs_CZ/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/cs_CZ/LC_MESSAGES/yelp.mo
%%SQUIRRELDIR%%/locale/cs_CZ/LC_MESSAGES/yelp.po
%%SQUIRRELDIR%%/locale/cs_CZ/setup.php
@@ -464,8 +470,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/de_DE/LC_MESSAGES/change_sqlpass.po
%%SQUIRRELDIR%%/locale/de_DE/LC_MESSAGES/check_quota.mo
%%SQUIRRELDIR%%/locale/de_DE/LC_MESSAGES/check_quota.po
-%%SQUIRRELDIR%%/locale/de_DE/LC_MESSAGES/compatibility.po
%%SQUIRRELDIR%%/locale/de_DE/LC_MESSAGES/compatibility.mo
+%%SQUIRRELDIR%%/locale/de_DE/LC_MESSAGES/compatibility.po
%%SQUIRRELDIR%%/locale/de_DE/LC_MESSAGES/empty_folders.mo
%%SQUIRRELDIR%%/locale/de_DE/LC_MESSAGES/empty_folders.po
%%SQUIRRELDIR%%/locale/de_DE/LC_MESSAGES/expire.mo
@@ -535,8 +541,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/es_ES/LC_MESSAGES/squirrelmail.po
%%SQUIRRELDIR%%/locale/es_ES/LC_MESSAGES/unsafe_image_rules.mo
%%SQUIRRELDIR%%/locale/es_ES/LC_MESSAGES/unsafe_image_rules.po
-%%SQUIRRELDIR%%/locale/es_ES/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/es_ES/LC_MESSAGES/vkeyboard.mo
+%%SQUIRRELDIR%%/locale/es_ES/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/es_ES/setup.php
%%SQUIRRELDIR%%/locale/et_EE/LC_MESSAGES/squirrelmail.mo
%%SQUIRRELDIR%%/locale/et_EE/LC_MESSAGES/squirrelmail.po
@@ -585,8 +591,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/fr_FR/LC_MESSAGES/squirrelmail.po
%%SQUIRRELDIR%%/locale/fr_FR/LC_MESSAGES/vacation_local.mo
%%SQUIRRELDIR%%/locale/fr_FR/LC_MESSAGES/vacation_local.po
-%%SQUIRRELDIR%%/locale/fr_FR/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/fr_FR/LC_MESSAGES/vkeyboard.mo
+%%SQUIRRELDIR%%/locale/fr_FR/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/fr_FR/LC_MESSAGES/yelp.mo
%%SQUIRRELDIR%%/locale/fr_FR/LC_MESSAGES/yelp.po
%%SQUIRRELDIR%%/locale/fr_FR/setup.php
@@ -698,8 +704,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/id_ID/LC_MESSAGES/askuserinfo.po
%%SQUIRRELDIR%%/locale/id_ID/LC_MESSAGES/compatibility.mo
%%SQUIRRELDIR%%/locale/id_ID/LC_MESSAGES/compatibility.po
-%%SQUIRRELDIR%%/locale/id_ID/LC_MESSAGES/cookie_warning.po
%%SQUIRRELDIR%%/locale/id_ID/LC_MESSAGES/cookie_warning.mo
+%%SQUIRRELDIR%%/locale/id_ID/LC_MESSAGES/cookie_warning.po
%%SQUIRRELDIR%%/locale/id_ID/LC_MESSAGES/folder_sizes.mo
%%SQUIRRELDIR%%/locale/id_ID/LC_MESSAGES/folder_sizes.po
%%SQUIRRELDIR%%/locale/id_ID/LC_MESSAGES/select_language.mo
@@ -952,10 +958,10 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/smallcal.po
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/spam_buttons.mo
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/spam_buttons.po
-%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/squirrelmail.mo
-%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/squirrelmail.po
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/squirrel_logger.mo
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/squirrel_logger.po
+%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/squirrelmail.mo
+%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/squirrelmail.po
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/templates.mo
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/templates.po
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/unsafe_image_rules.mo
@@ -964,8 +970,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/vacation_local.po
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/verify_reply_to.mo
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/verify_reply_to.po
-%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/vkeyboard.mo
+%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/web_search.mo
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/web_search.po
%%SQUIRRELDIR%%/locale/nl_NL/LC_MESSAGES/yelp.mo
@@ -1059,8 +1065,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/nn_NO/LC_MESSAGES/vacation_local.po
%%SQUIRRELDIR%%/locale/nn_NO/LC_MESSAGES/verify_reply_to.mo
%%SQUIRRELDIR%%/locale/nn_NO/LC_MESSAGES/verify_reply_to.po
-%%SQUIRRELDIR%%/locale/nn_NO/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/nn_NO/LC_MESSAGES/vkeyboard.mo
+%%SQUIRRELDIR%%/locale/nn_NO/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/nn_NO/LC_MESSAGES/web_search.mo
%%SQUIRRELDIR%%/locale/nn_NO/LC_MESSAGES/web_search.po
%%SQUIRRELDIR%%/locale/nn_NO/LC_MESSAGES/yelp.mo
@@ -1077,8 +1083,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/pt_BR/LC_MESSAGES/squirrelmail.po
%%SQUIRRELDIR%%/locale/pt_BR/LC_MESSAGES/unsafe_image_rules.mo
%%SQUIRRELDIR%%/locale/pt_BR/LC_MESSAGES/unsafe_image_rules.po
-%%SQUIRRELDIR%%/locale/pt_BR/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/pt_BR/LC_MESSAGES/vkeyboard.mo
+%%SQUIRRELDIR%%/locale/pt_BR/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/pt_BR/setup.php
%%SQUIRRELDIR%%/locale/pt_PT/LC_MESSAGES/askuserinfo.mo
%%SQUIRRELDIR%%/locale/pt_PT/LC_MESSAGES/askuserinfo.po
@@ -1154,10 +1160,10 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/naguser.po
%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/newuser_wiz.mo
%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/newuser_wiz.po
-%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/quicksave.mo
-%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/quicksave.po
%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/qmailadmin_login.mo
%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/qmailadmin_login.po
+%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/quicksave.mo
+%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/quicksave.po
%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/reply_buttons.mo
%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/reply_buttons.po
%%SQUIRRELDIR%%/locale/sv_SE/LC_MESSAGES/restrict_senders.mo
@@ -1234,8 +1240,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/locale/uk_UA/LC_MESSAGES/templates.po
%%SQUIRRELDIR%%/locale/uk_UA/LC_MESSAGES/vacation_local.mo
%%SQUIRRELDIR%%/locale/uk_UA/LC_MESSAGES/vacation_local.po
-%%SQUIRRELDIR%%/locale/uk_UA/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/uk_UA/LC_MESSAGES/vkeyboard.mo
+%%SQUIRRELDIR%%/locale/uk_UA/LC_MESSAGES/vkeyboard.po
%%SQUIRRELDIR%%/locale/uk_UA/LC_MESSAGES/web_search.mo
%%SQUIRRELDIR%%/locale/uk_UA/LC_MESSAGES/web_search.po
%%SQUIRRELDIR%%/locale/uk_UA/LC_MESSAGES/yelp.mo
@@ -1267,13 +1273,13 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/plugins/calendar/setup.php
%%SQUIRRELDIR%%/plugins/delete_move_next/index.php
%%SQUIRRELDIR%%/plugins/delete_move_next/setup.php
-%%SQUIRRELDIR%%/plugins/demo/index.php
-%%SQUIRRELDIR%%/plugins/demo/getpot
-%%SQUIRRELDIR%%/plugins/demo/demo.pot
-%%SQUIRRELDIR%%/plugins/demo/setup.php
%%SQUIRRELDIR%%/plugins/demo/COPYING
%%SQUIRRELDIR%%/plugins/demo/demo.php
+%%SQUIRRELDIR%%/plugins/demo/demo.pot
%%SQUIRRELDIR%%/plugins/demo/functions.php
+%%SQUIRRELDIR%%/plugins/demo/getpot
+%%SQUIRRELDIR%%/plugins/demo/index.php
+%%SQUIRRELDIR%%/plugins/demo/setup.php
%%SQUIRRELDIR%%/plugins/filters/bulkquery/Makefile
%%SQUIRRELDIR%%/plugins/filters/bulkquery/bq.in
%%SQUIRRELDIR%%/plugins/filters/bulkquery/bq.out
@@ -1349,15 +1355,16 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/plugins/squirrelspell/sqspell_interface.php
%%SQUIRRELDIR%%/plugins/squirrelspell/sqspell_options.php
%%SQUIRRELDIR%%/plugins/test/COPYING
-%%SQUIRRELDIR%%/plugins/test/test.php
-%%SQUIRRELDIR%%/plugins/test/setup.php
%%SQUIRRELDIR%%/plugins/test/decodeheader.php
-%%SQUIRRELDIR%%/plugins/test/ngettext.php
-%%SQUIRRELDIR%%/plugins/test/index.php
%%SQUIRRELDIR%%/plugins/test/functions.php
+%%SQUIRRELDIR%%/plugins/test/index.php
+%%SQUIRRELDIR%%/plugins/test/ngettext.php
+%%SQUIRRELDIR%%/plugins/test/setup.php
+%%SQUIRRELDIR%%/plugins/test/test.php
%%SQUIRRELDIR%%/plugins/translate/index.php
%%SQUIRRELDIR%%/plugins/translate/options.php
%%SQUIRRELDIR%%/plugins/translate/setup.php
+%%SQUIRRELDIR%%/po/.htaccess
%%SQUIRRELDIR%%/po/compilepo
%%SQUIRRELDIR%%/po/independent_strings.txt
%%SQUIRRELDIR%%/po/index.php