aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2009-06-18 03:29:52 +0800
committerdb <db@FreeBSD.org>2009-06-18 03:29:52 +0800
commitd59ba6aa11e181b77d65b8a34923aa7dedf511c6 (patch)
treed1770eb784709b86466ab96bf0e429a595735cbc
parentd4b7ed0c4a95b6c217ab4d805dc8b9e0b1d11302 (diff)
downloadfreebsd-ports-gnome-d59ba6aa11e181b77d65b8a34923aa7dedf511c6.tar.gz
freebsd-ports-gnome-d59ba6aa11e181b77d65b8a34923aa7dedf511c6.tar.zst
freebsd-ports-gnome-d59ba6aa11e181b77d65b8a34923aa7dedf511c6.zip
- Ensure Fortran shim is not built if USE_FORTRAN is not set.
- Split Fortran option into slave ports fftw3-fortran long-fortran float-fortran - Have to bump PORTREVISION for package builds etc.. - Fix silly spelling mistakes "Percision" -> "Precision" noted. Reviewed by: itetcu (portmgr) Approved by: ahze (Maintainer)
-rw-r--r--math/fftw3-float-fortran/Makefile15
-rw-r--r--math/fftw3-float/Makefile4
-rw-r--r--math/fftw3-fortran/Makefile17
-rw-r--r--math/fftw3-long-fortran/Makefile17
-rw-r--r--math/fftw3-long/Makefile4
-rw-r--r--math/fftw3/Makefile24
6 files changed, 71 insertions, 10 deletions
diff --git a/math/fftw3-float-fortran/Makefile b/math/fftw3-float-fortran/Makefile
new file mode 100644
index 000000000000..efbe20080382
--- /dev/null
+++ b/math/fftw3-float-fortran/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: fftw3-float-fortran
+# Date created: June 14, 2009
+# Whom: Diane Bruce <db@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTREVISION= 0
+
+COMMENT= Fast C routines (Single Precision) with fortran shim
+
+FFTW3_FLAVOR= float
+FORTRAN_SHIM= yes
+MASTERDIR= ${.CURDIR}/../../math/fftw3
+
+.include "${MASTERDIR}/Makefile"
diff --git a/math/fftw3-float/Makefile b/math/fftw3-float/Makefile
index 888139a0e0a5..adc50e839d5c 100644
--- a/math/fftw3-float/Makefile
+++ b/math/fftw3-float/Makefile
@@ -5,9 +5,9 @@
# $FreeBSD$
# $MCom: ports-experimental/math/fftw3-float/Makefile,v 1.1 2006/03/28 00:08:57 ahze Exp $
-PORTREVISION= 0
+PORTREVISION= 1
-COMMENT= Fast C routines (Single Percision)
+COMMENT= Fast C routines (Single Precision)
FFTW3_FLAVOR= float
MASTERDIR= ${.CURDIR}/../../math/fftw3
diff --git a/math/fftw3-fortran/Makefile b/math/fftw3-fortran/Makefile
new file mode 100644
index 000000000000..3592ee0ffc80
--- /dev/null
+++ b/math/fftw3-fortran/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: fftw3-fortran
+# Date created: June 14, 2009
+# Whom: Diane Bruce <db@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTREVISION= 0
+
+COMMENT= Fast C routines (Long Double Precision) with fortran shim
+
+FFTW3_FLAVOR= default
+FORTRAN_SHIM= yes
+MASTERDIR= ${.CURDIR}/../../math/fftw3
+
+ONLY_FOR_ARCHS= i386 sparc64
+
+.include "${MASTERDIR}/Makefile"
diff --git a/math/fftw3-long-fortran/Makefile b/math/fftw3-long-fortran/Makefile
new file mode 100644
index 000000000000..eef9c69e32fb
--- /dev/null
+++ b/math/fftw3-long-fortran/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: fftw3-long-fortran
+# Date created: June 14, 2009
+# Whom: Diane Bruce <db@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTREVISION= 0
+
+COMMENT= Fast C routines (Long Double Precision) with fortran shim
+
+FFTW3_FLAVOR= long
+FORTRAN_SHIM= yes
+MASTERDIR= ${.CURDIR}/../../math/fftw3
+
+ONLY_FOR_ARCHS= i386 sparc64
+
+.include "${MASTERDIR}/Makefile"
diff --git a/math/fftw3-long/Makefile b/math/fftw3-long/Makefile
index 886521d70754..15c2227a9501 100644
--- a/math/fftw3-long/Makefile
+++ b/math/fftw3-long/Makefile
@@ -5,9 +5,9 @@
# $FreeBSD$
# $MCom: ports-experimental/math/fftw3-long/Makefile,v 1.1 2006/03/28 00:08:58 ahze Exp $
-PORTREVISION= 0
+PORTREVISION= 1
-COMMENT= Fast C routines (Long Double Percision)
+COMMENT= Fast C routines (Long Double Precision)
FFTW3_FLAVOR= long
MASTERDIR= ${.CURDIR}/../../math/fftw3
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 16017e042a85..70f5c37db159 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fftw3
PORTVERSION= 3.2.1
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
ftp://ftp.fftw.org/pub/fftw/old/
@@ -38,13 +38,14 @@ MAN1= fftw${FFTW3_SUFX}-wisdom.1
INSTALL_TARGET= install-pkgconfigDATA install-libLTLIBRARIES install-exec
.endif
-OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off \
- FORTRAN "Build Fortran shims (needs gcc from port)" on
+OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off
-.include <bsd.port.options.mk>
-
-.if defined(WITH_FORTRAN)
+.if defined(FORTRAN_SHIM)
USE_FORTRAN= yes
+CONFLICTS= fftw3-3*
+.else
+CONFIGURE_ARGS+= --disable-fortran
+CONFLICTS= fftw3-*fortran-3*
.endif
.include <bsd.port.pre.mk>
@@ -75,19 +76,30 @@ CONFIGURE_ENV+= CFLAGS="${CFLAGS_3DNOW}"
.if defined(FFTW3_FLAVOR)
.if ${FFTW3_FLAVOR}=="float"
FFTW3_SUFX= f
+.if defined(FORTRAN_SHIM)
+FFTW3_PKGNAMESUFFIX= -float-fortran
+.else
FFTW3_PKGNAMESUFFIX= -float
+.endif
CONFIGURE_ARGS+=--enable-float
.else
.if ${FFTW3_FLAVOR}=="long"
LIB_DEPENDS+= ml.0:${PORTSDIR}/math/ldouble
FFTW3_SUFX= l
+.if defined(FORTRAN_SHIM)
+FFTW3_PKGNAMESUFFIX= -long-fortran
+.else
FFTW3_PKGNAMESUFFIX= -long
+.endif
CONFIGURE_ARGS+=--enable-long-double
.endif
.endif
.endif
.if ${FFTW3_FLAVOR}=="default"
+.if defined(FORTRAN_SHIM)
+FFTW3_PKGNAMESUFFIX= -fortran
+.endif
PLIST_SUB+= DEF=""
.else
PLIST_SUB+= DEF="@comment "