aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-30 05:33:51 +0800
committermarino <marino@FreeBSD.org>2014-07-30 05:33:51 +0800
commitd67e1883b6d3deed93b173e9acc01cbe37453ad1 (patch)
tree573b41ca2d36acf29d49b3f41ac0308374ef3ef3
parent6837d062fa622486f3b212c35bf03ffa8f8b9bae (diff)
downloadfreebsd-ports-gnome-d67e1883b6d3deed93b173e9acc01cbe37453ad1.tar.gz
freebsd-ports-gnome-d67e1883b6d3deed93b173e9acc01cbe37453ad1.tar.zst
freebsd-ports-gnome-d67e1883b6d3deed93b173e9acc01cbe37453ad1.zip
science/minc2: Unbreak, Upgrade version 2.0.18 => 2.2.00 and stage
PR: 187764 Submitted by: Ports Fury
-rw-r--r--science/minc2/Makefile52
-rw-r--r--science/minc2/distinfo4
-rw-r--r--science/minc2/files/patch-Makefile.am53
-rw-r--r--science/minc2/files/patch-conversion_minctoecat_machine_indep.c20
-rw-r--r--science/minc2/pkg-descr8
-rw-r--r--science/minc2/pkg-message8
-rw-r--r--science/minc2/pkg-plist18
7 files changed, 99 insertions, 64 deletions
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
index 5dc1459eec09..ca729d91dec7 100644
--- a/science/minc2/Makefile
+++ b/science/minc2/Makefile
@@ -1,22 +1,11 @@
# Created by: jbacon
# $FreeBSD$
-############################################################################
-# http://www.bic.mni.mcgill.ca/software/minc/
-# is the ultimate source for MINC, and will always contain the latest
-# source release. If this port is not up to date enough for you,
-# you can download the latest sources and build manually. On FreeBSD,
-# you must configure with the environment variable LDFLAGS set to
-# ${LOCALBASE}/lib so that the configure script will find libnetcdf.
-# Of course, the netcdf port must be installed first.
-
PORTNAME= minc
-PORTVERSION= 2.0.18
-PORTREVISION= 2
+PORTVERSION= 2.2.00
PORTEPOCH= 1
CATEGORIES= science biology
-MASTER_SITES= http://packages.bic.mni.mcgill.ca/tgz/ \
- http://www.nitrc.org/frs/download.php/801/
+MASTER_SITES= GH
PKGNAMESUFFIX= 2
MAINTAINER= ports@FreeBSD.org
@@ -24,18 +13,35 @@ COMMENT= Medical Imaging NetCDF
LICENSE= BSD
-BROKEN= Fails to build
-
-LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf \
- libhdf5.so:${PORTSDIR}/science/hdf5
-
-USES= libtool
-USE_LDCONFIG= yes
-CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -DH5_USE_16_API
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5 \
+ libnetcdf.so:${PORTSDIR}/science/netcdf
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_GITHUB= yes
+GH_ACCOUNT= BIC-MNI
+GH_TAGNAME= release-${PORTVERSION}
+GH_COMMIT= 6f2f5b9
+
+USES= bison gmake libtool perl5 shebangfix
+SHEBANG_FILES= progs/mincview/mincview
+USE_PERL5= build
+USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
+LIBTOOLIZE_ARGS=--copy --force
+ACLOCAL_ARGS= -I m4 --automake-acdir=${ACLOCAL_DIR}
+AUTOMAKE_ARGS= --add-missing --copy --force-missing
CONFIGURE_ARGS= --enable-shared=yes --enable-static=yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+CFLAGS+= -Wno-error=return-type
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFLICTS= minc-1* zh-tk-[0-9]*
-LATEST_LINK= minc2
+
+pre-patch:
+ @${RM} -f ${WRKSRC}/ac_config_aux/*
+ @${RM} -f ${WRKSRC}/progs/minccalc/gram.[ch]
+ @${RM} -f ${WRKSRC}/progs/mincgen/ncgentab.[ch]
.include <bsd.port.mk>
diff --git a/science/minc2/distinfo b/science/minc2/distinfo
index c471ce509e14..7af7cd3aacf8 100644
--- a/science/minc2/distinfo
+++ b/science/minc2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (minc-2.0.18.tar.gz) = 674cc89c43edfdb1957251c0124ea83252740c667cf3c4d9fc6183dcdb10f3e5
-SIZE (minc-2.0.18.tar.gz) = 1628038
+SHA256 (minc-2.2.00.tar.gz) = 0a719564fd27775e08913e1ab7faeb96964c035ec2abfef85677b6965579cbfd
+SIZE (minc-2.2.00.tar.gz) = 3906835
diff --git a/science/minc2/files/patch-Makefile.am b/science/minc2/files/patch-Makefile.am
new file mode 100644
index 000000000000..e38283aec741
--- /dev/null
+++ b/science/minc2/files/patch-Makefile.am
@@ -0,0 +1,53 @@
+--- Makefile.am.orig
++++ Makefile.am
+@@ -274,28 +274,28 @@
+ m4/smr_WITH_BUILD_PATH.m4
+
+ ezMINC_files = \
+- ezminc/examples/volume_msq_dist.cpp
+- ezminc/examples/CMakeLists.txt
+- ezminc/examples/fuzzy_volume_similarity.cpp
+- ezminc/examples/trilinear_resample.cpp
+- ezminc/examples/volume_avg.cpp
+- ezminc/examples/volume_gtc_similarity.cpp
+- ezminc/examples/volume_similarity.cpp
+- ezminc/minc_1_simple_rw.cpp
+- ezminc/minc_1_simple_rw.h
+- ezminc/minc_io_4d_volume.h
+- ezminc/minc_io_fixed_vector.h
+- ezminc/minc_io_simple_volume.h
+- ezminc/tests/minc_rw_test2.cpp
+- ezminc/tests/minc_rw_test_4d.cpp
+- ezminc/tests/minc_rw_test_simple.cpp
+- ezminc/tests/CMakeLists.txt
+- ezminc/tests/ezminc_rw_test.cpp
+- ezminc/tests/ezminc_stats.cpp
+- ezminc/minc_1_simple.h
+- ezminc/CMakeLists.txt
+- ezminc/minc_1_rw.cpp
+- ezminc/minc_1_rw.h
++ ezminc/examples/volume_msq_dist.cpp \
++ ezminc/examples/CMakeLists.txt \
++ ezminc/examples/fuzzy_volume_similarity.cpp \
++ ezminc/examples/trilinear_resample.cpp \
++ ezminc/examples/volume_avg.cpp \
++ ezminc/examples/volume_gtc_similarity.cpp \
++ ezminc/examples/volume_similarity.cpp \
++ ezminc/minc_1_simple_rw.cpp \
++ ezminc/minc_1_simple_rw.h \
++ ezminc/minc_io_4d_volume.h \
++ ezminc/minc_io_fixed_vector.h \
++ ezminc/minc_io_simple_volume.h \
++ ezminc/tests/minc_rw_test2.cpp \
++ ezminc/tests/minc_rw_test_4d.cpp \
++ ezminc/tests/minc_rw_test_simple.cpp \
++ ezminc/tests/CMakeLists.txt \
++ ezminc/tests/ezminc_rw_test.cpp \
++ ezminc/tests/ezminc_stats.cpp \
++ ezminc/minc_1_simple.h \
++ ezminc/CMakeLists.txt \
++ ezminc/minc_1_rw.cpp \
++ ezminc/minc_1_rw.h \
+ ezminc/minc_io_exceptions.h
+
+ voxeltoworld_SOURCES = progs/coordinates/voxeltoworld.c
diff --git a/science/minc2/files/patch-conversion_minctoecat_machine_indep.c b/science/minc2/files/patch-conversion_minctoecat_machine_indep.c
deleted file mode 100644
index 556375778be4..000000000000
--- a/science/minc2/files/patch-conversion_minctoecat_machine_indep.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- conversion/minctoecat/machine_indep.c.orig 2007-03-29 07:08:46.000000000 +0200
-+++ conversion/minctoecat/machine_indep.c 2014-01-28 22:55:57.000000000 +0100
-@@ -61,7 +61,7 @@
- }
-
- #if defined(__alpha) || defined(_WIN32) /* LITTLE_ENDIAN : alpha, intel */
--ftovaxf(f, bufr)
-+void ftovaxf(f, bufr)
- float f;
- unsigned short *bufr;
- {
-@@ -84,7 +84,7 @@
- bufr[1] = ret >>16;
- }
- #else /* BIG ENDIAN : sun hp sgi*/
--ftovaxf(orig,number)
-+void ftovaxf(orig,number)
- unsigned short number[2];
- float orig;
- {
diff --git a/science/minc2/pkg-descr b/science/minc2/pkg-descr
index 0730d1b37440..159e38789ec9 100644
--- a/science/minc2/pkg-descr
+++ b/science/minc2/pkg-descr
@@ -1,10 +1,4 @@
MINC (Medical Imaging NetCDF) is a medical imaging data format and an
-associated set of tools and libraries. MINC was created in 1993 by Peter
-Neelin at the McConnell Brain Imaging Centre of the Montreal Neurological
-Institute. Many others have contributed to the design and implementation
-MINC over the years.
+associated set of tools and libraries.
WWW: http://www.bic.mni.mcgill.ca/ServicesSoftware/MINC
-
-Port maintainer: Jason W. Bacon
- jwbacon@tds.net
diff --git a/science/minc2/pkg-message b/science/minc2/pkg-message
deleted file mode 100644
index cc3dd854da2b..000000000000
--- a/science/minc2/pkg-message
+++ /dev/null
@@ -1,8 +0,0 @@
-=============================================================================
-For questions or comments regarding this port, please contact the
-port maintainer: jwbacon@tds.net
-
-For MINC usage, please visit the MINC WEB site at
-
-http://www.bic.mni.mcgill.ca/ServicesSoftware/MINC
-=============================================================================
diff --git a/science/minc2/pkg-plist b/science/minc2/pkg-plist
index 9b950ca353f3..a5308acb29a2 100644
--- a/science/minc2/pkg-plist
+++ b/science/minc2/pkg-plist
@@ -3,7 +3,10 @@ bin/ecattominc
bin/invert_raw_image
bin/minc_modify_header
bin/mincaverage
+bin/mincblob
bin/minccalc
+bin/minccmp
+bin/minccomplete
bin/mincconcat
bin/mincconvert
bin/minccopy
@@ -20,9 +23,11 @@ bin/minclookup
bin/mincmakescalar
bin/mincmakevector
bin/mincmath
+bin/mincmorph
bin/mincpik
bin/mincresample
bin/mincreshape
+bin/mincsample
bin/mincstats
bin/minctoecat
bin/minctoraw
@@ -36,6 +41,7 @@ bin/upet2mnc
bin/vff2mnc
bin/voxeltoworld
bin/worldtovoxel
+bin/xfm2def
bin/xfmconcat
bin/xfmflip
bin/xfminvert
@@ -66,18 +72,21 @@ include/volume_io/volume_cache.h
include/voxel_loop.h
lib/libminc2.a
lib/libminc2.so
-lib/libminc2.so.1
-lib/libminc2.so.1.1.2
+lib/libminc2.so.3
+lib/libminc2.so.3.0.0
lib/libvolume_io2.a
lib/libvolume_io2.so
-lib/libvolume_io2.so.1
-lib/libvolume_io2.so.1.1.2
+lib/libvolume_io2.so.3
+lib/libvolume_io2.so.3.0.0
man/man1/dcm2mnc.1.gz
man/man1/ecattominc.1.gz
man/man1/invert_raw_image.1.gz
man/man1/minc_modify_header.1.gz
man/man1/mincaverage.1.gz
+man/man1/mincblob.1.gz
man/man1/minccalc.1.gz
+man/man1/minccmp.1.gz
+man/man1/minccomplete.1.gz
man/man1/mincconcat.1.gz
man/man1/mincconvert.1.gz
man/man1/minccopy.1.gz
@@ -108,6 +117,7 @@ man/man1/transformtags.1.gz
man/man1/upet2mnc.1.gz
man/man1/vff2mnc.1.gz
man/man1/voxeltoworld.1.gz
+man/man1/xfm2def.1.gz
man/man1/xfmconcat.1.gz
man/man1/xfmflip.1.gz
man/man1/xfminvert.1.gz