aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-08-31 10:03:21 +0800
committermarcus <marcus@FreeBSD.org>2003-08-31 10:03:21 +0800
commite265fcdc2b0f324a9a617c7a0c56616d94d6a8b8 (patch)
treecf6218eb6dbe9de4e3df6106174455d4f59dfc5a
parentadb4fcf7201084dd01af1bd46f4bd2f250c8fa83 (diff)
downloadfreebsd-ports-gnome-e265fcdc2b0f324a9a617c7a0c56616d94d6a8b8.tar.gz
freebsd-ports-gnome-e265fcdc2b0f324a9a617c7a0c56616d94d6a8b8.tar.zst
freebsd-ports-gnome-e265fcdc2b0f324a9a617c7a0c56616d94d6a8b8.zip
Allow for selection of ghostscript port.
PR: 54943 Submitted by: Jens Rehsack <rehsack@liwing.de> (based on)
-rw-r--r--print/gnome-print/Makefile22
-rw-r--r--print/gnomeprint/Makefile22
2 files changed, 40 insertions, 4 deletions
diff --git a/print/gnome-print/Makefile b/print/gnome-print/Makefile
index 50ebce79d61c..28e5fce1207f 100644
--- a/print/gnome-print/Makefile
+++ b/print/gnome-print/Makefile
@@ -16,9 +16,19 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gnome print support library
+.if defined(WITH_GHOSTSCRIPT_AFPL)
+.if ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 # XXX
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
PLIST_SUB= VERSION=${PORTVERSION}
@@ -30,7 +40,15 @@ USE_GNOME= gnomehack gnomeprefix gnomehier gnomelibs gnomecanvas
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-everything::
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO_MSG} ""
+.endif
post-install:
@${TOUCH} ${PREFIX}/etc/gnome/fonts/gnome-print-x11.fontmap
diff --git a/print/gnomeprint/Makefile b/print/gnomeprint/Makefile
index 50ebce79d61c..28e5fce1207f 100644
--- a/print/gnomeprint/Makefile
+++ b/print/gnomeprint/Makefile
@@ -16,9 +16,19 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gnome print support library
+.if defined(WITH_GHOSTSCRIPT_AFPL)
+.if ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 # XXX
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
PLIST_SUB= VERSION=${PORTVERSION}
@@ -30,7 +40,15 @@ USE_GNOME= gnomehack gnomeprefix gnomehier gnomelibs gnomecanvas
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-everything::
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO_MSG} ""
+.endif
post-install:
@${TOUCH} ${PREFIX}/etc/gnome/fonts/gnome-print-x11.fontmap