aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2017-04-14 15:53:55 +0800
committerdbn <dbn@FreeBSD.org>2017-04-14 15:53:55 +0800
commite368a313ba8cf2c318e8186b99d2e3830645ed4c (patch)
treea3322c8313ac8918e4a49acedca4e56d98515ce5
parent018a3ce502d9617e19ef4026a9dc2b01d465ed83 (diff)
downloadfreebsd-ports-gnome-e368a313ba8cf2c318e8186b99d2e3830645ed4c.tar.gz
freebsd-ports-gnome-e368a313ba8cf2c318e8186b99d2e3830645ed4c.tar.zst
freebsd-ports-gnome-e368a313ba8cf2c318e8186b99d2e3830645ed4c.zip
devel/py-mypy: update to 0.501
- Remove unneeded patches (superseded by upstream) - Track minimum depedency on py-typed-ast Change Log: - typed_ast is used as the default parser (i.e. --fast-parser is now the default) - Python 3.6 features supported by default - Simples metaclass support added - The --warn-no-return flag is now default: warns about missing return statements - A function that doesn't return can be annotated (using mypy_extensions.NoReturn) - Redundant Generic[T] no longer needed - Checking of assignments in a class body - The --strict flag is added, that turns on most additional checks PR: 218303 Approved by: Florian Limberger <flo@snakeoilproductions.net>
-rw-r--r--devel/py-mypy/Makefile4
-rw-r--r--devel/py-mypy/distinfo6
-rw-r--r--devel/py-mypy/files/patch-mypy_fastparse.py11
-rw-r--r--devel/py-mypy/files/patch-mypy_fastparse2.py11
4 files changed, 5 insertions, 27 deletions
diff --git a/devel/py-mypy/Makefile b/devel/py-mypy/Makefile
index 7bd1c4372659..bfe3f70b0269 100644
--- a/devel/py-mypy/Makefile
+++ b/devel/py-mypy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mypy
-PORTVERSION= 0.471
+PORTVERSION= 0.501
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +14,7 @@ LICENSE= MIT PSFL
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typed-ast>=0.6.3:devel/py-typed-ast
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typed-ast>=1.0.0:devel/py-typed-ast
NO_ARCH= yes
USES= python:3.3+
diff --git a/devel/py-mypy/distinfo b/devel/py-mypy/distinfo
index a2ab7e610a44..efef63072305 100644
--- a/devel/py-mypy/distinfo
+++ b/devel/py-mypy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1487173104
-SHA256 (mypy-0.471.tar.gz) = 552821e4ae601e9058797cfc7d251ff6a2789b5b5aeb00df017f76271d726e9f
-SIZE (mypy-0.471.tar.gz) = 660228
+TIMESTAMP = 1490943629
+SHA256 (mypy-0.501.tar.gz) = 1098ba0bc55b4f6cebdf35f1303be31107f2ae5a753f9aec28aaff2d701b8f98
+SIZE (mypy-0.501.tar.gz) = 679701
diff --git a/devel/py-mypy/files/patch-mypy_fastparse.py b/devel/py-mypy/files/patch-mypy_fastparse.py
deleted file mode 100644
index 06d0f2a3437d..000000000000
--- a/devel/py-mypy/files/patch-mypy_fastparse.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- mypy/fastparse.py.orig 2017-02-15 15:30:38 UTC
-+++ mypy/fastparse.py
-@@ -26,7 +26,7 @@ from mypy import experiments
- from mypy.errors import Errors
-
- try:
-- from typed_ast import ast35
-+ from typed_ast import ast3 as ast35
- except ImportError:
- if sys.version_info.minor > 2:
- print('You must install the typed_ast package before you can run mypy'
diff --git a/devel/py-mypy/files/patch-mypy_fastparse2.py b/devel/py-mypy/files/patch-mypy_fastparse2.py
deleted file mode 100644
index 803e6ef04b51..000000000000
--- a/devel/py-mypy/files/patch-mypy_fastparse2.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- mypy/fastparse2.py.orig 2017-02-15 15:30:42 UTC
-+++ mypy/fastparse2.py
-@@ -43,7 +43,7 @@ from mypy.fastparse import TypeConverter
-
- try:
- from typed_ast import ast27
-- from typed_ast import ast35
-+ from typed_ast import ast3 as ast35
- except ImportError:
- if sys.version_info.minor > 2:
- print('You must install the typed_ast package before you can run mypy'