aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-01-01 00:54:30 +0800
committertota <tota@FreeBSD.org>2011-01-01 00:54:30 +0800
commite7c742fd7b3df4a2d4dc44951bfcc38d6f10f28f (patch)
tree86a3c7b4f38ae5f7ff6740ffc29f3a4d43550b3f
parent488cc6dd1b259e6121e6e759e450b75b1366db16 (diff)
downloadfreebsd-ports-gnome-e7c742fd7b3df4a2d4dc44951bfcc38d6f10f28f.tar.gz
freebsd-ports-gnome-e7c742fd7b3df4a2d4dc44951bfcc38d6f10f28f.tar.zst
freebsd-ports-gnome-e7c742fd7b3df4a2d4dc44951bfcc38d6f10f28f.zip
- Add a new port: graphics/php5-swfed
SWF Editor is an extension for PHP that edits contents in SWF file. WWW: http://sourceforge.jp/projects/swfed/
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/php5-swfed/Makefile65
-rw-r--r--graphics/php5-swfed/distinfo2
-rw-r--r--graphics/php5-swfed/files/patch-config-lib.m420
-rw-r--r--graphics/php5-swfed/pkg-descr3
-rw-r--r--graphics/php5-swfed/pkg-plist7
6 files changed, 98 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 544fa8158275..c3c85f08cd86 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -719,6 +719,7 @@
SUBDIR += php5-exif
SUBDIR += php5-ffmpeg
SUBDIR += php5-gd
+ SUBDIR += php5-swfed
SUBDIR += php52-exif
SUBDIR += php52-gd
SUBDIR += php52-ming
diff --git a/graphics/php5-swfed/Makefile b/graphics/php5-swfed/Makefile
new file mode 100644
index 000000000000..90109693a6f0
--- /dev/null
+++ b/graphics/php5-swfed/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: php5-swfed
+# Date created: 2010-06-13
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= swfed
+PORTVERSION= 0.28
+CATEGORIES= graphics www
+MASTER_SITES= SFJP
+MASTER_SITE_SUBDIR= ${PORTNAME}/50400
+PKGNAMEPREFIX= php5-
+
+MAINTAINER= yoya@awm.jp
+COMMENT= A PHP extension to edit SWF file
+
+BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c
+
+DEFAULT_PHP_VER= 5
+IGNORE_WITH_PHP= 4
+USE_PHP= zlib
+USE_PHPEXT= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+CONFIGURE_ARGS= --with-zlib-dir=yes
+
+PORTDOCS= readme.txt
+PORTEXAMPLES= *
+
+PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+
+OPTIONS= GIF "With gif image support" on \
+ PNG "With png image support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GIF)
+LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
+CONFIGURE_ARGS+= --with-gif-dir=yes
+.else
+CONFIGURE_ARGS+= --with-gif-dir=no
+.endif
+
+.if defined(WITH_PNG)
+LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+CONFIGURE_ARGS+= --with-png-dir=yes
+.else
+CONFIGURE_ARGS+= --with-png-dir=no
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/${PORTDOCS} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/sample/${PORTEXAMPLES} ${EXAMPLESDIR}
+.endif
+ @${MKDIR} ${WWWDIR}
+ @${CP} -R ${WRKDIR}/${DISTNAME}/www/ ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
+.include <bsd.port.post.mk>
diff --git a/graphics/php5-swfed/distinfo b/graphics/php5-swfed/distinfo
new file mode 100644
index 000000000000..4492555e1b6d
--- /dev/null
+++ b/graphics/php5-swfed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (swfed-0.28.tar.gz) = 45e04cb0962109b9333ebe4ac990e4b1a3e2c9cda2e515b2c5fc76d178cae3f4
+SIZE (swfed-0.28.tar.gz) = 67107
diff --git a/graphics/php5-swfed/files/patch-config-lib.m4 b/graphics/php5-swfed/files/patch-config-lib.m4
new file mode 100644
index 000000000000..6cae29d3b217
--- /dev/null
+++ b/graphics/php5-swfed/files/patch-config-lib.m4
@@ -0,0 +1,20 @@
+--- config-lib.m4.orig 2010-04-20 10:09:36.000000000 +0900
++++ config-lib.m4 2010-06-13 13:01:53.000000000 +0900
+@@ -70,7 +70,7 @@
+ else
+ AC_MSG_ERROR([Can't find LIBPNG headers under "$PHP_PNG_DIR"])
+ fi
+- else
++ elif test "$PHP_PNG_DIR" = "yes"; then
+ for i in /usr/local /usr; do
+ if test -f "$i/include/libpng/png.h"; then
+ AC_DEFINE(HAVE_PNG,1,[ ])
+@@ -115,7 +115,7 @@
+ else
+ AC_MSG_ERROR([Can't find GIFLIB headers under "$PHP_GIF_DIR"])
+ fi
+- else
++ elif test "$PHP_GIF_DIR" = "yes"; then
+ for i in /usr/local /usr; do
+ if test -f "$i/include/giflib/gif_lib.h"; then
+ AC_DEFINE(HAVE_GIF,1,[ ])
diff --git a/graphics/php5-swfed/pkg-descr b/graphics/php5-swfed/pkg-descr
new file mode 100644
index 000000000000..76dfec463a61
--- /dev/null
+++ b/graphics/php5-swfed/pkg-descr
@@ -0,0 +1,3 @@
+SWF Editor is an extension for PHP that edits contents in SWF file.
+
+WWW: http://sourceforge.jp/projects/swfed/
diff --git a/graphics/php5-swfed/pkg-plist b/graphics/php5-swfed/pkg-plist
new file mode 100644
index 000000000000..bc803755df3c
--- /dev/null
+++ b/graphics/php5-swfed/pkg-plist
@@ -0,0 +1,7 @@
+%%WWWDIR%%/define.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/swfimage.php
+%%WWWDIR%%/swfimagelist.php
+%%WWWDIR%%/swfimagereplace.php
+@dirrm %%WWWDIR%%
+@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%