aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2013-07-17 23:04:40 +0800
committerosa <osa@FreeBSD.org>2013-07-17 23:04:40 +0800
commite96bb547649388c78558dbda8247b0fb3034437c (patch)
treef86ce8828a07ac7fba625fb561b23948773e46a0
parent186e57567448cf40c714a00d5af7d889bfa59d5b (diff)
downloadfreebsd-ports-gnome-e96bb547649388c78558dbda8247b0fb3034437c.tar.gz
freebsd-ports-gnome-e96bb547649388c78558dbda8247b0fb3034437c.tar.zst
freebsd-ports-gnome-e96bb547649388c78558dbda8247b0fb3034437c.zip
Update from 1.4.1 to 1.4.2.
Remove needless patch. <ChangeLog> *) Bugfix: the $r->header_in() embedded perl method did not return value of the "Cookie" and "X-Forwarded-For" request header lines; the bug had appeared in 1.3.14. *) Bugfix: nginx could not be built with the ngx_mail_ssl_module, but without ngx_http_ssl_module; the bug had appeared in 1.3.14. *) Bugfix: in the "proxy_set_body" directive. Thanks to Lanshun Zhou. *) Bugfix: the "fail_timeout" parameter of the "server" directive in the "upstream" context might not work if "max_fails" parameter was used; the bug had appeared in 1.3.0. *) Bugfix: a segmentation fault might occur in a worker process if the "ssl_stapling" directive was used. Thanks to Piotr Sikora. *) Bugfix: nginx/Windows might stop accepting connections if several worker processes were used. </ChangeLog>
-rw-r--r--www/nginx/Makefile3
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/patch-fix-mail-ssl79
3 files changed, 3 insertions, 83 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 948af4737f59..b28065cbcd29 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nginx
-PORTVERSION= 1.4.1
-PORTREVISION= 1
+PORTVERSION= 1.4.2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index bdab420b16ff..1d17caf12ef5 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-1.4.1.tar.gz) = bca5d1e89751ba29406185e1736c390412603a7e6b604f5b4575281f6565d119
-SIZE (nginx-1.4.1.tar.gz) = 767107
+SHA256 (nginx-1.4.2.tar.gz) = 5361ffb7b0ebf8b1a04369bc3d1295eaed091680c1c58115f88d56c8e51f3611
+SIZE (nginx-1.4.2.tar.gz) = 767688
SHA256 (giom-nginx_accept_language_module-02262ce.tar.gz) = 3191f4caa70d9a8942c4f10b6abaaa96af451991d4b5e1e3d7b991376b00bf0c
SIZE (giom-nginx_accept_language_module-02262ce.tar.gz) = 3398
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
diff --git a/www/nginx/files/patch-fix-mail-ssl b/www/nginx/files/patch-fix-mail-ssl
deleted file mode 100644
index 7836236ad21f..000000000000
--- a/www/nginx/files/patch-fix-mail-ssl
+++ /dev/null
@@ -1,79 +0,0 @@
-
-# HG changeset patch
-# User Maxim Dounin <mdounin@mdounin.ru>
-# Date 1368283770 -14400
-# Node ID 9d83ec073c514acec7adc84ee15d74692a5def7a
-# Parent 3494f14aa46a098bfcb4a1dc24acc7826cdd603b
-Fixed build with --with-mail_ssl_module.
-
-If nginx was compiled without --with-http_ssl_module, but with some
-other module which uses OpenSSL (e.g. --with-mail_ssl_module), insufficient
-preprocessor check resulted in build failure. The problem was introduced
-by e0a3714a36f8 (1.3.14).
-
-Reported by Roman Arutyunyan.
-
-diff -r 3494f14aa46a -r 9d83ec073c51 src/http/ngx_http.h
---- src/http/ngx_http.h Sat May 11 18:49:19 2013 +0400
-+++ src/http/ngx_http.h Sat May 11 18:49:30 2013 +0400
-@@ -89,7 +89,7 @@
- void ngx_http_init_connection(ngx_connection_t *c);
- void ngx_http_close_connection(ngx_connection_t *c);
-
--#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
-+#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
- int ngx_http_ssl_servername(ngx_ssl_conn_t *ssl_conn, int *ad, void *arg);
- #endif
-
-diff -r 3494f14aa46a -r 9d83ec073c51 src/http/ngx_http_request.c
---- src/http/ngx_http_request.c Sat May 11 18:49:19 2013 +0400
-+++ src/http/ngx_http_request.c Sat May 11 18:49:30 2013 +0400
-@@ -1955,7 +1955,7 @@
-
- hc = r->http_connection;
-
--#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
-+#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
-
- if (hc->ssl_servername) {
- if (hc->ssl_servername->len == host->len
-@@ -1986,7 +1986,7 @@
- return NGX_ERROR;
- }
-
--#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
-+#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
-
- if (hc->ssl_servername) {
- ngx_http_ssl_srv_conf_t *sscf;
-@@ -2053,7 +2053,7 @@
-
- sn = virtual_names->regex;
-
--#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
-+#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
-
- if (r == NULL) {
- ngx_http_connection_t *hc;
-@@ -2085,7 +2085,7 @@
- return NGX_DECLINED;
- }
-
--#endif /* SSL_CTRL_SET_TLSEXT_HOSTNAME */
-+#endif /* NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME */
-
- for (i = 0; i < virtual_names->nregex; i++) {
-
-diff -r 3494f14aa46a -r 9d83ec073c51 src/http/ngx_http_request.h
---- src/http/ngx_http_request.h Sat May 11 18:49:19 2013 +0400
-+++ src/http/ngx_http_request.h Sat May 11 18:49:30 2013 +0400
-@@ -295,7 +295,7 @@
- ngx_http_addr_conf_t *addr_conf;
- ngx_http_conf_ctx_t *conf_ctx;
-
--#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
-+#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
- ngx_str_t *ssl_servername;
- #if (NGX_PCRE)
- ngx_http_regex_t *ssl_servername_regex;
-