aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-11 04:10:27 +0800
committermarcus <marcus@FreeBSD.org>2003-04-11 04:10:27 +0800
commite9e061a5c8d1b7d808411071d135a4da28f40110 (patch)
tree05e6a24cd9b382a27aa32cfbe091be9df4835b96
parent21333a719a2e7e41ead8915f78663d08051592a1 (diff)
downloadfreebsd-ports-gnome-e9e061a5c8d1b7d808411071d135a4da28f40110.tar.gz
freebsd-ports-gnome-e9e061a5c8d1b7d808411071d135a4da28f40110.tar.zst
freebsd-ports-gnome-e9e061a5c8d1b7d808411071d135a4da28f40110.zip
Update to 2.1.4. This fixes the memory leak exploited by fc-cache
and fontconfig. With this update, fc-cache takes no more that 2.1 MB when running against full XFree fonts as well as webfonts, URW fonts, and a collection of Internet-downloaded TrueType fonts. PR: 50791 Submitted by: anholt and myself Approved by: sobomax (maintainer)
-rw-r--r--print/freetype2/Makefile5
-rw-r--r--print/freetype2/distinfo2
-rw-r--r--print/freetype2/files/patch-src_gzip_ftgzip.c20
-rw-r--r--print/freetype2/files/patch-src_gzip_infcodes.c13
-rw-r--r--print/freetype2/pkg-plist1
5 files changed, 4 insertions, 37 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index baed1ac69f91..7be3ef7c67f9 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= freetype2
-PORTVERSION= 2.1.3
-PORTREVISION= 1
+PORTVERSION= 2.1.4
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%,freetype,} \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/%SUBDIR%/ \
@@ -28,7 +27,7 @@ INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
LIBTOOLFILES= builds/unix/configure
CONFIGURE_ARGS= --disable-nls
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_WRKSRC= ${WRKSRC}/builds/unix
post-configure:
diff --git a/print/freetype2/distinfo b/print/freetype2/distinfo
index 99b096b25677..5410ccb3ad0a 100644
--- a/print/freetype2/distinfo
+++ b/print/freetype2/distinfo
@@ -1 +1 @@
-MD5 (freetype-2.1.3.tar.bz2) = 09775a4111e066f782866d8a57d8481b
+MD5 (freetype-2.1.4.tar.bz2) = 1fc0b188f1fe1216776e5855d2da141f
diff --git a/print/freetype2/files/patch-src_gzip_ftgzip.c b/print/freetype2/files/patch-src_gzip_ftgzip.c
deleted file mode 100644
index 260fa8e479b3..000000000000
--- a/print/freetype2/files/patch-src_gzip_ftgzip.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/gzip/ftgzip.c.orig Sat Jan 18 13:04:29 2003
-+++ src/gzip/ftgzip.c Sat Jan 18 13:04:40 2003
-@@ -177,7 +177,7 @@
- (void)FT_STREAM_SKIP( 6 );
-
- /* skip the extra field */
-- if ( head[3] && FT_GZIP_EXTRA_FIELD )
-+ if ( head[3] & FT_GZIP_EXTRA_FIELD )
- {
- FT_UInt len;
-
-@@ -187,7 +187,7 @@
- }
-
- /* skip original file name */
-- if ( head[3] && FT_GZIP_ORIG_NAME )
-+ if ( head[3] & FT_GZIP_ORIG_NAME )
- for (;;)
- {
- FT_UInt c;
diff --git a/print/freetype2/files/patch-src_gzip_infcodes.c b/print/freetype2/files/patch-src_gzip_infcodes.c
deleted file mode 100644
index c8d8f911f1ff..000000000000
--- a/print/freetype2/files/patch-src_gzip_infcodes.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/gzip/infcodes.c.orig Sat Jan 18 15:44:46 2003
-+++ src/gzip/infcodes.c Sat Jan 18 15:46:10 2003
-@@ -196,8 +196,8 @@
- c->mode = COPY;
- case COPY: /* o: copying bytes in window, waiting for space */
- f = q - c->sub.copy.dist;
-- while (f < s->window) /* modulo window size-"while" instead */
-- f += s->end - s->window; /* of "if" handles invalid distances */
-+ if ((uInt)(q - s->window) < c->sub.copy.dist)
-+ f = s->end - (c->sub.copy.dist - (uInt)(q - s->window));
- while (c->len)
- {
- NEEDOUT
diff --git a/print/freetype2/pkg-plist b/print/freetype2/pkg-plist
index 9ffc44107d9c..bf2f4c39913e 100644
--- a/print/freetype2/pkg-plist
+++ b/print/freetype2/pkg-plist
@@ -39,6 +39,7 @@ include/freetype2/freetype/ftsysmem.h
include/freetype2/freetype/ftsystem.h
include/freetype2/freetype/fttrigon.h
include/freetype2/freetype/fttypes.h
+include/freetype2/freetype/ftwinfnt.h
include/freetype2/freetype/ftxf86.h
include/freetype2/freetype/internal/autohint.h
include/freetype2/freetype/internal/bdftypes.h