aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-09-03 20:50:47 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-09-03 20:50:47 +0800
commitec0b4cdf0650ca2a8679ea73f8b5b0d3dbe2c0a4 (patch)
treedb4d66f0629ac38791b9dbb977d3a5980135df5a
parent833c3c5215747fcccc51dd346b6627c20381b9f5 (diff)
downloadfreebsd-ports-gnome-ec0b4cdf0650ca2a8679ea73f8b5b0d3dbe2c0a4.tar.gz
freebsd-ports-gnome-ec0b4cdf0650ca2a8679ea73f8b5b0d3dbe2c0a4.tar.zst
freebsd-ports-gnome-ec0b4cdf0650ca2a8679ea73f8b5b0d3dbe2c0a4.zip
- Followup to r325807, with USE_PACKAGE_DEPENDS_ONLY, still allow
ports framework to use the port for *_DEPENDS= ${NONEXISTENT}:PORT:target dependencies An example port is irc/gseen.mod, it depends on another port being extracted, not an installed pkg. PR: ports/180725 Reported by: antoine With hat: portmgr
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ce15e41d8738..89ddefc44634 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4923,7 +4923,7 @@ _INSTALL_DEPENDS= \
else \
${PKG_ADD} $${subpkgfile}; \
fi; \
- elif [ -n "${USE_PACKAGE_DEPENDS_ONLY}" ]; then \
+ elif [ -n "${USE_PACKAGE_DEPENDS_ONLY}" -a "$${target}" = "${DEPENDS_TARGET}" ]; then \
${ECHO_MSG} "===> ${PKGNAME} depends on package: $${subpkgfile} - not found"; \
${ECHO_MSG} "===> USE_PACKAGE_DEPENDS_ONLY set - will not build from source"; \
exit 1; \