aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2015-05-20 06:49:19 +0800
committermadpilot <madpilot@FreeBSD.org>2015-05-20 06:49:19 +0800
commitfddf29e5e40635a70337034e01bf20e0d5c44a51 (patch)
tree1632ce17dcdb389105fea62becbb047c96a0b2f8
parent22fc186f220eaceb149e33bd99a11019e00de971 (diff)
downloadfreebsd-ports-gnome-fddf29e5e40635a70337034e01bf20e0d5c44a51.tar.gz
freebsd-ports-gnome-fddf29e5e40635a70337034e01bf20e0d5c44a51.tar.zst
freebsd-ports-gnome-fddf29e5e40635a70337034e01bf20e0d5c44a51.zip
Add patch to force port to link against qt4, as the port Makefile
clearly states. Otherwise this software unconditionally checks for the presence of qt5 and link against that breaking a depending port and linking against unregistered dependencies. This is just a quick fix, to avoid core dumps in deskutils/owncloud. I'll post a more proper update to this port later. Reported by: Tobias Berner <tcberner at gmail.com>, Marko Cupac <marko.cupac at mimar.rs> Approved by: "Just Fix It" blanket
-rw-r--r--security/qtkeychain/Makefile1
-rw-r--r--security/qtkeychain/files/patch-CMakeLists.txt70
2 files changed, 71 insertions, 0 deletions
diff --git a/security/qtkeychain/Makefile b/security/qtkeychain/Makefile
index 42f886056df9..c3e9c89e5cb2 100644
--- a/security/qtkeychain/Makefile
+++ b/security/qtkeychain/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qtkeychain
PORTVERSION= 0.1.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= 6yearold@gmail.com
diff --git a/security/qtkeychain/files/patch-CMakeLists.txt b/security/qtkeychain/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9459d84c81ca
--- /dev/null
+++ b/security/qtkeychain/files/patch-CMakeLists.txt
@@ -0,0 +1,70 @@
+--- CMakeLists.txt.orig 2013-01-16 18:02:17 UTC
++++ CMakeLists.txt
+@@ -11,32 +11,32 @@ set(QTKEYCHAIN_SOVERSION 0)
+ set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${PROJECT_SOURCE_DIR}/cmake/Modules")
+ include(GNUInstallDirs)
+
+-# try Qt5 first, and prefer that if found
+-find_package(Qt5Core QUIET)
+-if (Qt5Core_FOUND)
+- if(UNIX AND NOT APPLE)
+- find_package(Qt5DBus REQUIRED)
+- include_directories(${Qt5DBus_INCLUDE_DIRS})
+- set(QTDBUS_LIBRARIES ${Qt5DBus_LIBRARIES})
+- macro(qt_add_dbus_interface)
+- qt5_add_dbus_interface(${ARGN})
+- endmacro()
+- endif()
+- macro(qt_wrap_cpp)
+- qt5_wrap_cpp(${ARGN})
+- endmacro()
+-
+- set(QTCORE_LIBRARIES ${Qt5Core_LIBRARIES})
+- include_directories(${Qt5Core_INCLUDE_DIRS})
+-
+- if (Qt5_POSITION_INDEPENDENT_CODE)
+- if (CMAKE_VERSION VERSION_LESS 2.8.9) # TODO remove once we increase the cmake requirement
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
+- else()
+- set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+- endif()
+- endif()
+-else()
++# Force Qt4
++#find_package(Qt5Core QUIET)
++#if (Qt5Core_FOUND)
++# if(UNIX AND NOT APPLE)
++# find_package(Qt5DBus REQUIRED)
++# include_directories(${Qt5DBus_INCLUDE_DIRS})
++# set(QTDBUS_LIBRARIES ${Qt5DBus_LIBRARIES})
++# macro(qt_add_dbus_interface)
++# qt5_add_dbus_interface(${ARGN})
++# endmacro()
++# endif()
++# macro(qt_wrap_cpp)
++# qt5_wrap_cpp(${ARGN})
++# endmacro()
++#
++# set(QTCORE_LIBRARIES ${Qt5Core_LIBRARIES})
++# include_directories(${Qt5Core_INCLUDE_DIRS})
++#
++# if (Qt5_POSITION_INDEPENDENT_CODE)
++# if (CMAKE_VERSION VERSION_LESS 2.8.9) # TODO remove once we increase the cmake requirement
++# set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
++# else()
++# set(CMAKE_POSITION_INDEPENDENT_CODE ON)
++# endif()
++# endif()
++#else()
+ if(UNIX AND NOT APPLE)
+ find_package(Qt4 COMPONENTS QtCore QtDBus REQUIRED)
+ macro(qt_add_dbus_interface)
+@@ -51,7 +51,7 @@ else()
+ endif()
+ include_directories(${QT_INCLUDES})
+ set(QTCORE_LIBRARIES ${QT_QTCORE_LIBRARY})
+-endif()
++#endif()
+
+
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})