aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2012-07-25 03:24:22 +0800
committerohauer <ohauer@FreeBSD.org>2012-07-25 03:24:22 +0800
commitfe78b66c4f2616529f0f1f0e30dd83f538826a04 (patch)
treeb8f872dcfbfbd83f75cdb7f67527f0b6f41a466a
parentae946aa4b05a5f8293213523fae4e119698357cb (diff)
downloadfreebsd-ports-gnome-fe78b66c4f2616529f0f1f0e30dd83f538826a04.tar.gz
freebsd-ports-gnome-fe78b66c4f2616529f0f1f0e30dd83f538826a04.tar.zst
freebsd-ports-gnome-fe78b66c4f2616529f0f1f0e30dd83f538826a04.zip
- fix broken mod_perl include
apache version detect was not enabled, the time SITE_PERL was removed from *_DEPENDS
-rw-r--r--devel/bugzilla/Makefile6
-rw-r--r--devel/bugzilla3/Makefile6
-rw-r--r--mail/p5-qpsmtpd/Makefile10
3 files changed, 19 insertions, 3 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index e0d36efaf877..84c27363be85 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -58,6 +58,12 @@ OPTIONS= MYSQL "MySQL database support" off \
LDAP "LDAP Authentication" off \
RADIUS "RADIUS Authentication" off
+.include <bsd.port.options.mk>
+
+.ifdef (WITH_MODPERL2)
+USE_APACHE_RUN= 20+
+.endif
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 501000
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index 25d14625d328..b2079dad4db2 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -58,6 +58,12 @@ OPTIONS= MYSQL "MySQL database support" off \
LDAP "LDAP Authentication" off \
RADIUS "RADIUS Authentication" off
+.include <bsd.port.options.mk>
+
+.ifdef (WITH_MODPERL2)
+USE_APACHE_RUN= 20+
+.endif
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 501000
diff --git a/mail/p5-qpsmtpd/Makefile b/mail/p5-qpsmtpd/Makefile
index b5c243dcf571..946b6cf9c3b6 100644
--- a/mail/p5-qpsmtpd/Makefile
+++ b/mail/p5-qpsmtpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qpsmtpd
PORTVERSION= 0.84
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail perl5
MASTER_SITES= http://smtpd.develooper.com/files/
PKGNAMEPREFIX= p5-
@@ -25,9 +25,13 @@ BUILD_DEPENDS= spamd:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
p5-Time-HiRes>0:${PORTSDIR}/devel/p5-Time-HiRes
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS = MODPERL "Enable Apache Support via mod_perl" On
+OPTIONS_DEFINE= MODPERL
+OPTIONS_DEFAULT=MODPERL
+MOD_PERL_DESC= "Apache Support via mod_perl"
-.ifdef WITH_MODPERL
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMODPERL}
USE_APACHE= 20+
RUN_DEPENDS+= ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2
.endif