aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-09-24 04:56:18 +0800
committerrene <rene@FreeBSD.org>2013-09-24 04:56:18 +0800
commit010dcd43f502281ec85cd36adf28ccd1d9325786 (patch)
treeba5c3d257031644e66b95880396dba7fabb32edd
parent83ed6a4af993650c49be1dc491c54ef915fe5351 (diff)
downloadfreebsd-ports-gnome-010dcd43f502281ec85cd36adf28ccd1d9325786.tar.gz
freebsd-ports-gnome-010dcd43f502281ec85cd36adf28ccd1d9325786.tar.zst
freebsd-ports-gnome-010dcd43f502281ec85cd36adf28ccd1d9325786.zip
- Add staging support
- Wrap some long lines
-rw-r--r--astro/boinc-setiathome-v7/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/astro/boinc-setiathome-v7/Makefile b/astro/boinc-setiathome-v7/Makefile
index a6476ed80b07..9e2461d37328 100644
--- a/astro/boinc-setiathome-v7/Makefile
+++ b/astro/boinc-setiathome-v7/Makefile
@@ -18,7 +18,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float
-NO_STAGE= yes
USES= gmake pkgconfig
USE_XZ= yes
USE_AUTOTOOLS= autoconf:env automake:env
@@ -97,18 +96,20 @@ pre-configure:
(cd ${WRKSRC} ; ./_autosetup)
do-install:
- ${INSTALL} -d -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} ${BOINC_CLIENT_HOME}/projects
${INSTALL} -d -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
- ${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
+ ${STAGEDIR}${BOINC_CLIENT_HOME}/projects
+ ${INSTALL} -d -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
+ ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
${INSTALL_PROGRAM} -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
- ${WRKSRC}/client/${SETI_BINARY} ${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
+ ${WRKSRC}/client/${SETI_BINARY} \
+ ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.if ${PORT_OPTIONS:MX11}
${INSTALL_PROGRAM} -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
- ${WRKSRC}/client/seti_graphics ${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
+ ${WRKSRC}/client/seti_graphics \
+ ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.endif
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>