aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2009-11-27 17:11:32 +0800
committerbeat <beat@FreeBSD.org>2009-11-27 17:11:32 +0800
commit01799001f1cdb6217ba45462645e79bf3c4030a9 (patch)
treeb65bd288589d8bbe5ed405c053cb731ce66fc361
parentfea2f3dc4c32c1d135a54691c2334301c42a0d53 (diff)
downloadfreebsd-ports-gnome-01799001f1cdb6217ba45462645e79bf3c4030a9.tar.gz
freebsd-ports-gnome-01799001f1cdb6217ba45462645e79bf3c4030a9.tar.zst
freebsd-ports-gnome-01799001f1cdb6217ba45462645e79bf3c4030a9.zip
- Remove obsolete gecko providers
- Remove obsolete inclusion of www/mozilla/bsd.gecko.mk Approved by: portmgr (miwi) Exp-run by: miwi
-rw-r--r--deskutils/chmsee/Makefile3
-rw-r--r--graphics/librsvg2/Makefile4
-rw-r--r--www/epiphany-extensions/Makefile3
-rw-r--r--www/epiphany/Makefile3
-rw-r--r--x11-toolkits/jdic/Makefile3
-rw-r--r--x11-toolkits/py-gnome-extras/Makefile3
6 files changed, 7 insertions, 12 deletions
diff --git a/deskutils/chmsee/Makefile b/deskutils/chmsee/Makefile
index 5b28390df018..0df88f12b38e 100644
--- a/deskutils/chmsee/Makefile
+++ b/deskutils/chmsee/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= chm.0:${PORTSDIR}/misc/chmlib \
gcrypt.16:${PORTSDIR}/security/libgcrypt
USE_GNOME= gnomehier libglade2
-USE_GECKO= libxul seamonkey xulrunner mozilla
+USE_GECKO= libxul seamonkey
USE_GETTEXT= yes
USE_CMAKE= yes
CMAKE_USE_PTHREAD= yes
@@ -26,7 +26,6 @@ CMAKE_ARGS= -DCMAKE_INSTALL_RPATH_USE_LINK_PATH:BOOL=TRUE
MAN1= chmsee.1
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if defined(GECKO) && ${GECKO:Mlibxul}!=""
GTKMOZEMBED_LIB="${GECKO}-embedding-unstable nspr"
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index 0ad4815eb244..e911912734ba 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -46,10 +46,10 @@ OPTIONS= MOZILLA_PLUGIN "Enable the SVG browser plug-in" on
.include <bsd.port.pre.mk>
.if defined(WITH_MOZILLA_PLUGIN)
-USE_GECKO= libxul firefox mozilla seamonkey xulrunner
+USE_GECKO= libxul seamonkey
USE_WEBPLUGINS= gecko*
WEBPLUGINS_FILES=libmozsvgdec.so
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
+.include "${PORTSDIR}/Mk/bsd.gecko.mk"
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
CONFIGURE_ENV+= MOZILLA_CONFIG=no
CONFIGURE_ARGS+=--enable-mozilla-plugin=yes
diff --git a/www/epiphany-extensions/Makefile b/www/epiphany-extensions/Makefile
index 4aae5f767e25..e1317f0d785d 100644
--- a/www/epiphany-extensions/Makefile
+++ b/www/epiphany-extensions/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
USE_GETTEXT= yes
USE_BZIP2= yes
-USE_GECKO= libxul firefox
+USE_GECKO= libxul
USE_GNOME= gnomeprefix gnomehack intlhack
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
@@ -42,7 +42,6 @@ PLIST_SUB= VERSION=2.26 EPHY_VERSION=2.26
OPTIONS= OPENSP "Enable OpenSP SGML support" off
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if defined(WITH_OPENSP)
CONFIGURE_ARGS+= --enable-opensp=yes
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index e4787ac5d80f..d97d89085e46 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -32,6 +32,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop desktopfileutils
WANT_GNOME= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_GECKO+= libxul
INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} ${EXTRA_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} ${EXTRA_LIBS}"
@@ -52,11 +53,9 @@ WITH_GNOME= yes
.include <bsd.port.pre.mk>
-USE_GECKO+= libxul firefox
CONFIGURE_ARGS+= --with-gecko=${GECKO} \
--with-engine=mozilla \
--with-gecko-home=${LOCALBASE}/lib/${GECKO}
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
CONFLICTS= epiphany-webkit-[1-9]*
PLIST_SUB+= GECKO=""
.if ${GECKO:Mlibxul}!=""
diff --git a/x11-toolkits/jdic/Makefile b/x11-toolkits/jdic/Makefile
index ee6e615d4d6c..db1b5b6a0601 100644
--- a/x11-toolkits/jdic/Makefile
+++ b/x11-toolkits/jdic/Makefile
@@ -32,7 +32,7 @@ JAVA_VERSION= 1.5+
USE_LDCONFIG= yes
# Do not build mozembed: it requires Gecko_SDK and XULRunner, which is
# broken ATM - see <http://developer.mozilla.org/en/docs/Gecko_SDK>.
-#USE_GECKO= firefox seamonkey mozilla
+#USE_GECKO= seamonkey libxul
#ALL_TARGET= buildall
ALL_TARGET= buildtray
@@ -70,5 +70,4 @@ regression-test: install
java -cp "${JAVAJARDIR}/jdic.jar:." Tray)
.endif
-#.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/py-gnome-extras/Makefile b/x11-toolkits/py-gnome-extras/Makefile
index f96076e6ced4..7e8bcd2b38b8 100644
--- a/x11-toolkits/py-gnome-extras/Makefile
+++ b/x11-toolkits/py-gnome-extras/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell \
gksuui1.0.1:${PORTSDIR}/sysutils/libgksuui \
gdl-1.0:${PORTSDIR}/x11-toolkits/gdl
-USE_GECKO= libxul firefox xulrunner mozilla
+USE_GECKO= libxul
USE_BZIP2= yes
USE_GMAKE= yes
USE_PYTHON= yes
@@ -43,7 +43,6 @@ DOCSDIR= ${WRKSRC}/share/doc/py-gnome-extras
.endif
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if defined(GECKO) && ${GECKO:Mlibxul}!=""
CONFIGURE_ARGS+= --with-gtkmozembed=mozilla