aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2009-09-11 02:44:27 +0800
committerdanfe <danfe@FreeBSD.org>2009-09-11 02:44:27 +0800
commit086927b2193c82af1848516d3bca8e52c15287a4 (patch)
treeb920664a9d85c8922ed204924cf0fe0a996cd225
parent9b9a792f0c0c0dc1e9912f9b4349647d64366898 (diff)
downloadfreebsd-ports-gnome-086927b2193c82af1848516d3bca8e52c15287a4.tar.gz
freebsd-ports-gnome-086927b2193c82af1848516d3bca8e52c15287a4.tar.zst
freebsd-ports-gnome-086927b2193c82af1848516d3bca8e52c15287a4.zip
- Allow to build with hidden layout boxes, lots of people should appreciate
- Adjust regexp slightly while here (avoid extra resulting space)
-rw-r--r--x11-wm/wmii/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11-wm/wmii/Makefile b/x11-wm/wmii/Makefile
index 2184ec5aa750..f90ec79840ef 100644
--- a/x11-wm/wmii/Makefile
+++ b/x11-wm/wmii/Makefile
@@ -30,6 +30,10 @@ MAKE_ARGS= PREFIX="${PREFIX}" INCLUDE="${LOCALBASE}/include" \
MAN1= wmii.1 wmiiloop.1 wmiir.1
+OPTIONS= LAYOUT_BOXES "Show layout boxes (some people hate them)" on
+
+.include <bsd.port.options.mk>
+
post-patch: .SILENT
${REINPLACE_CMD} -e 's|-lfmt -lutf|$${LIBX11} & -lX11|' \
${WRKSRC}/cmd/Makefile
@@ -38,7 +42,10 @@ post-patch: .SILENT
${REINPLACE_CMD} -e 's|CFLAGS += -DIXPlint|& -DIXP_NEEDAPI=89|' \
${WRKSRC}/config.mk
# Make actual compile/link commands appear in the build log
- ${REINPLACE_CMD} -e 's|^COMPILE=|& noisycc=yes | ; \
- s|^LINK=|& noisycc=yes |' ${WRKSRC}/mk/hdr.mk
+ ${REINPLACE_CMD} -e 's|^COMPILE=|& noisycc=yes| ; \
+ s|^LINK=|& noisycc=yes|' ${WRKSRC}/mk/hdr.mk
+.if defined(WITHOUT_LAYOUT_BOXES)
+ ${REINPLACE_CMD} -e '102,104d' ${WRKSRC}/cmd/wmii/column.c
+.endif
.include <bsd.port.mk>