aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2014-01-22 04:02:18 +0800
committerrm <rm@FreeBSD.org>2014-01-22 04:02:18 +0800
commit0930f05f6fb0a3ec836dcc8052b092c8efb45400 (patch)
treee2095bba2155312eac9a80cb97c0f8fc673452d4
parent7b4e3436871e38180e306eedfa64f3b5ae51ac75 (diff)
downloadfreebsd-ports-gnome-0930f05f6fb0a3ec836dcc8052b092c8efb45400.tar.gz
freebsd-ports-gnome-0930f05f6fb0a3ec836dcc8052b092c8efb45400.tar.zst
freebsd-ports-gnome-0930f05f6fb0a3ec836dcc8052b092c8efb45400.zip
This is a Django authentication backend that authenticates against an LDAP
service. Configuration can be as simple as a single distinguished name template, but there are many rich configuration options for working with users, groups, and permissions. WWW: http://pythonhosted.org/django-auth-ldap/ PR: 185959 Submitted by: Alexander Kriventsov <avk@vl.ru>
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-auth-ldap/Makefile22
-rw-r--r--www/py-django-auth-ldap/distinfo2
-rw-r--r--www/py-django-auth-ldap/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 17b3ec538e71..42fd59aab204 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1496,6 +1496,7 @@
SUBDIR += py-django-app-plugins
SUBDIR += py-django-appconf
SUBDIR += py-django-appmedia
+ SUBDIR += py-django-auth-ldap
SUBDIR += py-django-caching-app-plugins
SUBDIR += py-django-classy-tags
SUBDIR += py-django-cms
diff --git a/www/py-django-auth-ldap/Makefile b/www/py-django-auth-ldap/Makefile
new file mode 100644
index 000000000000..d2310ce9bfbc
--- /dev/null
+++ b/www/py-django-auth-ldap/Makefile
@@ -0,0 +1,22 @@
+# Created by: Alexander Kriventsov <avk@vl.ru>
+# $FreeBSD$
+
+PORTNAME= django-auth-ldap
+PORTVERSION= 1.1.7
+CATEGORIES= www security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= avk@vl.ru
+COMMENT= LDAP integration for django.contrib.auth
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.3.1:${PORTSDIR}/www/py-django \
+ ${PYTHON_PKGNAMEPREFIX}ldap2>=2.0:${PORTSDIR}/net/py-ldap2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-auth-ldap/distinfo b/www/py-django-auth-ldap/distinfo
new file mode 100644
index 000000000000..9886daa84839
--- /dev/null
+++ b/www/py-django-auth-ldap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-auth-ldap-1.1.7.tar.gz) = d4817ce758be27cbc687d83958d0109cdb2b7dbc696da661bd66c9975cb14b61
+SIZE (django-auth-ldap-1.1.7.tar.gz) = 127186
diff --git a/www/py-django-auth-ldap/pkg-descr b/www/py-django-auth-ldap/pkg-descr
new file mode 100644
index 000000000000..10c47b9129f9
--- /dev/null
+++ b/www/py-django-auth-ldap/pkg-descr
@@ -0,0 +1,6 @@
+This is a Django authentication backend that authenticates against an LDAP
+service. Configuration can be as simple as a single distinguished name template,
+but there are many rich configuration options for working with users, groups,
+and permissions.
+
+WWW: http://pythonhosted.org/django-auth-ldap/