aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
committeraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
commit0a9e5efb9de6b8811964b263c03b83ec89719f71 (patch)
treeaf6266e338105f6caa968f90afd0c4e98288d6f5
parent161ee4e405ddee7d6c945754c827684829ef8e90 (diff)
downloadfreebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.gz
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.zst
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
-rw-r--r--audio/mp32ogg/Makefile11
-rw-r--r--audio/p5-Shout/Makefile8
-rw-r--r--databases/p5-DBD-InterBase/Makefile10
-rw-r--r--databases/p5-DBIx-Class-TimeStamp/Makefile8
-rw-r--r--databases/p5-DBIx-MySQLSequence/Makefile8
-rw-r--r--devel/cvslines/Makefile11
-rw-r--r--devel/cvslines/pkg-descr2
-rw-r--r--devel/cvsplot/Makefile12
-rw-r--r--devel/cvsstat/Makefile8
-rw-r--r--devel/cvsweb/Makefile18
-rw-r--r--devel/cvsweb/pkg-descr2
-rw-r--r--devel/cvsweb3/Makefile18
-rw-r--r--devel/cvsweb3/pkg-descr2
-rw-r--r--devel/hypersrc/Makefile13
-rw-r--r--devel/p4db/Makefile11
-rw-r--r--devel/p5-Class-C3-Componentised/Makefile8
-rw-r--r--devel/p5-Class-Contract/Makefile11
-rw-r--r--devel/p5-Class-Default/Makefile9
-rw-r--r--devel/p5-Config-JFDI/Makefile3
-rw-r--r--devel/p5-Devel-Diagram/Makefile10
-rw-r--r--devel/p5-Devel-Timer/Makefile9
-rw-r--r--devel/p5-Inline-Tcl/Makefile8
-rw-r--r--devel/p5-MooseX-AttributeHelpers/Makefile8
-rw-r--r--devel/p5-MooseX-SimpleConfig/Makefile9
-rw-r--r--devel/p5-Return-Value/Makefile2
-rw-r--r--ftp/p5-POE-Component-Client-FTP/Makefile10
-rw-r--r--games/atr3d/Makefile11
-rw-r--r--games/atr3d/pkg-descr1
-rw-r--r--games/falconseye/Makefile2
-rw-r--r--games/gracer/Makefile8
-rw-r--r--graphics/p5-SWF-Builder/Makefile11
-rw-r--r--graphics/p5-SWF-File/Makefile11
-rw-r--r--mail/tlb/Makefile2
-rw-r--r--math/p5-Math-Bezier-Convert/Makefile10
-rw-r--r--misc/quotes/Makefile9
-rw-r--r--net-p2p/mldonkey-perlreactor/Makefile12
-rw-r--r--net-p2p/mldonkey-urlslave/Makefile11
-rw-r--r--textproc/p5-Pod-Stripper/Makefile10
38 files changed, 92 insertions, 235 deletions
diff --git a/audio/mp32ogg/Makefile b/audio/mp32ogg/Makefile
index 14b75a822c18..43a027fbfbf1 100644
--- a/audio/mp32ogg/Makefile
+++ b/audio/mp32ogg/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: mp32ogg
-# Date created: Nov 4, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= mp32ogg
PORTVERSION= 0.11
@@ -24,6 +19,8 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123 \
p5-String-ShellQuote>=0:${PORTSDIR}/textproc/p5-String-ShellQuote
USE_PERL5= yes
+USES= shebangfix
+SHEBANG_FILES= mp32ogg
NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= #
@@ -32,7 +29,7 @@ NO_BUILD= yes
PLIST_FILES= bin/mp32ogg
post-patch:
- @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/mp32ogg
+ @${REINPLACE_CMD} -i '' -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/mp32ogg
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/mp32ogg ${PREFIX}/bin
diff --git a/audio/p5-Shout/Makefile b/audio/p5-Shout/Makefile
index bea8ece05f70..09e9c61da460 100644
--- a/audio/p5-Shout/Makefile
+++ b/audio/p5-Shout/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Shout
-# Date created: 18 April 2001
-# Whom: leo
-#
+# Created by: leo
# $FreeBSD$
-#
PORTNAME= Shout
PORTVERSION= 2.1
@@ -23,7 +19,7 @@ MAN3= Shout.3
DOCSDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
post-patch:
- @${PERL} -i -pe 's/CCFLAGS/INC/;' ${WRKSRC}/Makefile.PL
+ ${REINPLACE_CMD} -i '' -e 's/CCFLAGS/INC/' ${WRKSRC}/Makefile.PL
post-configure:
@${PERL} -i -pe '$$_ .= " ${PTHREAD_LIBS}" if /^LDDLFLAGS/;' ${WRKSRC}/Makefile
diff --git a/databases/p5-DBD-InterBase/Makefile b/databases/p5-DBD-InterBase/Makefile
index d9defc6c670c..bf8ed56cad98 100644
--- a/databases/p5-DBD-InterBase/Makefile
+++ b/databases/p5-DBD-InterBase/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DBD::InterBase
-# Date created: 15 Oct 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= DBD-InterBase
PORTVERSION= 0.48
@@ -22,8 +18,8 @@ PERL_CONFIGURE= yes
USE_FIREBIRD= yes
post-patch:
- @${PERL} -pi -e 's,%%IB_BASE%%,${LOCALBASE},g' \
- ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e 's|%%IB_BASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/Makefile.PL
MAN3= DBD::InterBase.3
diff --git a/databases/p5-DBIx-Class-TimeStamp/Makefile b/databases/p5-DBIx-Class-TimeStamp/Makefile
index 1cbafe9e5b5c..5df2def9b180 100644
--- a/databases/p5-DBIx-Class-TimeStamp/Makefile
+++ b/databases/p5-DBIx-Class-TimeStamp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-DBIx-Class-TimeStamp
-# Date created: 28 April 2009
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBIx-Class-TimeStamp
PORTVERSION= 0.14
@@ -30,6 +26,6 @@ PERL_CONFIGURE= yes
MAN3= DBIx::Class::TimeStamp.3
post-patch:
- ${PERL} -pi -e '$$_="" if /auto_install/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/auto_install/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-MySQLSequence/Makefile b/databases/p5-DBIx-MySQLSequence/Makefile
index 856ebe5144a6..e9e4557ef3d8 100644
--- a/databases/p5-DBIx-MySQLSequence/Makefile
+++ b/databases/p5-DBIx-MySQLSequence/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-DBIx-MySQLSequence
-# Date created: 18 March 2006
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBIx-MySQLSequence
PORTVERSION= 1.04
@@ -27,6 +23,6 @@ PERL_CONFIGURE= yes
MAN3= DBIx::MySQLSequence.3
post-patch:
- @${PERL} -pi -e '$$_="" if m/Test::More/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/Test::More/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/cvslines/Makefile b/devel/cvslines/Makefile
index b3c54a1b8941..62efd26f7461 100644
--- a/devel/cvslines/Makefile
+++ b/devel/cvslines/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvslines
-# Date created: 24 Aug 1998
-# Whom: jkoshy
-#
+# Created by: jkoshy
# $FreeBSD$
-#
PORTNAME= cvslines
PORTVERSION= 1.6.9
@@ -16,6 +12,8 @@ COMMENT= Wrapper to ease merging of changes between CVS branches
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_PERL5= yes
NO_BUILD= yes
+USES= shebangfix
+SHEBANG_FILES= cvslines
.for ii in s s_check s-check s-commit s-config s-status
PLIST_FILES+= bin/cvsline${ii}
.endfor
@@ -23,8 +21,7 @@ PLIST_FILES+= bin/cvsline${ii}
MAN1= cvslines.1
pre-patch:
- ${PERL} -pi -e "s:usr/bin/perl5:${PERL5}:g" ${WRKSRC}/cvslines
- ${PERL} -pi -e "s:the the:the:g" ${WRKSRC}/cvslines.1
+ @${REINPLACE_CMD} -i '' -e 's|the the|the|' ${WRKSRC}/cvslines.1
do-install:
PREFIX=${PREFIX} ${PERL5} ${WRKSRC}/INSTALL ${WRKSRC}/CONFIG
diff --git a/devel/cvslines/pkg-descr b/devel/cvslines/pkg-descr
index 1a202f23bfe7..177ea2cba698 100644
--- a/devel/cvslines/pkg-descr
+++ b/devel/cvslines/pkg-descr
@@ -5,4 +5,4 @@ cvslines is a "wrapper" facility that helps out with merging changes
between various cvs branches, where the branches represent different
lines of development.
-WWW: http://cvslines.sourceforge.net/menu.html
+WWW: http://cvslines.sourceforge.net/menu.html
diff --git a/devel/cvsplot/Makefile b/devel/cvsplot/Makefile
index d058cc181437..1f1485f606c8 100644
--- a/devel/cvsplot/Makefile
+++ b/devel/cvsplot/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: cvsplot
-# Date created: May 31, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= cvsplot
PORTVERSION= 1.7.4
@@ -22,9 +17,8 @@ RUN_DEPENDS= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
USE_PERL5= yes
NO_BUILD= yes
PLIST_FILES= bin/cvsplot
-
-post-patch:
- @${PERL} -pi -e "s,^#!/usr/bin/perl -w,#!/usr/bin/env perl -w,g" ${WRKSRC}/cvsplot.pl
+USES= shebangfix
+SHEBANG_FILES= cvsplot.pl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cvsplot.pl ${PREFIX}/bin/cvsplot
diff --git a/devel/cvsstat/Makefile b/devel/cvsstat/Makefile
index 145dee687cae..657d1ba0e692 100644
--- a/devel/cvsstat/Makefile
+++ b/devel/cvsstat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvsstat
-# Date created: 27 August 2001
-# Whom: petef
-#
+# Created by: petef
# $FreeBSD$
-#
PORTNAME= cvsstat
PORTVERSION= 2.24
@@ -26,7 +22,7 @@ do-extract:
@${CP} -p ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}
post-patch:
- @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/cvsstat
+ @${REINPLACE_CMD} -i '' -e 's|perl -S|${PERL} -S|' ${WRKSRC}/cvsstat
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cvsstat ${PREFIX}/bin
diff --git a/devel/cvsweb/Makefile b/devel/cvsweb/Makefile
index 0fd25a760e19..7d567623576d 100644
--- a/devel/cvsweb/Makefile
+++ b/devel/cvsweb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvsweb
-# Date created: 27 Jun 1999
-# Whom: SADA Kenji <sada@FreeBSD.org>
-#
+# Created by: SADA Kenji <sada@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cvsweb
PORTVERSION= 2.0.6
@@ -55,14 +51,12 @@ SUB_FILES= pkg-message
SUB_LIST= PREFIX="${PREFIX}" DOCSDIR="${DOCSDIR}"
post-patch:
- ${PERL} -i -pe "\
- s'!!PERL!!'${PERL}'g; \
- s'!!PREFIX!!'${PREFIX}'g;" \
+ @${REINPLACE_CMD} -i '' -e 's,!!PERL!!,${PERL},' \
+ -e 's,!!PREFIX!!,${PREFIX},' \
${WRKSRC}/cvsweb.cgi
- ${PERL} -i -pe "\
- s'!!PREFIX!!'${PREFIX}'g; \
- s'!!CVSROOT!!'${CVSROOT}'g; \
- s'!!TITLE!!'${TITLE}'g;" \
+ @${REINPLACE_CMD} -i '' -e 's,!!PREFIX!!,${PREFIX},' \
+ -e 's,!!CVSROOT!!,${CVSROOT},' \
+ -e 's,!!TITLE!!,${TITLE},' \
${WRKSRC}/cvsweb.conf
do-install:
diff --git a/devel/cvsweb/pkg-descr b/devel/cvsweb/pkg-descr
index e529dbba570c..22ac5a46e92b 100644
--- a/devel/cvsweb/pkg-descr
+++ b/devel/cvsweb/pkg-descr
@@ -11,4 +11,4 @@ brought it back to the FreeBSD community and made further
improvements.
Author: The FreeBSD Project <freebsd-cvsweb at FreeBSD dot org>
-WWW: http://www.FreeBSD.org/projects/cvsweb.html
+WWW: http://www.FreeBSD.org/projects/cvsweb.html
diff --git a/devel/cvsweb3/Makefile b/devel/cvsweb3/Makefile
index 41f1bd03770b..69e64068294b 100644
--- a/devel/cvsweb3/Makefile
+++ b/devel/cvsweb3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvsweb
-# Date created: 27 Jun 1999
-# Whom: SADA Kenji <sada@FreeBSD.org>
-#
+# Created by: SADA Kenji <sada@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cvsweb
PORTVERSION= 3.0.6
@@ -79,14 +75,12 @@ SUB_FILES= pkg-message
SUB_LIST= PREFIX="${PREFIX}" DOCSDIR="${DOCSDIR}"
post-patch:
- ${PERL} -i -pe "\
- s'!!PERL!!'${PERL}'g; \
- s'!!PREFIX!!'${PREFIX}'g;" \
+ @${REINPLACE_CMD} -i '' -e 's,!!PERL!!,${PERL},' \
+ -e 's,!!PREFIX!!,${PREFIX},' \
${WRKSRC}/cvsweb.cgi
- ${PERL} -i -pe "\
- s'!!PREFIX!!'${PREFIX}'g; \
- s'!!CVSROOT!!'${CVSROOT}'g; \
- s'!!TITLE!!'${TITLE}'g;" \
+ @${REINPLACE_CMD} -i '' -e 's,!!PREFIX!!,${PREFIX},' \
+ -e 's,!!CVSROOT!!,${CVSROOT},' \
+ -e 's,!!TITLE!!,${TITLE},' \
${WRKSRC}/cvsweb.conf
do-install:
diff --git a/devel/cvsweb3/pkg-descr b/devel/cvsweb3/pkg-descr
index 8eb3cce32ffc..37e0c506eead 100644
--- a/devel/cvsweb3/pkg-descr
+++ b/devel/cvsweb3/pkg-descr
@@ -11,4 +11,4 @@ brought it back to the FreeBSD community and made further
improvements. FreeBSD-CVSweb is currently maintained by Ville Skytta.
Author: The FreeBSD Project <freebsd-cvsweb at FreeBSD dot org>
-WWW: http://www.FreeBSD.org/projects/cvsweb.html
+WWW: http://www.FreeBSD.org/projects/cvsweb.html
diff --git a/devel/hypersrc/Makefile b/devel/hypersrc/Makefile
index 1dc15c799b2b..6719acc21f14 100644
--- a/devel/hypersrc/Makefile
+++ b/devel/hypersrc/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: hypersrc
-# Date created: Apr 9, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= hypersrc
PORTVERSION= 5.4.21
@@ -26,13 +21,15 @@ USE_GNOME= gnomelibs
USE_GMAKE= yes
MAKEFILE= GNUmakefile
MAKE_ARGS= CC="${CC}" C_OPTIMIZE="${CFLAGS}"
+USES= shebangfix
+SHEBANG_FILES= Hypersrc.pl
MAN1= hypersrc.1
PLIST_FILES= bin/hypersrc bin/Hypersrc.pl bin/ctags.pl
post-patch:
- @${PERL} -pi -e 's|"ctags"|"${LOCALBASE}/bin/exctags"|g ; \
- s|"ctags.pl"|"${PREFIX}/bin/ctags.pl"|g' ${WRKSRC}/Hypersrc.pl
+ @${REINPLACE_CMD} -i '' -e 's|"ctags"|"${LOCALBASE}/bin/exctags"|' \
+ -e 's|"ctags.pl"|"${PREFIX}/bin/ctags.pl"|' ${WRKSRC}/Hypersrc.pl
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/out/hypersrc ${PREFIX}/bin
diff --git a/devel/p4db/Makefile b/devel/p4db/Makefile
index c9c3bf620e82..0625606b7025 100644
--- a/devel/p4db/Makefile
+++ b/devel/p4db/Makefile
@@ -45,12 +45,11 @@ post-extract:
done
post-patch:
- ${PERL} -pi \
- -e 's,!!PREFIX!!,${PREFIX},g;' \
- -e 's,!!PERFORCE_USER!!,p4admin,g;' \
- -e 's,!!PERFORCE_GROUP!!,p4admin,g;' \
- -e 's,!!PERFORCE_PORT!!,${PERFORCE_PORT},g;' \
- -e 's,!!FQDN!!,${FQDN},g;' \
+ @${REINPLACE_CMD} -i '' -e 's,!!PREFIX!!,${PREFIX},' \
+ -e 's,!!PERFORCE_USER!!,p4admin,' \
+ -e 's,!!PERFORCE_GROUP!!,p4admin,' \
+ -e 's,!!PERFORCE_PORT!!,${PERFORCE_PORT},' \
+ -e 's,!!FQDN!!,${FQDN},' \
${WRKSRC}/${PORTNAME}/P4DB.conf.sample
${FIND} ${WRKSRC}/${PORTNAME} -name '*.orig' -delete
diff --git a/devel/p5-Class-C3-Componentised/Makefile b/devel/p5-Class-C3-Componentised/Makefile
index d24daa3fa51a..8bec9e7a4fb9 100644
--- a/devel/p5-Class-C3-Componentised/Makefile
+++ b/devel/p5-Class-C3-Componentised/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-C3-Componentised
-# Date created: 2007-08-13
-# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
-#
+# Created by: Lars Balker Rasmussen <lbr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Class-C3-Componentised
PORTVERSION= 1.0009
@@ -31,6 +27,6 @@ PERL_CONFIGURE= yes
MAN3= Class::C3::Componentised.3
post-extract:
- @${PERL} -i.bak -ne 'print unless m,Test::,' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e '/Test::/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-Class-Contract/Makefile b/devel/p5-Class-Contract/Makefile
index 0e1d682bf757..2c435cdf69c4 100644
--- a/devel/p5-Class-Contract/Makefile
+++ b/devel/p5-Class-Contract/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class::Contract
-# Date created: 5 Nov 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Class-Contract
PORTVERSION= 1.14
@@ -15,14 +11,11 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Design-by-Contract OO in Perl
PERL_CONFIGURE= yes
+USE_DOS2UNIX= yes
PLIST_SUB+= EXAMPLESDIR="share/examples/${PORTNAME}"
MAN3= Class::Contract.3 Class::Contract::Production.3
-post-patch:
- @${FIND} ${WRKSRC} -type f -name "*.p[lm]" | \
- ${XARGS} ${PERL} -pi -e 's/\x0d//g;'
-
pre-configure:
${MKDIR} ${WRKSRC}/examples
${MV} ${WRKSRC}/demo.pl ${WRKSRC}/examples
diff --git a/devel/p5-Class-Default/Makefile b/devel/p5-Class-Default/Makefile
index 239a021e72c7..710ae7e26f5f 100644
--- a/devel/p5-Class-Default/Makefile
+++ b/devel/p5-Class-Default/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class-Default
-# Date created: 10 December 2002
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Class-Default
PORTVERSION= 1.51
@@ -21,7 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Class::Default.3
-post-patch:
- @${PERL} -pi -e 's/^auto_install.*$$//' ${WRKSRC}/Makefile.PL
-
.include <bsd.port.mk>
diff --git a/devel/p5-Config-JFDI/Makefile b/devel/p5-Config-JFDI/Makefile
index 44b4491d1b62..372bb3da71a4 100644
--- a/devel/p5-Config-JFDI/Makefile
+++ b/devel/p5-Config-JFDI/Makefile
@@ -30,7 +30,6 @@ PERL_CONFIGURE= yes
MAN3= Config::JFDI.3
post-extract:
- @${PERL} -i -ne 'print unless /\.swp$$/' ${WRKSRC}/MANIFEST
- @${PERL} -i.bak -ne 'print unless m,^Test::,' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/Test::/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-Devel-Diagram/Makefile b/devel/p5-Devel-Diagram/Makefile
index fcc1022f69f3..54c9e55e4043 100644
--- a/devel/p5-Devel-Diagram/Makefile
+++ b/devel/p5-Devel-Diagram/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Devel-Diagram
-# Date created: 25 January 2004
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Devel-Diagram
PORTVERSION= 1.00
@@ -15,12 +11,10 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Discover the classes of an arbitrary suite of Perl modules
PERL_CONFIGURE= yes
+USE_DOS2UNIX= yes
MAN3= Devel::Diagram.3 Devel::Diagram::Render::UXF20.3
-post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//'
-
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
diff --git a/devel/p5-Devel-Timer/Makefile b/devel/p5-Devel-Timer/Makefile
index 81b54720a92e..c56857f17a2f 100644
--- a/devel/p5-Devel-Timer/Makefile
+++ b/devel/p5-Devel-Timer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Devel-Timer
-# Date created: 2006-12-11
-# Whom: Cory R. King <coryking@mozimediacom>
-#
+# Created by: Cory R. King <coryking@mozimediacom>
# $FreeBSD$
-#
PORTNAME= Devel-Timer
PORTVERSION= 0.04
@@ -19,7 +15,4 @@ PERL_CONFIGURE= yes
MAN3= Devel::Timer.3
-post-extract:
- @${PERL} -pi -e '$$_ = undef if /''OPTIMIZE''/' ${WRKSRC}/Makefile.PL
-
.include <bsd.port.mk>
diff --git a/devel/p5-Inline-Tcl/Makefile b/devel/p5-Inline-Tcl/Makefile
index e061767b05ac..73762935b78f 100644
--- a/devel/p5-Inline-Tcl/Makefile
+++ b/devel/p5-Inline-Tcl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Inline::Tcl
-# Date created: 14 Dec 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Inline-Tcl
PORTVERSION= 0.09
@@ -25,6 +21,6 @@ CONFIGURE_ARGS= INC="-I${PREFIX}/include/tcl8.4" \
MAN3= Inline::Tcl.3
post-patch:
- @${PERL} -pi -e '$$_="" if $$.>1 && $$.<100' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i.bak '2,99d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-AttributeHelpers/Makefile b/devel/p5-MooseX-AttributeHelpers/Makefile
index cf2d464597f7..8e541599e692 100644
--- a/devel/p5-MooseX-AttributeHelpers/Makefile
+++ b/devel/p5-MooseX-AttributeHelpers/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-MooseX-AttributeHelpers
-# Date created: 27 Jul 2008
-# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
-#
+# Created by: Lars Balker Rasmussen <lbr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= MooseX-AttributeHelpers
PORTVERSION= 0.23
@@ -53,6 +49,6 @@ MAN3= MooseX::AttributeHelpers.3 \
MooseX::AttributeHelpers::Trait::String.3
post-extract:
- @${PERL} -i -ne 'print unless m,build_requires,' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/build_requires/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-SimpleConfig/Makefile b/devel/p5-MooseX-SimpleConfig/Makefile
index 371096858b1c..3c0a30c038ff 100644
--- a/devel/p5-MooseX-SimpleConfig/Makefile
+++ b/devel/p5-MooseX-SimpleConfig/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/MooseX-SimpleConfig
-# Date created: 25 February 2009
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= MooseX-SimpleConfig
PORTVERSION= 0.09
@@ -24,6 +20,7 @@ PERL_CONFIGURE= yes
MAN3= MooseX::SimpleConfig.3
post-patch:
- @${PERL} -pi -e '$$_="" if m/Test::More|auto_install/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -e '/auto_install/d' -e '/Test::More/d' \
+ ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-Return-Value/Makefile b/devel/p5-Return-Value/Makefile
index fd5d618efc45..8d6d82afaf63 100644
--- a/devel/p5-Return-Value/Makefile
+++ b/devel/p5-Return-Value/Makefile
@@ -17,6 +17,6 @@ PERL_CONFIGURE= yes
MAN3= Return::Value.3
post-patch:
- ${PERL} -pi -e 's/^Carp::cluck/# Carp::cluck/' ${WRKSRC}/lib/Return/Value.pm
+ @${REINPLACE_CMD} -i '' -e 's/^Carp::cluck/# Carp::cluck/' ${WRKSRC}/lib/Return/Value.pm
.include <bsd.port.mk>
diff --git a/ftp/p5-POE-Component-Client-FTP/Makefile b/ftp/p5-POE-Component-Client-FTP/Makefile
index 96f7ee38b9ef..2e1366a3d87e 100644
--- a/ftp/p5-POE-Component-Client-FTP/Makefile
+++ b/ftp/p5-POE-Component-Client-FTP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: POE-Component-Client-FTP
-# Date created: 17 March 2002
-# Whom: Sergey Skvortsov <skv@FreeBSD.org>
-#
+# Created by: Sergey Skvortsov <skv@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= POE-Component-Client-FTP
PORTVERSION= 0.22
@@ -22,10 +18,6 @@ CONFIGURE_ENV= PERL_MM_USE_DEFAULT=yes
MAN3= POE::Component::Client::FTP.3
-post-patch:
- @${PERL} -pi -e '$$_="" if /^use warnings/; s/\x0d(?=\x0a)//;' \
- ${WRKSRC}/FTP.pm
-
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 6108746c59da..11faaedae2eb 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: atr3d
-# Date created: 11 Jun 2003
-# Whom: Kirill Ponomarew <ponomarew@oberon.net>
-#
+# Created by: Kirill Ponomarew <ponomarew@oberon.net>
# $FreeBSD$
-#
PORTNAME= atr3d
PORTVERSION= 0.6
@@ -44,8 +40,9 @@ CONFIGURE_ARGS+= --disable-sound
.endif
pre-patch:
- @${PERL} -pi.orig -e 's|^aclocal|${ACLOCAL}|; \
- s|^autoconf|${AUTOCONF}|; s|^automake|${AUTOMAKE}|' \
+ @${REINPLACE_CMD} -i '' -e 's|^aclocal|${ACLOCAL}|' \
+ -e 's|^autoconf|${AUTOCONF}|' \
+ -e 's|^automake|${AUTOMAKE}|' \
${WRKSRC}/autogen.sh
@${REINPLACE_CMD} -e 's|-lopenal|& -lalut|' ${WRKSRC}/Makefile.am
diff --git a/games/atr3d/pkg-descr b/games/atr3d/pkg-descr
index f4b808ab263c..40f80d44b743 100644
--- a/games/atr3d/pkg-descr
+++ b/games/atr3d/pkg-descr
@@ -2,4 +2,3 @@ Avoid The Roid 3D is a 3D asteroids-like multiplayer game. The
player flies around in a three dimensional space, shooting
asteroids and other ships while trying to avoid running into
any of them or being shot.
-
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index 4a7121d77140..f188719000b5 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -26,7 +26,7 @@ NO_WRKSUBDIR= yes
MAKE_JOBS_UNSAFE= yes
post-patch:
- @${PERL} -pi -e "s@<malloc.h>@<stdlib.h>@g" \
+ @${REINPLACE_CMD} -i '' -e "s|<malloc.h>|<stdlib.h>|" \
${WRKSRC}/include/jtp_gen.h ${WRKSRC}/win/jtp/jtp_dirx.c \
${WRKSRC}/win/jtp/jtp_keys.c ${WRKSRC}/win/jtp/jtp_sdl.c \
${WRKSRC}/win/Qt/qt_win.cpp
diff --git a/games/gracer/Makefile b/games/gracer/Makefile
index 903f87fb7c09..e0e190b8f8a7 100644
--- a/games/gracer/Makefile
+++ b/games/gracer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gracer
-# Date created: Fri Jul 30 20:50:16 MET DST 1999
-# Whom: nox@jelal.kn-bremen.de
-#
+# Created by: nox@jelal.kn-bremen.de
# $FreeBSD$
-#
PORTNAME= gracer
PORTVERSION= 0.1.5
@@ -36,7 +32,7 @@ MAN6= gracer.6
.include <bsd.port.pre.mk>
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -i '' -e 's|<malloc.h>|<stdlib.h>|' \
${WRKSRC}/common/gr_memory.h
.include <bsd.port.post.mk>
diff --git a/graphics/p5-SWF-Builder/Makefile b/graphics/p5-SWF-Builder/Makefile
index 076da5651bc6..24e2222a0028 100644
--- a/graphics/p5-SWF-Builder/Makefile
+++ b/graphics/p5-SWF-Builder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SWF-Builder
-# Date created: 25 December 2003
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= SWF-Builder
PORTVERSION= 0.16
@@ -20,6 +16,7 @@ BUILD_DEPENDS= p5-SWF-File>=0:${PORTSDIR}/graphics/p5-SWF-File \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+USE_DOS2UNIX= yes
MAN3= SWF::Builder.3 SWF::Builder::ActionScript.3 \
SWF::Builder::Character::Bitmap.3 \
@@ -31,10 +28,6 @@ MAN3= SWF::Builder.3 SWF::Builder::ActionScript.3 \
SWF::Builder::Character::Text.3 SWF::Builder::Gradient.3
MAN1= asc.plx.1
-post-patch:
- @${FIND} ${WRKSRC} -type f |\
- ${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//'
-
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
diff --git a/graphics/p5-SWF-File/Makefile b/graphics/p5-SWF-File/Makefile
index 6768113f1c39..68ca8bd49c3d 100644
--- a/graphics/p5-SWF-File/Makefile
+++ b/graphics/p5-SWF-File/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SWF-File
-# Date created: 20 May 2003
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= SWF-File
PORTVERSION= 0.42
@@ -20,15 +16,12 @@ RUN_DEPENDS= p5-Data-TemporaryBag>=0:${PORTSDIR}/devel/p5-Data-TemporaryBag
BUILD_DEPENDS= p5-Data-TemporaryBag>=0:${PORTSDIR}/devel/p5-Data-TemporaryBag
PERL_CONFIGURE= yes
+USE_DOS2UNIX= yes
MAN3= SWF::BinStream.3 SWF::BinStream::Codec.3 \
SWF::BinStream::Codec::Zlib.3 SWF::BinStream::File.3 \
SWF::Element.3 SWF::File.3 SWF::Parser.3
-post-patch:
- @${FIND} ${WRKSRC} -type f |\
- ${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//'
-
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
diff --git a/mail/tlb/Makefile b/mail/tlb/Makefile
index 29b34feb2f4b..55707c2d0d4c 100644
--- a/mail/tlb/Makefile
+++ b/mail/tlb/Makefile
@@ -29,7 +29,7 @@ perl_OLD_CMD= /usr/local/bin/perl5
pre-patch:
.for f in ${FIXPREFIX}
- @${PERL} -pi -e "s@/usr/lib/sendmail@/usr/sbin/sendmail@g" ${WRKSRC}/${f}
+ @${REINPLACE_CMD} -i '' -e 's@/usr/lib/sendmail@/usr/sbin/sendmail@' ${WRKSRC}/${f}
.endfor
do-install:
diff --git a/math/p5-Math-Bezier-Convert/Makefile b/math/p5-Math-Bezier-Convert/Makefile
index b52ab033ddcd..736cf5f7b361 100644
--- a/math/p5-Math-Bezier-Convert/Makefile
+++ b/math/p5-Math-Bezier-Convert/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Math-Bezier-Convert
-# Date created: 07 February 2005
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Math-Bezier-Convert
PORTVERSION= 0.02
@@ -15,12 +11,10 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Convert cubic and quadratic Bezier each other
PERL_CONFIGURE= yes
+USE_DOS2UNIX= yes
MAN3= Math::Bezier::Convert.3
-post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//'
-
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
diff --git a/misc/quotes/Makefile b/misc/quotes/Makefile
index fac82ec18f4e..631185563f5a 100644
--- a/misc/quotes/Makefile
+++ b/misc/quotes/Makefile
@@ -14,15 +14,14 @@ COMMENT= Quote, currency, and Slashdot headline fetcher based on Perl
NO_BUILD= yes
USE_PERL5= yes
+USES= shebangfix
+SHEBANG_FILES= quotes quotesmailer QuExample.pm
.include <bsd.port.options.mk>
post-patch:
- @ ${PERL} -pi -e "s:/usr/bin/perl:${PERL}:g" ${WRKSRC}/quotes
- @ ${PERL} -pi -e "s:/usr/local/lib/Quotes:${PREFIX}/etc:g" ${WRKSRC}/quotes
- @ ${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/quotes
- @ ${PERL} -pi -e "s:/usr/bin/perl:${PERL}:g" ${WRKSRC}/quotesmailer
- @ ${PERL} -pi -e "s:/usr/bin/perl:${PERL}:g" ${WRKSRC}/QuExample.pm
+ @${REINPLACE_CMD} -i '' -e "s:/usr/local/lib/Quotes:${PREFIX}/etc:" \
+ -e "s:/usr/local:${PREFIX}:" ${WRKSRC}/quotes
do-install:
@ ${INSTALL_SCRIPT} ${WRKSRC}/quotes ${PREFIX}/bin
diff --git a/net-p2p/mldonkey-perlreactor/Makefile b/net-p2p/mldonkey-perlreactor/Makefile
index baca0990d0b1..14becbaaf4c0 100644
--- a/net-p2p/mldonkey-perlreactor/Makefile
+++ b/net-p2p/mldonkey-perlreactor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mldonkey perlreactor
-# Date created: Sat Feb 23 13:13:08 BRT 2002
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mldonkey
PORTVERSION= 0.2
@@ -20,13 +16,13 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
USE_PERL5= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
+USES= shebangfix
+SHEBANG_FILES$=${BINARY_NAME}
BINARY_NAME= perlreactor
post-patch:
- @${PERL} -pi -e 's|#!/usr/bin/perl\n||; \
- s|/usr/local/bin/perl|${PERL}|' \
- ${WRKSRC}/${BINARY_NAME}
+ @${REINPLACE_CMD} -i '' -e '1d' ${WRKSRC}/${BINARY_NAME}
do-install:
.ifndef(NOPORTDOCS)
diff --git a/net-p2p/mldonkey-urlslave/Makefile b/net-p2p/mldonkey-urlslave/Makefile
index 1a78b368b90f..4918922325d0 100644
--- a/net-p2p/mldonkey-urlslave/Makefile
+++ b/net-p2p/mldonkey-urlslave/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mldonkey link submitter
-# Date created: Fri Feb 21 14:11:00 UTC 2003
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mldonkey
PORTVERSION= 0.0.1
@@ -20,15 +16,14 @@ BUILD_DEPENDS= p5-Gtk>=0:${PORTSDIR}/x11-toolkits/p5-Gtk
USE_PERL5= yes
NO_BUILD= yes
+USES= shebangfix
+SHEBANG_FILES= ${BINARY_NAME}
BINARY_NAME= mlurlslave
post-extract:
@${GREP} '^#' ${WRKSRC}/${BINARY_NAME} | ${GREP} -v '/usr/bin/perl' > ${WRKDIR}/README
-post-patch:
- @${PERL} -pi -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/${BINARY_NAME}
-
do-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
diff --git a/textproc/p5-Pod-Stripper/Makefile b/textproc/p5-Pod-Stripper/Makefile
index 395a098c65da..734eae5eeb2a 100644
--- a/textproc/p5-Pod-Stripper/Makefile
+++ b/textproc/p5-Pod-Stripper/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Pod-Stripper
-# Date created: 18 November 2003
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Pod-Stripper
PORTVERSION= 0.22
@@ -16,11 +12,9 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Strip all pod, and output what's left
PERL_CONFIGURE= yes
+USE_DOS2UNIX= yes
MAN1= podstrip.1
MAN3= Pod::Stripper.3
-post-patch:
- @${FIND} ${WRKSRC} -type f|${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//;'
-
.include <bsd.port.mk>