aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-11-25 09:24:13 +0800
committerlinimon <linimon@FreeBSD.org>2007-11-25 09:24:13 +0800
commit0ac7d39af7430dad1e4dd93dca3ed895af453594 (patch)
tree148654db8774c14dcd135b08e9e556e64613f9e6
parent7b70df09543e9f3de3c2d181f70e8fc148a2cc34 (diff)
downloadfreebsd-ports-gnome-0ac7d39af7430dad1e4dd93dca3ed895af453594.tar.gz
freebsd-ports-gnome-0ac7d39af7430dad1e4dd93dca3ed895af453594.tar.zst
freebsd-ports-gnome-0ac7d39af7430dad1e4dd93dca3ed895af453594.zip
Mark as broken on 5.x: fails to find pthread.h.
Something in the infrastructure changed in the late July timeframe that actually caused this problem. The only major thing at that time was the autoconf/libtool change, but I can't see how that could have caused this failure mode. It only happens on 5.x; 6.x and 7.x are fine. Approved by: portmgr (self)
-rw-r--r--databases/virtuoso/Makefile9
-rw-r--r--security/squidclam/Makefile5
-rw-r--r--www/havp/Makefile4
-rw-r--r--x11-drivers/xf86-video-openchrome/Makefile2
4 files changed, 17 insertions, 3 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 5740edeb64e2..dc08cfe28205 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -15,6 +15,9 @@ DISTNAME= ${PORTNAME}-opensource-${PORTVERSION}
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Universal SQL/Application Server
+BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
+LIB_DEPENDS= iodbc.3:${PORTSDIR}/databases/libiodbc
+
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-readline\
--with-iodbc=${LOCALBASE}\
@@ -22,8 +25,6 @@ CONFIGURE_ARGS= --with-readline\
--disable-jdbc
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"\
LDFLAGS="-L${LOCALBASE}/lib"
-BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
-LIB_DEPENDS= iodbc.3:${PORTSDIR}/databases/libiodbc
ONLY_FOR_ARCHS= i386
OPTIONS= IMAGEMAGICK "ImageMagick support" off\
@@ -61,6 +62,10 @@ BUILD_DEPENDS+= ${NETCAT}:${PORTSDIR}/net/netcat
CHECK_PORT= /usr/bin/nc -z localhost $$\1
.endif
+.if ${OSVERSION} < 600000
+BROKEN= Fails to compile: does not find pthread include file
+.endif
+
.if defined(WITH_IMAGEMAGICK)
CONFIGURE_ARGS+=--enable-imagemagick=${LOCALBASE}
LIB_DEPENDS+= Magick.10:${PORTSDIR}/graphics/ImageMagick
diff --git a/security/squidclam/Makefile b/security/squidclam/Makefile
index 514f4872abf0..54362535f83f 100644
--- a/security/squidclam/Makefile
+++ b/security/squidclam/Makefile
@@ -31,6 +31,11 @@ PLIST_FILES= bin/squidclam %%EXAMPLESDIR%%/squidclam.conf
PLIST_DIRS= %%EXAMPLESDIR%%
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+BROKEN= Fails to compile: does not find pthread include file
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' \
diff --git a/www/havp/Makefile b/www/havp/Makefile
index 48efc3fd7b1d..fbe9b87519ac 100644
--- a/www/havp/Makefile
+++ b/www/havp/Makefile
@@ -37,6 +37,10 @@ OPTIONS= SSL "Enable SSL proxying (not scanned, only forwarded!)" on \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 600000
+BROKEN= Fails to compile: does not find pthread include file
+.endif
+
.if defined(WITH_SSL)
CONFIGURE_ARGS+= --enable-ssl-tunnel
.else
diff --git a/x11-drivers/xf86-video-openchrome/Makefile b/x11-drivers/xf86-video-openchrome/Makefile
index 820df531fbe6..8ef1027992c3 100644
--- a/x11-drivers/xf86-video-openchrome/Makefile
+++ b/x11-drivers/xf86-video-openchrome/Makefile
@@ -33,7 +33,7 @@ pre-configure:
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 600000
-BROKEN= Does not compile
+BROKEN= Fails to compile: does not find pthread include file
.endif
.include <bsd.port.post.mk>