aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-09 20:44:34 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-09 20:44:34 +0800
commit0c8b585cd1b4b6631d88b4fbc1cfa96c684aab55 (patch)
tree1a3de3ef446315d4d130874b70f2ff807a9be60b
parent2b7c906e1ae13ce6dcb8e4df3c57a5beb3de5b8a (diff)
downloadfreebsd-ports-gnome-0c8b585cd1b4b6631d88b4fbc1cfa96c684aab55.tar.gz
freebsd-ports-gnome-0c8b585cd1b4b6631d88b4fbc1cfa96c684aab55.tar.zst
freebsd-ports-gnome-0c8b585cd1b4b6631d88b4fbc1cfa96c684aab55.zip
multimedia/plexhometheater: oops, back out r425788
`outputptr` is modified a few lines later which leads to undefined behavior. Pointy hat to: @jbeich
-rw-r--r--multimedia/plexhometheater/Makefile2
-rw-r--r--multimedia/plexhometheater/files/patch-xbmc_cores_dvdplayer_DVDPlayerAudioResampler.cpp11
2 files changed, 2 insertions, 11 deletions
diff --git a/multimedia/plexhometheater/Makefile b/multimedia/plexhometheater/Makefile
index 0a1db3f30f3c..c9f04936dce2 100644
--- a/multimedia/plexhometheater/Makefile
+++ b/multimedia/plexhometheater/Makefile
@@ -61,6 +61,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
xdpyinfo:x11/xdpyinfo
+BROKEN= Fails to build against libsamplerate-0.1.9
+
USE_GITHUB= yes
GH_ACCOUNT= plexinc
GH_PROJECT= plex-home-theater-public
diff --git a/multimedia/plexhometheater/files/patch-xbmc_cores_dvdplayer_DVDPlayerAudioResampler.cpp b/multimedia/plexhometheater/files/patch-xbmc_cores_dvdplayer_DVDPlayerAudioResampler.cpp
deleted file mode 100644
index 37aec17ecde1..000000000000
--- a/multimedia/plexhometheater/files/patch-xbmc_cores_dvdplayer_DVDPlayerAudioResampler.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- xbmc/cores/dvdplayer/DVDPlayerAudioResampler.cpp.orig 2015-05-11 07:54:22 UTC
-+++ xbmc/cores/dvdplayer/DVDPlayerAudioResampler.cpp
-@@ -74,7 +74,7 @@ void CDVDPlayerResampler::Add(DVDAudioFr
-
- //add samples to the resample input buffer
- int16_t* inputptr = (int16_t*)audioframe.data;
-- float* outputptr = m_converterdata.data_in;
-+ float* outputptr = (float*)m_converterdata.data_in;
-
- for (int i = 0; i < nrframes * m_nrchannels; i++)
- *outputptr++ = (float)*inputptr++ / scale;