aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordbaio <dbaio@FreeBSD.org>2018-03-17 22:43:34 +0800
committerdbaio <dbaio@FreeBSD.org>2018-03-17 22:43:34 +0800
commit0cdb69130df6aed3c464fa6c811443268af53c83 (patch)
treec9a3b025eacc65cf8afe994dbec747b6af16855a
parenta9fbd41bba766c86fbd0504480b821453e856915 (diff)
downloadfreebsd-ports-gnome-0cdb69130df6aed3c464fa6c811443268af53c83.tar.gz
freebsd-ports-gnome-0cdb69130df6aed3c464fa6c811443268af53c83.tar.zst
freebsd-ports-gnome-0cdb69130df6aed3c464fa6c811443268af53c83.zip
Fix order of variables
Ports maintained by me in categories: science security sysutils textproc
-rw-r--r--science/silo/Makefile7
-rw-r--r--security/chaosreader/Makefile7
-rw-r--r--security/pecl-ssh2-0/Makefile7
-rw-r--r--security/pecl-ssh2/Makefile3
-rw-r--r--security/py-halberd/Makefile2
-rw-r--r--security/py-vulndb/Makefile2
-rw-r--r--security/w3af/Makefile3
-rw-r--r--sysutils/pslist/Makefile2
-rw-r--r--sysutils/py-scriptine/Makefile2
-rw-r--r--textproc/extract_url/Makefile7
-rw-r--r--textproc/pear-File_MARC/Makefile6
-rw-r--r--textproc/pecl-xdiff/Makefile7
-rw-r--r--textproc/pecl-xdiff2/Makefile7
-rw-r--r--textproc/pecl-yaml/Makefile3
-rw-r--r--textproc/pecl-yaml1/Makefile3
-rw-r--r--textproc/py-guess-language/Makefile2
-rw-r--r--textproc/py-html2text/Makefile2
-rw-r--r--textproc/py-parsimonious/Makefile2
18 files changed, 42 insertions, 32 deletions
diff --git a/science/silo/Makefile b/science/silo/Makefile
index afcb57c34887..c3f6ae8f4037 100644
--- a/science/silo/Makefile
+++ b/science/silo/Makefile
@@ -3,8 +3,8 @@
PORTNAME= silo
PORTVERSION= 4.10.2
-PORTREVISION= 6
DISTVERSIONSUFFIX= -bsd
+PORTREVISION= 6
CATEGORIES= science
MASTER_SITES= http://wci.llnl.gov/content/assets/docs/simulation/computer-codes/${PORTNAME}/silo-${PORTVERSION}/
@@ -14,11 +14,12 @@ COMMENT= Mesh and field I/O library and scientific database
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+USES= gmake libtool readline
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --disable-static
INSTALL_TARGET= install-strip
-USES= gmake libtool readline
-USE_LDCONFIG= yes
OPTIONS_DEFINE= FORTRAN HDF5 PYTHON QT4
OPTIONS_DEFAULT= HDF5
diff --git a/security/chaosreader/Makefile b/security/chaosreader/Makefile
index 1704511197fd..8d230135e7ad 100644
--- a/security/chaosreader/Makefile
+++ b/security/chaosreader/Makefile
@@ -12,15 +12,16 @@ LICENSE= GPLv3+
RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
-NO_BUILD= yes
USES= perl5 shebangfix
-USE_PERL5= run
-NO_ARCH= yes
USE_GITHUB= yes
GH_ACCOUNT= brendangregg
GH_PROJECT= Chaosreader
+USE_PERL5= run
+NO_BUILD= yes
+NO_ARCH= yes
+
PLIST_FILES= bin/${PORTNAME}
SHEBANG_FILES= chaosreader
diff --git a/security/pecl-ssh2-0/Makefile b/security/pecl-ssh2-0/Makefile
index 458bd85d06e0..d1b7fd7c3f8c 100644
--- a/security/pecl-ssh2-0/Makefile
+++ b/security/pecl-ssh2-0/Makefile
@@ -11,18 +11,19 @@ COMMENT= PECL extension to the libssh2 library
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libssh2.so:security/libssh2
+IGNORE_WITH_PHP= 70 71 72
-PORTSCOUT= limit:^0.*
+LIB_DEPENDS= libssh2.so:security/libssh2
USES= php:pecl
-IGNORE_WITH_PHP= 70 71 72
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
CONFIGURE_ARGS= --with-ssh2
+PORTSCOUT= limit:^0.*
+
post-patch:
@${REINPLACE_CMD} -e 's|\$$SSH2_DIR/lib|\$$SSH2_DIR/\$$PHP_LIBDIR|g' ${WRKSRC}/config.m4
diff --git a/security/pecl-ssh2/Makefile b/security/pecl-ssh2/Makefile
index ef1503256549..fa11987b0a07 100644
--- a/security/pecl-ssh2/Makefile
+++ b/security/pecl-ssh2/Makefile
@@ -11,10 +11,11 @@ COMMENT= PECL extension to the libssh2 library
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
+IGNORE_WITH_PHP= 56
+
LIB_DEPENDS= libssh2.so:security/libssh2
USES= php:pecl
-IGNORE_WITH_PHP= 56
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
diff --git a/security/py-halberd/Makefile b/security/py-halberd/Makefile
index cf1120c31dd5..c460303186ff 100644
--- a/security/py-halberd/Makefile
+++ b/security/py-halberd/Makefile
@@ -12,8 +12,8 @@ COMMENT= HTTP load balancer detector written in Python
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-NO_ARCH= yes
USES= python:2.7
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/security/py-vulndb/Makefile b/security/py-vulndb/Makefile
index de8edf439911..b58eae77e4bf 100644
--- a/security/py-vulndb/Makefile
+++ b/security/py-vulndb/Makefile
@@ -14,8 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-git>=1.1:devel/py-setuptools-git@${FLAVOR}
-NO_ARCH= yes
USES= python
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/security/w3af/Makefile b/security/w3af/Makefile
index 0ef3c37759ad..20bd5a509f41 100644
--- a/security/w3af/Makefile
+++ b/security/w3af/Makefile
@@ -48,10 +48,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=2.1:devel/py-lxml@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}vulndb>=0.0.17:security/py-vulndb@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}markdown>=2.6.1:textproc/py-markdown@${FLAVOR}
+USES= gettext python:2.7 shebangfix
+
USE_GITHUB= yes
GH_ACCOUNT= andresriancho
-USES= gettext python:2.7 shebangfix
USE_PYTHON= flavors
SHEBANG_FILES= tools/* w3af_console w3af_gui
NO_BUILD= yes
diff --git a/sysutils/pslist/Makefile b/sysutils/pslist/Makefile
index ec0053e65fd8..33267dcca3d1 100644
--- a/sysutils/pslist/Makefile
+++ b/sysutils/pslist/Makefile
@@ -12,10 +12,10 @@ COMMENT= Utility to view or send signals to processes with all their children
LICENSE= BSD2CLAUSE
#LICENSE_FILE= ${WRKSRC}/README # License on 4th paragraph
-NO_ARCH= yes
USES= perl5 shebangfix
USE_PERL5= run
SHEBANG_FILES= pslist
MAKE_ENV= INSTALL_DATA="${INSTALL_DATA}" INSTALL_SCRIPT="${INSTALL_SCRIPT}"
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/sysutils/py-scriptine/Makefile b/sysutils/py-scriptine/Makefile
index 61e7b3903936..9276886edb7e 100644
--- a/sysutils/py-scriptine/Makefile
+++ b/sysutils/py-scriptine/Makefile
@@ -12,8 +12,8 @@ COMMENT= Python shell scripts made easy
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-NO_ARCH= yes
USES= python:-2.7
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/textproc/extract_url/Makefile b/textproc/extract_url/Makefile
index 81d64e2771dc..05884c0cbdb8 100644
--- a/textproc/extract_url/Makefile
+++ b/textproc/extract_url/Makefile
@@ -17,14 +17,15 @@ BUILD_DEPENDS= p5-MIME-Tools>=0:mail/p5-MIME-Tools \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gmake perl5
-MAKE_ARGS= all prefix=${PREFIX} man_prefix=${PREFIX}
-SUB_FILES= pkg-message
-NO_ARCH= yes
USE_GITHUB= yes
GH_ACCOUNT= m3m0ryh0l3
GH_PROJECT= extracturl
+MAKE_ARGS= all prefix=${PREFIX} man_prefix=${PREFIX}
+SUB_FILES= pkg-message
+NO_ARCH= yes
+
PLIST_FILES= bin/extract_url \
share/extract_url/extract_urlview.sample \
man/man1/extract_url.1.gz
diff --git a/textproc/pear-File_MARC/Makefile b/textproc/pear-File_MARC/Makefile
index 7d737175a6ce..28bff66e926f 100644
--- a/textproc/pear-File_MARC/Makefile
+++ b/textproc/pear-File_MARC/Makefile
@@ -11,12 +11,12 @@ COMMENT= Parse, modify, and create MARC records
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE
+USES= pear
+NO_ARCH= yes
+
OPTIONS_DEFINE= ISPN
ISPN_DESC= Validation class for ISPN (International Standard Product Numbers)
ISPN_RUN_DEPENDS= ${PEARDIR}/Validate/ISPN.php:textproc/pear-Validate_ISPN@${PHP_FLAVOR}
-USES= pear
-NO_ARCH= yes
-
.include <bsd.port.mk>
diff --git a/textproc/pecl-xdiff/Makefile b/textproc/pecl-xdiff/Makefile
index 032118faa511..f52762b2e4ab 100644
--- a/textproc/pecl-xdiff/Makefile
+++ b/textproc/pecl-xdiff/Makefile
@@ -11,13 +11,14 @@ COMMENT= PECL extension to create/apply binary and text patches
LICENSE= PHP301
-LIB_DEPENDS= libxdiff.so:textproc/libxdiff
+IGNORE_WITH_PHP= 70 71 72
-PORTSCOUT= limit:^1.*
+LIB_DEPENDS= libxdiff.so:textproc/libxdiff
USES= php:pecl
-IGNORE_WITH_PHP= 70 71 72
LDFLAGS+= -L${LOCALBASE}/lib
+PORTSCOUT= limit:^1.*
+
.include <bsd.port.mk>
diff --git a/textproc/pecl-xdiff2/Makefile b/textproc/pecl-xdiff2/Makefile
index e74f17a7a19a..eb77f7f602a2 100644
--- a/textproc/pecl-xdiff2/Makefile
+++ b/textproc/pecl-xdiff2/Makefile
@@ -10,14 +10,15 @@ COMMENT= PECL extension to create/apply binary and text patches
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libxdiff.so:textproc/libxdiff
+IGNORE_WITH_PHP= 56
-PORTSCOUT= limit:^2.*
+LIB_DEPENDS= libxdiff.so:textproc/libxdiff
USES= php:pecl
-IGNORE_WITH_PHP= 56
CONFLICTS= pecl-xdiff-1*
LDFLAGS+= -L${LOCALBASE}/lib
+PORTSCOUT= limit:^2.*
+
.include <bsd.port.mk>
diff --git a/textproc/pecl-yaml/Makefile b/textproc/pecl-yaml/Makefile
index 6754ce80f06d..7715311e7c85 100644
--- a/textproc/pecl-yaml/Makefile
+++ b/textproc/pecl-yaml/Makefile
@@ -11,9 +11,10 @@ COMMENT= YAML-1.1 parser and emitter
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+IGNORE_WITH_PHP= 56
+
LIB_DEPENDS= libyaml.so:textproc/libyaml
USES= php:pecl
-IGNORE_WITH_PHP= 56
.include <bsd.port.mk>
diff --git a/textproc/pecl-yaml1/Makefile b/textproc/pecl-yaml1/Makefile
index f968bbfe2daa..c050674dae79 100644
--- a/textproc/pecl-yaml1/Makefile
+++ b/textproc/pecl-yaml1/Makefile
@@ -11,11 +11,12 @@ COMMENT= YAML-1.1 parser and emitter
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+IGNORE_WITH_PHP= 70 71 72
+
LIB_DEPENDS= libyaml.so:textproc/libyaml
PORTSCOUT= limit:^1.*
USES= php:pecl
-IGNORE_WITH_PHP= 70 71 72
.include <bsd.port.mk>
diff --git a/textproc/py-guess-language/Makefile b/textproc/py-guess-language/Makefile
index 8bcc6a73aa57..4b2026a33d1e 100644
--- a/textproc/py-guess-language/Makefile
+++ b/textproc/py-guess-language/Makefile
@@ -11,8 +11,8 @@ COMMENT= Guess the natural language of a text in Python
LICENSE= LGPL21+
-NO_ARCH= yes
USES= python
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/textproc/py-html2text/Makefile b/textproc/py-html2text/Makefile
index 6d5edd76c2cb..bc04da41734a 100644
--- a/textproc/py-html2text/Makefile
+++ b/textproc/py-html2text/Makefile
@@ -15,9 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage
-NO_ARCH= yes
USES= python
USE_PYTHON= distutils autoplist
+NO_ARCH= yes
CONFLICTS= html2text
diff --git a/textproc/py-parsimonious/Makefile b/textproc/py-parsimonious/Makefile
index d768089ec48d..257a106539c9 100644
--- a/textproc/py-parsimonious/Makefile
+++ b/textproc/py-parsimonious/Makefile
@@ -14,8 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${FLAVOR}
-NO_ARCH= yes
USES= python
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
.include <bsd.port.mk>