aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-09-16 00:36:17 +0800
committerwg <wg@FreeBSD.org>2014-09-16 00:36:17 +0800
commit0e32943937fb56f7d3ecc3ecece1afe95b4e7993 (patch)
treea350e687fc5aefe66e08fddea24c0603008c9136
parente780ff01459a690707256ae3b780bda04e0e4c56 (diff)
downloadfreebsd-ports-gnome-0e32943937fb56f7d3ecc3ecece1afe95b4e7993.tar.gz
freebsd-ports-gnome-0e32943937fb56f7d3ecc3ecece1afe95b4e7993.tar.zst
freebsd-ports-gnome-0e32943937fb56f7d3ecc3ecece1afe95b4e7993.zip
sysutils/debootstrap: update to 1.0.61
- Add LICENSE (GPLv2) PR: 193238 Submitted by: maintainer
-rw-r--r--sysutils/debootstrap/Makefile12
-rw-r--r--sysutils/debootstrap/distinfo4
-rw-r--r--sysutils/debootstrap/files/patch-Makefile6
-rw-r--r--sysutils/debootstrap/files/patch-debootstrap29
-rw-r--r--sysutils/debootstrap/pkg-plist86
5 files changed, 72 insertions, 65 deletions
diff --git a/sysutils/debootstrap/Makefile b/sysutils/debootstrap/Makefile
index d86b1235b935..a9dde782c4e7 100644
--- a/sysutils/debootstrap/Makefile
+++ b/sysutils/debootstrap/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= debootstrap
-PORTVERSION= 1.0.60
-PORTREVISION= 1
+PORTVERSION= 1.0.61
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/d/${PORTNAME}
@@ -12,11 +11,13 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= lifanov@mail.lifanov.com
COMMENT= Install Debian base system into a directory
-RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget \
- dpkg:${PORTSDIR}/archivers/dpkg
+LICENSE= GPLv2
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
NO_BUILD= yes
+NO_ARCH= yes
USES= gmake perl5 tar:xz
USE_PERL5= run
MAKE_ARGS= DESTDIR="${STAGEDIR}"
@@ -28,6 +29,9 @@ post-patch:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
${WRKSRC}/Makefile \
${WRKSRC}/debootstrap
+ @${REINPLACE_CMD} -e 's,%%DATADIR%%,${DATADIR},g' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/debootstrap
post-install:
@${INSTALL_MAN} ${WRKSRC}/debootstrap.8 \
diff --git a/sysutils/debootstrap/distinfo b/sysutils/debootstrap/distinfo
index 79f7edd3dbea..52c0d6314b43 100644
--- a/sysutils/debootstrap/distinfo
+++ b/sysutils/debootstrap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (debootstrap_1.0.60.tar.xz) = 886b140a6801012aba3f502d1f50f5b8e94fc032965400a6c2da19437a75dd4b
-SIZE (debootstrap_1.0.60.tar.xz) = 49612
+SHA256 (debootstrap_1.0.61.tar.xz) = b6e1d3048c8afe7c819be297f9bac24d8820e7cabba0766d2ed2fc5928e71766
+SIZE (debootstrap_1.0.61.tar.xz) = 49724
diff --git a/sysutils/debootstrap/files/patch-Makefile b/sysutils/debootstrap/files/patch-Makefile
index a026251e4969..47d89e031790 100644
--- a/sysutils/debootstrap/files/patch-Makefile
+++ b/sysutils/debootstrap/files/patch-Makefile
@@ -1,11 +1,11 @@
---- ./Makefile.orig 2011-08-10 07:59:34.000000000 -0400
-+++ ./Makefile 2014-08-06 19:37:57.799160204 -0400
+--- Makefile.orig 2011-08-10 11:59:34 UTC
++++ Makefile
@@ -13,17 +13,15 @@
rm -f devices.tar.gz
rm -rf dev
-DSDIR=$(DESTDIR)/usr/share/debootstrap
-+DSDIR=$(DESTDIR)%%PREFIX%%/share/debootstrap
++DSDIR=$(DESTDIR)%%DATADIR%%
install:
mkdir -p $(DSDIR)/scripts
- mkdir -p $(DESTDIR)/usr/sbin
diff --git a/sysutils/debootstrap/files/patch-debootstrap b/sysutils/debootstrap/files/patch-debootstrap
index aed3294eb02c..f6194b29888f 100644
--- a/sysutils/debootstrap/files/patch-debootstrap
+++ b/sysutils/debootstrap/files/patch-debootstrap
@@ -1,39 +1,42 @@
---- ./debootstrap.orig 2014-02-07 10:25:58.000000000 -0500
-+++ ./debootstrap 2014-08-07 20:46:10.626600981 -0400
+--- debootstrap.orig 2014-02-07 15:25:58 UTC
++++ debootstrap
@@ -13,7 +13,7 @@
if [ -x /debootstrap/debootstrap ]; then
DEBOOTSTRAP_DIR=/debootstrap
else
- DEBOOTSTRAP_DIR=/usr/share/debootstrap
-+ DEBOOTSTRAP_DIR=%%PREFIX%%/share/debootstrap
++ DEBOOTSTRAP_DIR=%%DATADIR%%
fi
fi
-@@ -399,10 +399,10 @@
+@@ -397,13 +397,7 @@
- if in_path dpkg && \
- dpkg --print-architecture >/dev/null 2>&1; then
+ ###########################################################################
+
+-if in_path dpkg && \
+- dpkg --print-architecture >/dev/null 2>&1; then
- HOST_ARCH=`/usr/bin/dpkg --print-architecture`
-+ HOST_ARCH=`%%PREFIX%%/bin/dpkg --print-architecture`
- elif in_path udpkg && \
- udpkg --print-architecture >/dev/null 2>&1; then
+-elif in_path udpkg && \
+- udpkg --print-architecture >/dev/null 2>&1; then
- HOST_ARCH=`/usr/bin/udpkg --print-architecture`
-+ HOST_ARCH=`%%PREFIX%%/bin/udpkg --print-architecture`
- elif [ -e $DEBOOTSTRAP_DIR/arch ]; then
+-elif [ -e $DEBOOTSTRAP_DIR/arch ]; then
++if [ -e $DEBOOTSTRAP_DIR/arch ]; then
HOST_ARCH=`cat $DEBOOTSTRAP_DIR/arch`
fi
-@@ -425,6 +425,10 @@
+ HOST_OS="$HOST_ARCH"
+@@ -425,6 +419,11 @@
esac
fi
+if [ "$HOST_OS" = "freebsd" -a -z "$HOST_ARCH" ]; then
+ HOST_ARCH=kfreebsd-`/sbin/sysctl -n hw.machine_arch`
++ EXTRACTOR_OVERRIDE=ar
+fi
+
if [ -z "$ARCH" ]; then
ARCH=$HOST_ARCH
fi
-@@ -621,7 +625,6 @@
+@@ -621,7 +620,6 @@
if ! am_doing_phase second_stage; then
cp "$0" "$TARGET/debootstrap/debootstrap"
cp $DEBOOTSTRAP_DIR/functions "$TARGET/debootstrap/functions"
diff --git a/sysutils/debootstrap/pkg-plist b/sysutils/debootstrap/pkg-plist
index 3bc9d7c46411..3241ae0c99f9 100644
--- a/sysutils/debootstrap/pkg-plist
+++ b/sysutils/debootstrap/pkg-plist
@@ -2,46 +2,46 @@
sbin/debootstrap
@mode
man/man8/debootstrap.8.gz
-share/debootstrap/functions
-share/debootstrap/scripts/breezy
-share/debootstrap/scripts/dapper
-share/debootstrap/scripts/edgy
-share/debootstrap/scripts/etch
-share/debootstrap/scripts/etch-m68k
-share/debootstrap/scripts/feisty
-share/debootstrap/scripts/gutsy
-share/debootstrap/scripts/hardy
-share/debootstrap/scripts/hoary
-share/debootstrap/scripts/hoary.buildd
-share/debootstrap/scripts/intrepid
-share/debootstrap/scripts/jaunty
-share/debootstrap/scripts/jessie
-share/debootstrap/scripts/karmic
-share/debootstrap/scripts/lenny
-share/debootstrap/scripts/lucid
-share/debootstrap/scripts/maverick
-share/debootstrap/scripts/natty
-share/debootstrap/scripts/oldstable
-share/debootstrap/scripts/oneiric
-share/debootstrap/scripts/potato
-share/debootstrap/scripts/precise
-share/debootstrap/scripts/quantal
-share/debootstrap/scripts/raring
-share/debootstrap/scripts/sarge
-share/debootstrap/scripts/sarge.buildd
-share/debootstrap/scripts/sarge.fakechroot
-share/debootstrap/scripts/saucy
-share/debootstrap/scripts/sid
-share/debootstrap/scripts/squeeze
-share/debootstrap/scripts/stable
-share/debootstrap/scripts/testing
-share/debootstrap/scripts/trusty
-share/debootstrap/scripts/unstable
-share/debootstrap/scripts/utopic
-share/debootstrap/scripts/warty
-share/debootstrap/scripts/warty.buildd
-share/debootstrap/scripts/wheezy
-share/debootstrap/scripts/woody
-share/debootstrap/scripts/woody.buildd
-@dirrm share/debootstrap/scripts
-@dirrm share/debootstrap
+%%DATADIR%%/functions
+%%DATADIR%%/scripts/breezy
+%%DATADIR%%/scripts/dapper
+%%DATADIR%%/scripts/edgy
+%%DATADIR%%/scripts/etch
+%%DATADIR%%/scripts/etch-m68k
+%%DATADIR%%/scripts/feisty
+%%DATADIR%%/scripts/gutsy
+%%DATADIR%%/scripts/hardy
+%%DATADIR%%/scripts/hoary
+%%DATADIR%%/scripts/hoary.buildd
+%%DATADIR%%/scripts/intrepid
+%%DATADIR%%/scripts/jaunty
+%%DATADIR%%/scripts/jessie
+%%DATADIR%%/scripts/karmic
+%%DATADIR%%/scripts/lenny
+%%DATADIR%%/scripts/lucid
+%%DATADIR%%/scripts/maverick
+%%DATADIR%%/scripts/natty
+%%DATADIR%%/scripts/oldstable
+%%DATADIR%%/scripts/oneiric
+%%DATADIR%%/scripts/potato
+%%DATADIR%%/scripts/precise
+%%DATADIR%%/scripts/quantal
+%%DATADIR%%/scripts/raring
+%%DATADIR%%/scripts/sarge
+%%DATADIR%%/scripts/sarge.buildd
+%%DATADIR%%/scripts/sarge.fakechroot
+%%DATADIR%%/scripts/saucy
+%%DATADIR%%/scripts/sid
+%%DATADIR%%/scripts/squeeze
+%%DATADIR%%/scripts/stable
+%%DATADIR%%/scripts/testing
+%%DATADIR%%/scripts/trusty
+%%DATADIR%%/scripts/unstable
+%%DATADIR%%/scripts/utopic
+%%DATADIR%%/scripts/warty
+%%DATADIR%%/scripts/warty.buildd
+%%DATADIR%%/scripts/wheezy
+%%DATADIR%%/scripts/woody
+%%DATADIR%%/scripts/woody.buildd
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%