aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-03-12 08:09:52 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-03-12 08:09:52 +0800
commit0fa181ec41e5bcad24c96319ad5f588592b0222d (patch)
tree4809d827d3e60c45f5a1c2ee4ce84e517c70011f
parent2ff4f8266001e4da37fb5b3508cc76a25168de83 (diff)
downloadfreebsd-ports-gnome-0fa181ec41e5bcad24c96319ad5f588592b0222d.tar.gz
freebsd-ports-gnome-0fa181ec41e5bcad24c96319ad5f588592b0222d.tar.zst
freebsd-ports-gnome-0fa181ec41e5bcad24c96319ad5f588592b0222d.zip
Math::Geometry::Planar::GPC::Polygon - OO wrapper to gpc library
WWW: http://search.cpan.org/dist/Math-Geometry-Planar-GPC-Polygon/
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Geometry-Planar-GPC-Polygon/Makefile24
-rw-r--r--math/p5-Math-Geometry-Planar-GPC-Polygon/distinfo2
-rw-r--r--math/p5-Math-Geometry-Planar-GPC-Polygon/pkg-descr3
-rw-r--r--math/p5-Math-Geometry-Planar-GPC-Polygon/pkg-plist18
5 files changed, 48 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 53d5bc95806d..0c296c746af0 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -349,6 +349,7 @@
SUBDIR += p5-Math-Geometry
SUBDIR += p5-Math-Geometry-Planar
SUBDIR += p5-Math-Geometry-Planar-GPC
+ SUBDIR += p5-Math-Geometry-Planar-GPC-Polygon
SUBDIR += p5-Math-Geometry-Planar-Offset
SUBDIR += p5-Math-Geometry-Voronoi
SUBDIR += p5-Math-Gradient
diff --git a/math/p5-Math-Geometry-Planar-GPC-Polygon/Makefile b/math/p5-Math-Geometry-Planar-GPC-Polygon/Makefile
new file mode 100644
index 000000000000..9db45354f585
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar-GPC-Polygon/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Math-Geometry-Planar-GPC-Polygon
+# Date created: 03 Mar 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Geometry-Planar-GPC-Polygon
+PORTVERSION= 0.05
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= OO wrapper to gpc library
+
+BUILD_DEPENDS= ${SITE_PERL}/Inline/MakeMaker.pm:${PORTSDIR}/devel/p5-Inline
+
+PERL_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+
+MAN3= Math::Geometry::Planar::GPC::Polygon.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Geometry-Planar-GPC-Polygon/distinfo b/math/p5-Math-Geometry-Planar-GPC-Polygon/distinfo
new file mode 100644
index 000000000000..38adde002b6c
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar-GPC-Polygon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Math-Geometry-Planar-GPC-Polygon-0.05.tar.gz) = 2f9d96a9bc4ef2101442bc12152f7f7ca8c062f67091ddeca6fee82d65b3d390
+SIZE (Math-Geometry-Planar-GPC-Polygon-0.05.tar.gz) = 19338
diff --git a/math/p5-Math-Geometry-Planar-GPC-Polygon/pkg-descr b/math/p5-Math-Geometry-Planar-GPC-Polygon/pkg-descr
new file mode 100644
index 000000000000..1371789f18d9
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar-GPC-Polygon/pkg-descr
@@ -0,0 +1,3 @@
+Math::Geometry::Planar::GPC::Polygon - OO wrapper to gpc library
+
+WWW: http://search.cpan.org/dist/Math-Geometry-Planar-GPC-Polygon/
diff --git a/math/p5-Math-Geometry-Planar-GPC-Polygon/pkg-plist b/math/p5-Math-Geometry-Planar-GPC-Polygon/pkg-plist
new file mode 100644
index 000000000000..4884a9b35f53
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar-GPC-Polygon/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Geometry/Planar/GPC/Polygon.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Geometry/Planar/GPC/Polygon/functions.c
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Geometry/Planar/GPC/Polygon/include/gpc.c
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Geometry/Planar/GPC/Polygon/include/gpc.h
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry/Planar/GPC/Polygon/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry/Planar/GPC/Polygon/Polygon.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry/Planar/GPC/Polygon/Polygon.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry/Planar/GPC/Polygon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry/Planar/GPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry/Planar
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math/Geometry/Planar/GPC/Polygon/include
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math/Geometry/Planar/GPC/Polygon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Geometry/Planar/GPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Geometry/Planar
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Geometry
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math