aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2013-01-16 18:21:51 +0800
committerolgeni <olgeni@FreeBSD.org>2013-01-16 18:21:51 +0800
commit159138b92b92669b7cf3b369055042240919ae41 (patch)
tree19cb641504e72169dcc83934ddf0548a6d646ecf
parent910a91e852bf3d573051ad6d01ee82a8a90f30bb (diff)
downloadfreebsd-ports-gnome-159138b92b92669b7cf3b369055042240919ae41.tar.gz
freebsd-ports-gnome-159138b92b92669b7cf3b369055042240919ae41.tar.zst
freebsd-ports-gnome-159138b92b92669b7cf3b369055042240919ae41.zip
Upgrade to version 8.1.8.
Note about the change in files/jettyctl.in: if the configuration file is passed on the command line then jetty 8 will try to create a socket twice on the same port and fail, so it was removed.
-rw-r--r--www/jetty/Makefile9
-rw-r--r--www/jetty/distinfo4
-rw-r--r--www/jetty/files/jettyctl.in3
-rw-r--r--www/jetty/pkg-descr41
4 files changed, 19 insertions, 38 deletions
diff --git a/www/jetty/Makefile b/www/jetty/Makefile
index 726e46f02ebb..eaeb8324c49d 100644
--- a/www/jetty/Makefile
+++ b/www/jetty/Makefile
@@ -2,18 +2,19 @@
# $FreeBSD$
PORTNAME= jetty
-DISTVERSION= 6.1.26
+PORTVERSION= 8.1.8
CATEGORIES= www java
-MASTER_SITES= http://dist.codehaus.org/jetty/${PORTNAME}-${DISTVERSION}/
+MASTER_SITES= ${MASTER_SITE_ECLIPSE}
+MASTER_SITE_SUBDIR=jetty/stable-8/dist
+DISTNAME= jetty-distribution-8.1.8.v20121106
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Full-featured web server implemented entirely in Java
USE_RC_SUBR= ${PORTNAME}
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
-USE_PYTHON= 1.6+
+USE_PYTHON= 2.4+
PLIST= ${WRKDIR}/pkg-plist
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/www/jetty/distinfo b/www/jetty/distinfo
index 16a7921343b7..dbe50bf43625 100644
--- a/www/jetty/distinfo
+++ b/www/jetty/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jetty-6.1.26.zip) = 96c08eb87ec3772dccc2b3dba54fea85ccc3f804faf7429eecfba3ed55648187
-SIZE (jetty-6.1.26.zip) = 25894195
+SHA256 (jetty-distribution-8.1.8.v20121106.tar.gz) = f66cfe7b3da8f2191709926420a9755a17908c258bcb265fc905f147879bb9f9
+SIZE (jetty-distribution-8.1.8.v20121106.tar.gz) = 9064609
diff --git a/www/jetty/files/jettyctl.in b/www/jetty/files/jettyctl.in
index 705acd5c5b26..d9b498688240 100644
--- a/www/jetty/files/jettyctl.in
+++ b/www/jetty/files/jettyctl.in
@@ -152,8 +152,7 @@ if __name__ == '__main__':
ARGS += [
"-Djetty.home=%%APP_HOME%%",
"-jar",
- "%%APP_HOME%%/start.jar",
- "%%PREFIX%%/etc/%%APP_NAME%%.xml"
+ "%%APP_HOME%%/start.jar"
]
os.environ['PATH'] = "%%LOCALBASE%%/bin:/usr/bin:/bin"
diff --git a/www/jetty/pkg-descr b/www/jetty/pkg-descr
index f31a96247f3a..81e23ce39179 100644
--- a/www/jetty/pkg-descr
+++ b/www/jetty/pkg-descr
@@ -1,33 +1,14 @@
-Jetty is an open-source, standards-based, full-featured web server implemented
-entirely in Java. It is released under the Apache 2.0 licence and is therefore
-free for commercial use and distribution.
+The Jetty Web Server provides an HTTP server and Servlet container
+capable of serving static and dynamic content either from a standalone
+or embedded instantiations. From jetty-7, the jetty webserver and
+other core compoments are hosted by the eclipse foundation.
-Jetty can be used as:
+The project provides:
- * a stand-alone traditional web server for static and dynamic content
- * a dynamic content server behind a dedicated HTTP server such as Apache
- using mod_proxy
- * an embedded component within a Java application
+* Asynchronous HTTP Server
+* Standard based Servlet Container
+* Web Sockets server
+* Asynchronous HTTP Client
+* OSGi, JNDI, JMX, JASPI, AJP support
-Some of the defining features of Jetty are:
-
-Simplicity: The guiding principle of Jetty could be said to be "simplicity not
-complexity". We want to make Jetty easy to understand and use:
-
-Efficiency: A lot of effort goes into optimizing Jetty's performance and
-crafting the code so as to make the footprint as small as possible.
-
-Embeddability: Jetty is designed to be a good component. This means that it can
-easily be embedded in an application without forcing the application to adapt to
-it.
-
-Pluggability: Jetty is architected for pluggability. The API allows different
-implementations of all of the principal Jetty components to be selected. At
-least one, but sometimes more, implementations of a component are always
-provided. However if these do not meet your needs, you are free to code your own
-using the interfaces and abstract classes as a basis. This means that Jetty
-can be easily customised to a particular application environment. This is
-particularly useful when Jetty is acting as the web container in a J2EE server,
-as Jetty's pluggability ensures a tight integration with a host container.
-
-WWW: http://jetty.mortbay.com/
+WWW: http://www.eclipse.org/jetty/