aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-28 23:38:18 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-28 23:38:18 +0800
commit162b1e72de32c194510910cb119f0b756e0eedca (patch)
tree70561ba0aab5be91ede6b42af1261ecf9614f120
parent932eb2d5750a214e130cd9c6ce4d90413d8326c9 (diff)
downloadfreebsd-ports-gnome-162b1e72de32c194510910cb119f0b756e0eedca.tar.gz
freebsd-ports-gnome-162b1e72de32c194510910cb119f0b756e0eedca.tar.zst
freebsd-ports-gnome-162b1e72de32c194510910cb119f0b756e0eedca.zip
- use hook for bsd.openssl.mk
-rw-r--r--dns/bind9-dlz/Makefile15
-rw-r--r--mail/sendmail-old/Makefile4
-rw-r--r--mail/sendmail811/Makefile4
-rw-r--r--net-im/licq/Makefile10
-rw-r--r--net/bind9-dlz/Makefile15
-rw-r--r--net/licq/Makefile10
-rw-r--r--news/suck/Makefile7
-rw-r--r--security/hpn-ssh/Makefile2
-rw-r--r--security/openssh-portable/Makefile2
-rw-r--r--security/openssh/Makefile14
-rw-r--r--www/apache13-modssl/Makefile13
11 files changed, 56 insertions, 40 deletions
diff --git a/dns/bind9-dlz/Makefile b/dns/bind9-dlz/Makefile
index 7ff6dff77139..4f4735d41b07 100644
--- a/dns/bind9-dlz/Makefile
+++ b/dns/bind9-dlz/Makefile
@@ -62,6 +62,14 @@ CONFIGURE_ARGS+= --with-dlz-filesystem
CONFIGURE_ARGS+= --with-dlz-stub
.endif
+.if defined(WITH_OPENSSL)
+.if !defined(WITHOUT_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+.endif
+
+
WRKSRC= ${WRKDIR}/bind-${ISCVERSION}
EXTRA_PATCHES= ${WRKDIR}/dlz.patch
PLIST= ${WRKDIR}/.PLIST.more
@@ -175,13 +183,6 @@ post-clean:
.include <bsd.port.pre.mk>
-.if defined(WITH_OPENSSL)
-.if !defined(WITHOUT_OPENSSL)
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.endif
-.endif
-
.if ${OSVERSION} > 500030
CONFIGURE_ARGS+= --enable-threads
.else
diff --git a/mail/sendmail-old/Makefile b/mail/sendmail-old/Makefile
index 9b40660c6737..88523cd8f5f0 100644
--- a/mail/sendmail-old/Makefile
+++ b/mail/sendmail-old/Makefile
@@ -72,6 +72,9 @@ SITE+= ${FILESDIR}/site.config.m4.ldap
.if ! defined(SENDMAIL_WITHOUT_MILTER)
SITE+= ${FILESDIR}/site.config.m4.milter
.endif
+.if defined(SENDMAIL_WITH_TLS) || defined(WITH_TLS)
+USE_OPENSSL= yes
+.endif
# install directly if no mailwrapper support
.if ! exists(${DESTDIR}/etc/mail/mailer.conf)
@@ -172,7 +175,6 @@ mailer.conf:
.include <bsd.port.pre.mk>
.if defined(SENDMAIL_WITH_TLS) || defined(WITH_TLS)
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
.if ! defined(WITH_OPENSSL_BASE)
SITE+= ${FILESDIR}/site.config.m4.ssl
.endif
diff --git a/mail/sendmail811/Makefile b/mail/sendmail811/Makefile
index 9b40660c6737..88523cd8f5f0 100644
--- a/mail/sendmail811/Makefile
+++ b/mail/sendmail811/Makefile
@@ -72,6 +72,9 @@ SITE+= ${FILESDIR}/site.config.m4.ldap
.if ! defined(SENDMAIL_WITHOUT_MILTER)
SITE+= ${FILESDIR}/site.config.m4.milter
.endif
+.if defined(SENDMAIL_WITH_TLS) || defined(WITH_TLS)
+USE_OPENSSL= yes
+.endif
# install directly if no mailwrapper support
.if ! exists(${DESTDIR}/etc/mail/mailer.conf)
@@ -172,7 +175,6 @@ mailer.conf:
.include <bsd.port.pre.mk>
.if defined(SENDMAIL_WITH_TLS) || defined(WITH_TLS)
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
.if ! defined(WITH_OPENSSL_BASE)
SITE+= ${FILESDIR}/site.config.m4.ssl
.endif
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 0e113d1d375b..aecde4ae98f7 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -31,6 +31,12 @@ CONFIGURE_ARGS+=--with-socks5-inc=${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
.endif
+.if !defined(WITHOUT_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl-inc=${OPENSSLINC}
+CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
+.endif
+
pre-configure:
@${MV} ${WRKSRC}/src/licq.conf.h ${WRKSRC}/src/licq.conf.h.sed
${SED} -e "s=/usr/share/licq=${PREFIX}/share/licq=" \
@@ -45,9 +51,5 @@ post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
-CONFIGURE_ARGS+=--with-openssl-inc=${OPENSSLINC}
-CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
-
.include "${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>
diff --git a/net/bind9-dlz/Makefile b/net/bind9-dlz/Makefile
index 7ff6dff77139..4f4735d41b07 100644
--- a/net/bind9-dlz/Makefile
+++ b/net/bind9-dlz/Makefile
@@ -62,6 +62,14 @@ CONFIGURE_ARGS+= --with-dlz-filesystem
CONFIGURE_ARGS+= --with-dlz-stub
.endif
+.if defined(WITH_OPENSSL)
+.if !defined(WITHOUT_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+.endif
+
+
WRKSRC= ${WRKDIR}/bind-${ISCVERSION}
EXTRA_PATCHES= ${WRKDIR}/dlz.patch
PLIST= ${WRKDIR}/.PLIST.more
@@ -175,13 +183,6 @@ post-clean:
.include <bsd.port.pre.mk>
-.if defined(WITH_OPENSSL)
-.if !defined(WITHOUT_OPENSSL)
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.endif
-.endif
-
.if ${OSVERSION} > 500030
CONFIGURE_ARGS+= --enable-threads
.else
diff --git a/net/licq/Makefile b/net/licq/Makefile
index 0e113d1d375b..aecde4ae98f7 100644
--- a/net/licq/Makefile
+++ b/net/licq/Makefile
@@ -31,6 +31,12 @@ CONFIGURE_ARGS+=--with-socks5-inc=${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
.endif
+.if !defined(WITHOUT_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl-inc=${OPENSSLINC}
+CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
+.endif
+
pre-configure:
@${MV} ${WRKSRC}/src/licq.conf.h ${WRKSRC}/src/licq.conf.h.sed
${SED} -e "s=/usr/share/licq=${PREFIX}/share/licq=" \
@@ -45,9 +51,5 @@ post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
-CONFIGURE_ARGS+=--with-openssl-inc=${OPENSSLINC}
-CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
-
.include "${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>
diff --git a/news/suck/Makefile b/news/suck/Makefile
index 23870b5929f6..61c070d36f68 100644
--- a/news/suck/Makefile
+++ b/news/suck/Makefile
@@ -23,6 +23,7 @@ EX_DATA= suckkillfile.sample sucknewsrc.sample suckothermsgs.sample
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
MAKE_ENV+= CHKHISTORY=chkhistory_db.o
+
.if defined(NEWSBIN) && !defined(SUCK_WITH_INN)
CNEWS_PORT?= news/cnews
PKGNAMESUFFIX?= -cnews
@@ -40,10 +41,8 @@ MAKE_ENV+= INCDIR2=-I${LOCALBASE}/include
BUILD_DEPENDS+= ${LOCALBASE}/news/lib/libinn.a:${PORTSDIR}/news/inn
.endif
-.include <bsd.port.pre.mk>
-
.if !defined(SUCK_WITHOUT_SSL) && !defined(WITHOUT_SSL)
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
+USE_OPENSSL= yes
MAKE_ENV+= SSL_LIB="-lssl -lcrypto"
MAKE_ENV+= SSL_DEFS="-I${OPENSSLINC} -DHAVE_LIBSSL"
MAKE_ENV+= SSL_LIB_LOC="-L${OPENSSLLIB}"
@@ -75,4 +74,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 7b6b7b32fad5..1aab176efbf3 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -20,6 +20,7 @@ MLINKS= ssh.1 slogin.1
MAN5= ssh_config.5 sshd_config.5
MAN8= sftp-server.8 sshd.8 ssh-keysign.8
+USE_OPENSSL= yes
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS=${LDFLAGS}
@@ -139,7 +140,6 @@ test:
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
.if ${OPENSSLBASE} == "/usr"
CONFIGURE_ARGS+= --without-rpath
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 7b6b7b32fad5..1aab176efbf3 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -20,6 +20,7 @@ MLINKS= ssh.1 slogin.1
MAN5= ssh_config.5 sshd_config.5
MAN8= sftp-server.8 sshd.8 ssh-keysign.8
+USE_OPENSSL= yes
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS=${LDFLAGS}
@@ -139,7 +140,6 @@ test:
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
.if ${OPENSSLBASE} == "/usr"
CONFIGURE_ARGS+= --without-rpath
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index b5ca34c40fa8..c4176aa51cdf 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -20,11 +20,15 @@ PATCHFILES= openbsd28_${PORTVERSION}.patch
MAINTAINER= dinoex@FreeBSD.org
COMMENT= OpenBSD's secure shell client and server (remote login program)
+USE_OPENSSL= yes
+WRKSRC= ${WRKDIR}/ssh
+
MAN1= scp.1 slogin.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh.1 \
ssh-keyscan.1 sftp.1
MAN5= ssh_config.5 sshd_config.5
MAN8= sshd.8 sftp-server.8 ssh-keysign.8
MANCOMPRESSED= yes
+
MODIFY= ssh.h sshd_config sshd.sh pathnames.h
FIXME= lib/Makefile scp/Makefile sftp/Makefile sftp-server/Makefile \
ssh/Makefile ssh-add/Makefile ssh-agent/Makefile \
@@ -41,41 +45,45 @@ PAM=no
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
-
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
# Here, MANDIR is concetenated to DESTDIR which all forms the man install dir...
MAKE_ENV+= DESTDIR=${PREFIX} MANDIR=/man/man CRYPTOLIBS="${CRYPTOLIBS}"
MAKE_ENV+= LDFLAGS=${LDFLAGS}
+
.if ${OSVERSION} < 400014
MAKE_ENV+= COMPAT_GETADDRINFO=yes
ADDME+= netdb.h
.else
MAKE_ENV+= INET6FLAGS=-DINET6
.endif
+
.if !exists(/usr/include/tcpd.h)
MAKE_ENV+= TCP_WRAPPERS=no
.endif
+
.if defined(AFS) && ${AFS} == YES
MAKE_ENV+= AFS=yes
.endif
+
.if defined(KERBEROS) && ${KERBEROS} == YES
MAKE_ENV+= KERBEROS=yes
.endif
+
.if exists(/usr/include/security/pam_modules.h)
PAM?= yes
.else
PAM= no
.endif
MAKE_ENV+= PAM=${PAM}
+
.if defined(SKEY) && ${SKEY} == YES
MAKE_ENV+= SKEY=yes
.endif
+
EMPTYDIR= ${PREFIX}/empty
ETCOLD= ${PREFIX}/etc
ETCSSH= ${PREFIX}/etc/ssh
PLIST_SUB+= EMPTYDIR=${EMPTYDIR}
-WRKSRC= ${WRKDIR}/ssh
post-extract:
@${CP} ${FILESDIR}/sshd.sh ${WRKSRC}/
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index 34d6951f7606..f5ba628d4e95 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -19,7 +19,13 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= The Apache 1.3 webserver with SSL/TLS functionality
LIB_DEPENDS= mm.13:${PORTSDIR}/devel/mm
+PATCH_DEPENDS= ${BUILD_DEPENDS}
+VERSION_APACHE= 1.3.28
+VERSION_MODSSL= 2.8.15
+USE_OPENSSL= yes
+HAS_CONFIGURE= yes
+USE_PERL5_BUILD= yes
MASTER_SITES_MODSSL= http://www.modssl.org/source/ \
ftp://ftp.modssl.org/source/ \
ftp://ftp.pca.dfn.de/pub/tools/net/mod_ssl/ \
@@ -36,9 +42,6 @@ MASTER_SITES_MODSSL= http://www.modssl.org/source/ \
.include <bsd.port.pre.mk>
-VERSION_APACHE= 1.3.28
-VERSION_MODSSL= 2.8.15
-
DATADIR= ${PREFIX}/www
DOCUMENT_ROOT= ${DATADIR}/data
@@ -76,8 +79,6 @@ SUEXEC_MAN=
.endif # !SUEXEC
-USE_PERL5= yes
-HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${PREFIX} \
--server-uid=www \
--server-gid=www \
@@ -118,8 +119,6 @@ OPTIM+= -DBUFFERED_LOGS
CFLAGS+= -O3
.endif
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
-
CONFIGURE_ENV= CFLAGS='${CFLAGS}' \
OPTIM='${OPTIM}' \
SSL_BASE='${OPENSSLBASE}' \