aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2010-02-08 15:04:53 +0800
committerdougb <dougb@FreeBSD.org>2010-02-08 15:04:53 +0800
commit1971aa6c0b4659a0ec15177349ebf79d0756480d (patch)
tree28cab9836f28855a7b42f2cc45a97f352ddb4a09
parent5767b6837ee40ef812b700308bb9c3b182a5d36e (diff)
downloadfreebsd-ports-gnome-1971aa6c0b4659a0ec15177349ebf79d0756480d.tar.gz
freebsd-ports-gnome-1971aa6c0b4659a0ec15177349ebf79d0756480d.tar.zst
freebsd-ports-gnome-1971aa6c0b4659a0ec15177349ebf79d0756480d.zip
Allow alpine to link against OpenSSL from the ports instead of the base.
PR: ports/143525 Submitted by: Dan Lukes <dan@obluda.cz>
-rw-r--r--mail/alpine/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/mail/alpine/Makefile b/mail/alpine/Makefile
index 6f556a276af7..75ebaa8dc1b8 100644
--- a/mail/alpine/Makefile
+++ b/mail/alpine/Makefile
@@ -128,8 +128,9 @@ PATCHFILES+= maildir.patch.gz
.endif
.if !defined(WITHOUT_SSL)
-MAKE_ARGS+= SSLINCLUDE=${OPENSSLINC} SSLLIB=${OPENSSLLIB}
CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLDIR} \
+ --with-ssl-include-dir=${OPENSSLINC} \
+ --with-ssl-lib-dir=${OPENSSLLIB} \
--with-ssl-certs-dir=${OPENSSLDIR}/certs
.else
CONFIGURE_ARGS+= --without-ssl