aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-29 17:31:03 +0800
committeredwin <edwin@FreeBSD.org>2003-04-29 17:31:03 +0800
commit206b9299d163f899e78138d669cfab2ad7251813 (patch)
treebb6a615928fba2bb31417fc74edfc63c25199b5c
parent1da6be29a34aa2bce3404600526fc10c9bedef6e (diff)
downloadfreebsd-ports-gnome-206b9299d163f899e78138d669cfab2ad7251813.tar.gz
freebsd-ports-gnome-206b9299d163f899e78138d669cfab2ad7251813.tar.zst
freebsd-ports-gnome-206b9299d163f899e78138d669cfab2ad7251813.zip
new port, p5-Text-Shellwords
This is a thin wrapper around the shellwords.pl package, which comes preinstalled with Perl. This module imports a single subroutine, shellwords(). The shellwords() routine parses lines of text and returns a set of tokens using the same rules that the Unix shell does for its command-line arguments. Tokens are separated by whitespace, and can be delimited by single or double quotes. The module also respects backslash escapes. PR: ports/50081 Submitted by: George Hartzell <hartzell@fruitfly.org>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Shellwords/Makefile23
-rw-r--r--textproc/p5-Text-Shellwords/distinfo1
-rw-r--r--textproc/p5-Text-Shellwords/pkg-descr7
-rw-r--r--textproc/p5-Text-Shellwords/pkg-plist3
5 files changed, 35 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 21a58088aa99..09cd5f687a40 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -234,6 +234,7 @@
SUBDIR += p5-Text-Reflow
SUBDIR += p5-Text-Reform
SUBDIR += p5-Text-Repository
+ SUBDIR += p5-Text-Shellwords
SUBDIR += p5-Text-SimpleTemplate
SUBDIR += p5-Text-Tabs+Wrap
SUBDIR += p5-Text-Template
diff --git a/textproc/p5-Text-Shellwords/Makefile b/textproc/p5-Text-Shellwords/Makefile
new file mode 100644
index 000000000000..eb6587cababa
--- /dev/null
+++ b/textproc/p5-Text-Shellwords/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: textproc/p5-Text-Shellwords
+# Date created: Mon Mar 17 11:47:21 PST 2003
+# Whom: George Hartzell <hartzell@fruitfly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Shellwords
+PORTVERSION= 1.00
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@fruitfly.org
+COMMENT= This is a thin wrapper around the shellwords.pl package
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Shellwords.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Shellwords/distinfo b/textproc/p5-Text-Shellwords/distinfo
new file mode 100644
index 000000000000..98add13a7b16
--- /dev/null
+++ b/textproc/p5-Text-Shellwords/distinfo
@@ -0,0 +1 @@
+MD5 (Text-Shellwords-1.00.tar.gz) = 016f95c2e40a760d261772a40025e543
diff --git a/textproc/p5-Text-Shellwords/pkg-descr b/textproc/p5-Text-Shellwords/pkg-descr
new file mode 100644
index 000000000000..5e79f6c38e74
--- /dev/null
+++ b/textproc/p5-Text-Shellwords/pkg-descr
@@ -0,0 +1,7 @@
+This is a thin wrapper around the shellwords.pl package, which comes
+preinstalled with Perl. This module imports a single subroutine,
+shellwords(). The shellwords() routine parses lines of text and
+returns a set of tokens using the same rules that the Unix shell does
+for its command-line arguments. Tokens are separated by whitespace,
+and can be delimited by single or double quotes. The module also
+respects backslash escapes.
diff --git a/textproc/p5-Text-Shellwords/pkg-plist b/textproc/p5-Text-Shellwords/pkg-plist
new file mode 100644
index 000000000000..9ad156872ac6
--- /dev/null
+++ b/textproc/p5-Text-Shellwords/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Text/Shellwords.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Shellwords/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Shellwords > /dev/null || true